Symantec Identity Management

Expand all | Collapse all

Identity Governance Client tools error "Provider cannot be found. It may not be properly installed" while connecting to Database

Jump to Best Answer
  • 1.  Identity Governance Client tools error "Provider cannot be found. It may not be properly installed" while connecting to Database

    Posted 09-06-2016 06:47 AM
      |   view attached

    Identity governance client tools throws the error "Provider cannot be found. It may not be properly installed" while connecting to MS SQL Server. As the governance server is also installed in the environment i am trying "Request SQL credentials from a server". however with not much success.

     

    Any suggestions please!? 



  • 2.  Re: Identity Governance Client tools error "Provider cannot be found. It may not be properly installed" while connecting to Database
    Best Answer

    Posted 09-06-2016 08:04 AM

    Hi,

     

    Have you installed "Microsoft SQL Native Client 2005" ? Take a look here :

     

    https://support.ca.com/cadocs/0/CA%20Identity%20Suite%2012%206%205-ENU/Bookshelf_Files/HTML/idocs/1064218.html

     

    regards, Roberto



  • 3.  Re: Identity Governance Client tools error "Provider cannot be found. It may not be properly installed" while connecting to Database

    Posted 09-06-2016 08:36 AM

    Does it have to be the SQLNCLI 2005? or should i install SQLNCLI 2012 as that is the version being used?

     

    I'm trying with SQLNCLI 2012 first to see if it works.



  • 4.  Re: Identity Governance Client tools error "Provider cannot be found. It may not be properly installed" while connecting to Database

    Posted 09-06-2016 08:44 AM

    You can try with SQLNCLI 2012, but as I remember it works only using SQLNCLI 2005.

     

    regards, Roberto



  • 5.  Re: Identity Governance Client tools error "Provider cannot be found. It may not be properly installed" while connecting to Database

    Posted 09-06-2016 10:33 AM

    I agree with Roberto. I think it only works with 2005 as this is the only version I gotten it to work with.



  • 6.  Re: Identity Governance Client tools error "Provider cannot be found. It may not be properly installed" while connecting to Database

    Posted 09-08-2016 03:02 AM

    I can now confirm it only Works with SQL Native Client 2005.

     

    Thanks Roberto and Andrew for your help!