Symantec IGA

Expand all | Collapse all

IDM 12.6.4cr2 (Or similar) with JBoss EAP 6.2 in a multi-node set up

  • 1.  IDM 12.6.4cr2 (Or similar) with JBoss EAP 6.2 in a multi-node set up

    Posted 03-12-2015 01:35 PM

    Has anyone configured IDM 12.6.4cr2 (Or similar) with JBoss EAP 6.2 in a multi-node set up?  I'm having trouble with my standalone-full-ha.xml configuration files on both nodes and would really love an example to jump off of.  I'm a fairly novice JBoss admin, and I'm confused about HornetQ configuration between two or more cluster nodes.  The redhat/jboss documentation is great, but after looking through the 350 page hornetq doc I think I'm more confused than when I started as there is so much information!

     

    I'm concerned that my JMS system isn't properly communicating messages between servers, but I have no idea how to verify my configurations properly.  I don't understand how to properly set up the paging/bindings/journal/messages directories for both nodes.  I would open a case with RedHat, but I don't even know what to ask.  I've switched from UDP to TCP in attempt to simplify configurations, but again, I'm concerned that the JMS system via HornetQ isn't right.

     

    For instance, one of the things I've seen is that if I point both nodes in my cluster to the same directory for the 4 directories, one node will start perfectly, but the second node will not deploy the IDM application until the first node shuts down.  If I point them to their own individual directories, they start, but I'm concerned that the messaging sharing between nodes isn't actually occurring.

     

    Please help!

     

    Thanks in advance,

    Dave



  • 2.  Re: IDM 12.6.4cr2 (Or similar) with JBoss EAP 6.2 in a multi-node set up

    Posted 03-19-2015 03:21 PM

    Anyone able to help with this?

     

    Thank you

     

    David Dixon wrote:

     

    Has anyone configured IDM 12.6.4cr2 (Or similar) with JBoss EAP 6.2 in a multi-node set up?  I'm having trouble with my standalone-full-ha.xml configuration files on both nodes and would really love an example to jump off of.  I'm a fairly novice JBoss admin, and I'm confused about HornetQ configuration between two or more cluster nodes.  The redhat/jboss documentation is great, but after looking through the 350 page hornetq doc I think I'm more confused than when I started as there is so much information!

     

    I'm concerned that my JMS system isn't properly communicating messages between servers, but I have no idea how to verify my configurations properly.  I don't understand how to properly set up the paging/bindings/journal/messages directories for both nodes.  I would open a case with RedHat, but I don't even know what to ask.  I've switched from UDP to TCP in attempt to simplify configurations, but again, I'm concerned that the JMS system via HornetQ isn't right.

     

    For instance, one of the things I've seen is that if I point both nodes in my cluster to the same directory for the 4 directories, one node will start perfectly, but the second node will not deploy the IDM application until the first node shuts down.  If I point them to their own individual directories, they start, but I'm concerned that the messaging sharing between nodes isn't actually occurring.

     

    Please help!

     

    Thanks in advance,

    Dave



  • 3.  Re: IDM 12.6.4cr2 (Or similar) with JBoss EAP 6.2 in a multi-node set up

    Posted 03-20-2015 02:51 PM

    Nothing yet, but I have an open case with support and I believe they are currently working with sustaining to obtain some information on this.

     

    Thanks,

    Dave