DX NetOps

CAPCIPDomain search options not working

  • 1.  CAPCIPDomain search options not working

    Posted 02-22-2019 10:37 PM

    Hi all,

     

    This question may be more suited to the CA PM community, but I guess I'll try here first as the issue is with Spectrum.

     

    As part of the Spectrum Integration with CAPC, a CAPCIPDomain Global Collection was created on Spectrum.

    To control what items are synchronized to CAPC, I have tried to add Search Options to the Global Collection. This does not seem to work correctly as the GC does not recognize the search expression properly.

     

    For example, a simple filter:

    These options should result in only active, non-pingable devices being displayed in the Global Collection. Instead, what I get are devices of all conditions, of a non-pingable type.

    In contrast, If I run a Locator Search, with exactly the same options, I get the correct results.

     

    Note, this is a basic example. I do plan to use more advanced filters, like excluding certain device Types. Attempts to try this with the CAPCIPDomain have failed.

     

    If I manually create a standard Global Collection, with the above example filter, it works correctly. So it appears that only the CAPCIPDomain type of Global Collection is affected by this issue.

     

    One final point - issuing a GET to the REST interface for Global Collections does not return results for CAPCIPDomain collections - only standard GCs. So I can't modify it that way either. 

    EDIT: Issuing a GET to the Model_Handle for the CAPCIPDomain for the DynamicCriteriaXML attribute returns the search options that I specified initially. Which would indicate that the options are applied correctly, just ignored.

     

    Any help would be greatly appreciated.

     

    Regards,

    Michael.