DX NetOps

Expand all | Collapse all

Report Manager event processing failed!

Jump to Best Answer
  • 1.  Report Manager event processing failed!

    Posted 06-05-2018 06:34 PM

    Hi all,

     

    Please your help, I have  this alarm active in spectrum:

     

    You are being notified of 1 alarm(s).

    Severity : Critical
    Date/Time : 13-05-2018 0:04:35 CLT
    Name : SRM_Application-spectrum-oc01
    Network Address :
    Secure Domain :
    Type : SRMApplication
    Acknowledged : No
    Alarm Title : Report Manager event processing failed!
    Landscape : spectrum-ss (0x1000000)
    Event : Report Manager has encountered an error while processing events. Please refer to the OneClick log file for more details.

     

    I checked the stdout and found the following error:

     

    May 13, 2018 00:04:34.367 (SRM/EventPoller/spectrum-ss) (SRM_Events) - (ERROR) - Failed to insert event into event table. SQL Exception code: 1406 SQL Exception message: Data truncation: Data too long for column 'event_msg' at row 1 Last known event time = 1523874620000
    May 13, 2018 00:04:34.367 (SRM/EventPoller/spectrum-ss) (SRM_Events) - (ERROR) - event record (mh=0x1001a78, type=0x6330076, time=2018-04-16 07:30:20.0)
    May 13, 2018 00:04:34.367 (SRM/EventPoller/spectrum-ss) (SRM_Events) - (INFO) - Stopping event polling (Domain: spectrum-ss)

     

     

    How can I revolve this error and why ocurred?

     

    Also, this error can cause problem with alarm reports of jaspersoft? I'm trying to run an alarm report and appear "No record found" 

     

    I appreciate your comments!

     

    Greetings!

     

    EOS



  • 2.  Re: Report Manager event processing failed!
    Best Answer

    Posted 06-05-2018 07:33 PM

    Looks similar to the errors in the below tech doc , please check if this helps 

     

    CA Spectrum Report Manager fails to insert event i - CA Knowledge 

     

    Both the Jasper and the old BOXI access the same reporting database for reports , so yes, if there is a problem with data in the reporting db you would not be able to run the reports from either of the consoles 



  • 3.  Re: Report Manager event processing failed!

    Posted 06-05-2018 07:36 PM


  • 4.  Re: Report Manager event processing failed!

    Posted 06-07-2018 10:47 AM

    Thank you Phani.Devulapalli and sirha02 for your responses.

     

    I was able to resolve the SRM alarm modifying the event_msg table length to mediumtext, once applied that and restarted the tomcat the alarm was gone.

     

    Now the SRM application looks normal but I'm still have the message "No record found" when I run an alarm report from Jaspersoft.

    I cheked the integration between both and look good, I am able to run others reports such as the Availability.

     

    Have a good day!

     

    EOS



  • 5.  Re: Report Manager event processing failed!

    Posted 06-11-2018 08:42 PM

    May be the event data which you are trying to run the report against is still not synchronised to the reporting database as you had issues with reporting DB. Take a look at the Archive Expert or Spectrum Status under Administration-->Report Manager in the Web Console , it should be be up to date . In case its still trying to sync the event data, wait until the sync finishes and try to rerun the report 



  • 6.  Re: Report Manager event processing failed!

    Posted 06-13-2018 10:21 AM

    Phani.Devulapalli indeed was that. The event data was not synchronized completely when I tried run the alarms report. I noticed that the "Last Event Time" on Spectrum Status at the Report Manager web page had a old date then hours later was up to date and I was able to run the reports again.

     

    kind regards

    EOS