DX NetOps

Expand all | Collapse all

AlarmNotifier and IPv6

  • 1.  AlarmNotifier and IPv6

    Posted 05-24-2017 04:47 AM

    Hi folks,

     

    we just ran into a strange problem in our test environment (Spectrum 10.2.1 / CentOS 6.9):

     

    When attempting to start AlarmNotifier, it failed saying that it could not connect to port 0xbeef, although the SpectroSERVER process was running:

     

    [spectrum@spe2-vm Notifier]$ ./AlarmNotifier

     

    AlarmNotifier 10.2.1.000
    Multiple Landscapes Mode
    SPECTRUM Alarm Notification Manager Enabled

     

    CA Technologies
    One CA Plaza
    Islandia, NY  11749 USA
    Copyright 2017 CA Technologies All Rights Reserved

     


    AlarmNotifier: Warning: 10:01:09 05/24/17 - Landscape on spe2-vm: failed to connect, not listening on port 0xbeef.  Check that the server is started and ready.


    AlarmNotifier: 10:01:29 05/24/17 - Error: Landscape 0x1000000: Connection lost

     

    After some investigation, it turned out that the AlarmNotifier tried to connect to the port via IPv6:

     

    [spectrum@spe2-vm Notifier]$ telnet spe2-vm 48879
    Trying 2001:db8::98:134...
    telnet: connect to address 2001:db8::98:134: Connection refused
    Trying 192.168.98.134...
    Connected to spe2-vm.

     

    I have the following entries in /etc/hosts:

     

    [spectrum@spe2-vm Notifier]$ grep spe2-vm /etc/hosts
    2001:db8::98:134 spe2-vm
    192.168.98.134   spe2-vm

     

    When I remove the IPv6 entry or change the associated hostname, AlarmNotifier works. Has anybody been facing the same issue and could convince the AlarmNotifier to fall back to IPv4?

     

    Ideally, the SpectroSERVER process would just be listening on IPv6 as well...

     

    [spectrum@spe2-vm Notifier]$ netstat -an | grep 48879
    tcp        0      0 0.0.0.0:48879               0.0.0.0:*                   LISTEN

     

    As far as I know, this was not possible because of some Visibroker libraries, but this iformation is also a couple years old.

     

    Regards

    Maik



  • 2.  Re: AlarmNotifier and IPv6

    Posted 12-06-2017 04:37 AM

    Hi Maik,

     

    Am sorry the post is quite old but wanted to check if you were able to find the cause of the issue here. If not, you could open ticket with CA Support for this.

     

    You could try enabling the debug in the $SPECROOT/Notifier/.alarmrc file adding the following parameter:

    DEBUG_GAS=TRUE
    ctrace=true
    strace=true

     

    Restart the AlarmNotifier for the changes to take effect.

     

    Recreate the issue and send us the files via creating a support case for further review:

    $SPECROOT/Notifier/Notifier.OUT file,
    $SPECROOT/Notifier/notifier_debug.out and the
    $SPECROOT/lib/SDPM/processd_log file

     

    Thanks,