DX NetOps

  • 1.  HTTP tests when site runs json

    Posted 08-09-2016 04:01 AM

    Hi, I'm trying to run HTTP test on CA Spectrum SPM and the site should give answer TRUE. When I access site using FF browser everything is OK but if I try to do the same with IE the browser offers me to download filename.json file.

    How to run HTTP tests for this type sites?

     

     

    Adrijus



  • 2.  Re: HTTP tests when site runs json
    Best Answer

    Broadcom Employee
    Posted 08-09-2016 11:51 AM

    Hi Adrijus, I did some looking around and this appears to be a known Internet Explorer issue.

    Check out this link - jquery - How can I convince IE to simply display application/json rather than offer to download it? - Stack Overflow

     

    Hope that helps!



  • 3.  Re: HTTP tests when site runs json

    Posted 08-10-2016 02:42 AM

    Thank you, now IE shows correct respond answer. however,  SPM HTTP test still fail (SPM test timeout).



  • 4.  Re: HTTP tests when site runs json

    Broadcom Employee
    Posted 08-10-2016 08:21 AM

    Does it timeout on Chrome also? If it's working on one browser and not the other, it must be caused by an IE setting.

    If you are seeing the same behavior on both, I'd post another question here, focusing on the SPM test.

    That would allow Spectrum-experts to more easily see and respond to this!



  • 5.  Re: HTTP tests when site runs json

    Posted 08-11-2016 04:37 AM

    Now it work. I make some changes in registry as was recommended and now it works in all browsers. The reason why SMP tests fails was latency respond time - it is >10000 ms. But this is the problem on site side, not SPM.

     

    Thank you for your help!