DX NetOps

 View Only

Spec KB: Persistent and Stale Alarms Spectrum Alarms in UIM, after CA Spectrum to CA UIM Alarm Synchronization

  • 1.  Spec KB: Persistent and Stale Alarms Spectrum Alarms in UIM, after CA Spectrum to CA UIM Alarm Synchronization

    Posted Apr 06, 2017 12:01 PM

    Document ID:  TEC1158401

    Show Technical Document Details

    Symptoms:

    Tickets are not created in CA UIM for alarms without a Troubleshooter ID assigned to the alarm.


    In a CA Spectrum-CA UIM bidirectional integrated setup, alarms synced from CA Spectrum to CA UIM using the spectrumgtw probe are added to the queue, unassigned, and turn
    stale/persistent.


    This is because, CA Spectrum doesn’t auto-assign Troubleshooters/Troubleshooting ID to alarms.

    Cause:

    Product: CA Spectrum (CA Spectrum 10.1.2 and CA UIM 8.47 integration using spectrumgtw)
    Release: r10.1.2
    Components:
    AlarmNotifier SetScript
    updatealarm utility 

    Workaround:

    Workaround:
    If Spectrum operator or SANM policy assigns an alarm to a user, the Spectrum gateway passes the assigned user with the synchronized alarm to UIM, then the user name assignment is retained by CA UIM.SANM supports the automatic assignment of a troubleshooter with the AlarmNotifier SetScript by using updatealarm Utility.
    To update model troubleshooter attributes of the alarm, set the value of the Troubleshooter attribute (ID 0x11f57) of the alarm with the Troubleshooter,
    The command has the following format:

    ./updatealarm $MHANDLE $AID (Troubleshooterattribute ID)/(0x11f57) $NOTIFDATA

    MHANDLE (ModelHandle)          

    Specifies the handle of the model for which the alarm has been generated.

    AID (AlarmID)

    Specifies the numeric identifier that CA Spectrum assigned to the alarm

    TROUBLESHOOTER ATTRIBUTE ID

    Default / assigned troubleshooter attribute of the alarm; Attribute value= 0x11f57

    NOTIFDATA: NotificationData
    Lists notification data entries (names of persons) that SANM passes to an instance of AlarmNotifier that is associated with that policy. The entries are specified in the filters in an SANM policy. AlarmNotifier scripts can be configured to initiate email notifications to those persons in the notification data entries.

    Additional Information:

    More information:
    SANM-Enabled Script Parameters
    Update Model and model attributes