DX NetOps

Expand all | Collapse all

ProcessD is refusing to starting up

  • 1.  ProcessD is refusing to starting up

    Posted 11-05-2015 07:48 AM

    Hi all,

    The ProcessD on the server is refusing to start up. The only Spectrum processes running are Remote Admin and Tomcat.

    The ProcessD log file says that it cannot authenticate the user.

    I tried using the ProcessD --install command, with no luck. All I get is an error message stating Unable to Authentcate user. with service refused to be installed

    this is the last action that I've tried:

    I have logged onto the Spectrum server with the user.

    There were two passwords (Server Password and Spectrum password, same user), I have changed the Server password to the last know Spectrum password for that spectrum user.

    I rebooted the server

    Logged in again and ran the ProcessD --install command again. The "--remove" command will not work as ProcessD is still down.

    I received the following error message

    SpectrumUser-05.JPG

    This is the correct local user and password.

    Any ideas??



  • 2.  Re: ProcessD is refusing to starting up

    Broadcom Employee
    Posted 11-05-2015 08:21 AM

    Hi Kurt,

    Looks like you are in a bash shell.  Use a cmd window instead, since you are configuring a windows service.

     

    The processd owner really should be the Spectrum install owner.  It doesn’t NEED to be, but it should be.  Either way, if the username you specify is local, then you only need the username and password (like you have in the screenshot).  If that user is a domain user, make sure you specify the domain as part of the –username entry.  Also, make sure that the user you install processd with is part of the Spectrum Users Group.

     

    HTH

    Jay



  • 3.  Re: ProcessD is refusing to starting up

    Posted 11-05-2015 09:05 AM

    Hi Jason,

     

    Thanks for the input, but that didn't work either.

    The user is local on the box, and was the spectrum owner, but has left the company.

    I have the feeling that the client has removed the user from the Spectrum User group.

    SpectrumUser-06.JPG



  • 4.  Re: ProcessD is refusing to starting up

    Broadcom Employee
    Posted 11-06-2015 05:24 AM

    Hello Kurt,

     

    please check for the "current" CA Spectrum Processd service under the Windows Services panel - and the assigned account. By default the Spectrum installation will create the "processd" to run under "Local System Account". We saw the "update" problems when the assigned account is per permission in conflict to the "account" which is used to run the "processd --install" ..

    For one issue/support-case we were unable to resolve the problem at all - but we then did an install again over the existing install - applying the same servicepack/hotfix pack again. This then did "refresh" all the install and resolved the issue.

    From $SPECROOT/Install-Tools/.history you will find the most recent applied Hotfixpack - just reapply this again - by using the same account for running the installation - and the same "spectrum installartion owner" (see $SPECROOT/Install-Tools/LOGS -- here find the first release entriy - i.e. the R9.4.0 install - and inside this find the "hostargs" file - covering all installation details.

     

    hth, cheers, Joerg