DX NetOps

Expand all | Collapse all

JasperReports integration with OneClick fails

Jump to Best Answer
  • 1.  JasperReports integration with OneClick fails

    Posted 08-19-2016 02:01 PM

    Hi everyone,

     

    We've recently upgraded Spectrum to the last version (10.1.1) and we've installed JasperReports (BOXI 6.1).

     

    However, we can't find any OOTB Spectrum reports, despite the integration steps we did (including in OneClick). We already tried to redeploy the reports, but the page loads without ending and nothing happens.

     

    We noted that all users from Spectrum were been created in JasperReports.

     

    Did anyone experience this problem before? Any ideas?

     

    Thanks,

     

    Diogo



  • 2.  Re: JasperReports integration with OneClick fails

    Broadcom Employee
    Posted 08-22-2016 08:32 AM

    Hi Diogo,

     

    What user you are using to integrate?

     

    Are you able to logon to below url

     

    http://{Jaspersoft-server}:{port}/jasperserver-pro/login.html?error=1

     

    if you are able to login

    click on domains and check whether you see spectrum domain there or not.

     

    Regards

    Sunny



  • 3.  Re: JasperReports integration with OneClick fails

    Posted 08-22-2016 09:17 AM

    Hi Sunny.chv,

     

    I'm using the "superuser" user in OneClick.

     

    Yes, I'm able to login using superuser, but I'm not seeing Spectrum Domain. Just the default ones:

     

     

    Thanks,

     

    Diogo



  • 4.  Re: JasperReports integration with OneClick fails

    Broadcom Employee
    Posted 08-22-2016 03:02 PM

    Hi Diogo,

    One thing you can try is to open the OneClick Web Page and select Administration -> Report Manager -> Jasper Integration then click the Re_deploy option under the Re_deploy section of the page. Once it completes, please check to see if the reports have deployed correctly.

     

    Best regards,

     

    Bill



  • 5.  Re: JasperReports integration with OneClick fails
    Best Answer

    Posted 09-14-2016 01:13 PM

    Hi Bill,

     

    We were able to integrate and view OOTB Spectrum Reports. We had to reinstall Jasper though.

     

    Thanks,

     

    Diogo



  • 6.  Re: JasperReports integration with OneClick fails

    Broadcom Employee
    Posted 09-01-2016 07:16 AM

    Hi Diogo,

     

    Please check the Tomcat log file (C:\Tomcat8\catalina.yyyy-mm-dd.log). It might help you to understand why when you click on the Jasper integration "Save" and/or "Re-deploy" buttons, the request never finishes: 

    Processing your request, please wait......

     

    Thanks,

    Silvio