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  • 1.  Include root cause of an service alarm in email

    Posted Jun 07, 2016 09:35 AM

    Hi everyone,

     

    The Alarm Notifier can include the root cause of an service alarm? In this case, the root cause are other alarms.

    Is it possible include detailed information of these alarms in email? This information is available in "root cause" tab of Oneclick.

     

    Thank you.

     

    Follow example of desired scenario:

     

    ============================================================

     

    Alarm Notification from SPECTRUM

     

    Alarm SET:

     

    Date: 06/06/2016

    Time: 16:28:52

    DeviceType: N/A

    Mtype: SM_Service

    ModelName: Service_Example

    AlarmID: 3575940

    Severity: CRITICAL

    ProbableCauseID: 4500006

    RepairPerson:   

    AlarmStatus:     

    SpectroSERVER: spectrum01

    Landscape: 0x100000

    ModelHandle: 0x107400

    ModelTypeHandle: 0x1046f

    IPAddress:      

    SecurityString: 

    AlarmState: NEW

    Acknowledged: FALSE

    UserClearable: TRUE

    Location:       

    AlarmAge:         0

    NotificationData: myemail@abc.com

     

    ProbableCause: SERVICE IS DOWN

     

    SYMPTOMS:

     

    SPECTRUM has detected a change in one or more of the resource models associated with this service that indicates this service is down, according to the established "resource monitoring rules".

     

    PROBABLE CAUSES:

     

    1) An infrastructure component that is responsible for delivering this service has been compromised.

     

    RECOMMENDED ACTIONS:

     

    1) Find the compromised resources affecting this service, and expedite their repair.

    2) If the service appears to be operating correctly, review the "resource monitor rules" to verify they are correct.

     

     

    EventMessage: seg 06 jun, 2016 - 16:28:52 - This service is down. (event [0x04500006])

     

    Root Cause:

     

    ------- Alarm # 1 ----------------------------------------

                 Alarm URL : http://xxxxxxx/spectrum/oneclick.jnlp?alarm=5755deb7-1fd0-1000-026b-005056be6849

                  Severity : Critical

                 Date/Time : Jun 6, 2016 5:36:07 PM BRT

                      Name : pe-prod-31.tjrs.gov.br

           Network Address : 10.1.1.1

             Secure Domain : Directly Managed

                      Type : IP Device

              Acknowledged : No

               Alarm Title : URL response for 'server1.aaa.gov.br' failed. 7 Couldn't connect to server

                 Landscape : spectrum01 (0x100000)

                     Event : Mon 06 Jun, 2016 - 17:36:07 - NIMSOFT SNMP GATEWAY

                             Critical Alarm generated with the following details:

                             ----------------------------------------------------------------

                             URL response for 'server1.aaa.gov.br' failed. 7 Couldn't connect to server

                             Source: nimsoft02

                             IP/HostName: server1.aaa.gov.br

                             Level: Critical

                             Suppression Key: URLResp/pserver1.aaa.gov.br/httpError

                             Subsystem: NMS.Alarm.Application

                             Probe ID: url_response

                             Origin: NMS_BBB

                             Arrival Time (s): 1465245230

                             NIM-ID: ZS00643632-95216

                             Domain: Nimsoft-BBB-dom

                             ================================================================

                             Spectrum Event ID: 0x06330003

     

    ============================================================

     

    ------- Alarm # 2 ----------------------------------------

    ....

    ------- Alarm # 3 ----------------------------------------

    ....



  • 2.  Re: Include root cause of an service alarm in email

    Posted Jun 10, 2016 06:54 AM

    I took a quick look. I am not seeing how to do this.



  • 3.  Re: Include root cause of an service alarm in email

    Posted Jun 10, 2016 08:08 AM

    Even, we are looking for this. Whenever, we have a service alarm, the teams are unable to identify the resources/root cause alarms in notification. They are always relying on Spectrum admins to identify the alarms and resources.

     

    Regards,

    Rajashekar



  • 4.  Re: Include root cause of an service alarm in email

    Posted Jun 10, 2016 08:36 AM

    Hello,

     

    So we don't have Spectrum integrated with UIM, however there are some indirect options available.

     

    For instance in the IM console, you could add a 'note' to incoming alarms or create an "url action" item in USM for those alarms that link the specific alarm to a solution or to a root cause document (web-doc).

     

    Additionally I think you could use the pre-processing rule or AO rules to add notes and additional content from messages. Hope this helps.

     

    A



  • 5.  Re: Include root cause of an service alarm in email
    Best Answer

    Broadcom Employee
    Posted Sep 16, 2016 11:17 AM

    I haven't tested but I believe you can get a list of symptom/root alarm ids by enabling this section in the <SPECROOT>/Notifier/SetScript - 

     


    # If you wish to see correlation related information, you need to set
    # ENABLE_CORRELATION to "true" and SHOW_SYMPTOM_ALARMS to "true" in
    # the configuration file.
    if [ "$SYMPTOM_ALARM_LIST" ]
    then
    echo "CorrelationAlarmType: " CAUSE
    echo "SYMPTOMGlobalAlarmIDList: " $SYMPTOM_ALARM_LIST
    fi

    if [ "$CAUSE_ALARM_LIST" ]
    then
    echo "CorrelationAlarmType: " SYMPTOM
    echo "CAUSEGlobalAlarmIDList: " $CAUSE_ALARM_LIST
    fi