DX NetOps Manager

Expand all | Collapse all

Tech Tip: Key points while installing CABI 4.1

  • 1.  Tech Tip: Key points while installing CABI 4.1

    Posted 10-29-2015 08:34 AM

    Tech Tip: Key points while installing CABI 4.1


    CA Spectrum Tech Tip by Bill Wolforth, Sr Support Engineer for October 29, 2015


    Key points while installing CABI 4.1

     

    1.      Memory (RAM) should not be less than 16 GB and HDD space should not be less than 20 GB.
    2.      If installing on Linux, check the prerequisite packages, version numbers should be equal to the mentioned ones at: https://wiki.ca.com/display/CABI41SP3/Hardware+and+Software+Requirements+for+Installation+on+Linux
    3.      Before starting the installation of CABI make sure you have copied the CABI DVD/ISO to any local folder where the user has full permissions to it
    4.      Once the installation is done, login into the CMC app and check the Servers -> Servers List and make sure all the servers are running fine. If any servers are not running it means there is a package and/or version problem.
    5.      Now run the PostInstallation utility from utilities/PostInstall folder (you can omit the errors if any unless you see some functional effect while using CABI)
    6.      Once post installation is done, make sure all the servers are running fine once again


  • 2.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 10-29-2015 01:06 PM

    Bill, what happens if my OOTB RHEL installation (6.7) has packages that are on a newer version that the ones mentioned on your link? It's my problem to have the system at the specified patchlevel? Resolve all the dependencies between packages and then start the installation of CABI on the machine?



  • 3.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 10-29-2015 03:43 PM

    Yes, that's correct. If your RHEL packages are newer than the ones specified in the documentation you could run into issues like this one:

    An error occurred while creating a subprocess in the processing server. [RCIRAS0603]

    Document ID: TEC1388328

     

    Hope this helps.

     

    Best regards,

     

    Bill



  • 4.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 11-05-2015 01:18 AM

    How to fix this error Bill? I am getting error to run any reports in CABI. When i am clicking on prompt it is showing that error.



  • 5.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-05-2015 04:22 PM

    Just downgrade your Libx by using following command :

    yum -y downgrade libX{11,11-common,11-devel,cursor,ext,ext-devel}



  • 6.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-06-2015 11:10 PM

    Thanks. We have RHEL 6.6 version and all are having the base package. We can’t downgrade those packages as  those are base ones. Could you please share the version of the listed packages on which Spectrum CABI 4.1 SP3 works I will try to manually compile those packages from RPM site.

     

    # rpm -qa | grep libX11

    libX11-devel-1.6.0-2.2.el6.x86_64

    libX11-1.6.0-2.2.el6.x86_64

    libX11-common-1.6.0-2.2.el6.noarch

    libX11-1.6.0-2.2.el6.i686

    #

     

    # rpm -qa | grep libXcursor

    libXcursor-1.1.14-2.1.el6.x86_64

    #

     

    # rpm -qa | grep libXext

    libXext-1.3.2-2.1.el6.x86_64

    libXext-1.3.2-2.1.el6.i686

    libXext-devel-1.3.2-2.1.el6.x86_64

    libXext-devel-1.3.2-2.1.el6.i686

    #

     

     

    Thanks & Regards,

     

    Md Mukul Hasan |Sr. Network Engineer |6767 – Corp IT India – HYD

    Email: mukulh@qti.qualcomm.com<mailto:mukulh@qti.qualcomm.com> | Cell: +91-9985836245 |Desk: +91-4030170331

    Desk No: 480A11|4th Floor|Building No: Maximus 2B|Raheja IT Park Mindspace|Hyderabad|India



  • 7.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 03:40 AM

    If your RHEL server is registered with Red Hat, you can use the command above specified:

     

    Just downgrade your Libx by using following command :

    yum downgrade -y libXext-1.1-3.el6.i686 libXext-1.1-3.el6.x86_64.

     

    It will resolve its dependencies automatically. You don't have to do anything, except identifying relations between packages.

    Before downgrading libX11-devel-1.6.0-2.2.el6.x86_64 you should downgrade libX11-1.6.0-2.2.el6.x86_64.



  • 8.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 03:44 AM

    Thanks. How many packages we need to downgrade and what are the useful version?

     

    Thanks & Regards,

     

    Md Mukul Hasan |Sr. Network Engineer |6767 – Corp IT India – HYD

    Email: mukulh@qti.qualcomm.com<mailto:mukulh@qti.qualcomm.com> | Cell: +91-9985836245 |Desk: +91-4030170331

    Desk No: 480A11|4th Floor|Building No: Maximus 2B|Raheja IT Park Mindspace|Hyderabad|India



  • 9.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 04:11 AM

    Get them here: https://docops.ca.com//display/CABI41SP3/Hardware+and+Software+Requirements+for+Installation+on+Linux.

    I'm struggling myself to get it working. I was planning to describe the entire process in a post or somewhere here, as I found out that there are several things that ar not mentioned anywhere in the documentation and can create problems with the Linux installations. I had several issues opened and still have some and I was working with support to get it working. I'm still don't have the WEBI reports running.



  • 10.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 04:31 AM

    Thanks. However you requested to downgrade almost 9 packages. However in your list it shows only 5 related to that. How about the below packages related to libX11 and libXcursor?

     

    # rpm -qa | grep libX11

    libX11-devel-1.6.0-2.2.el6.x86_64

    libX11-1.6.0-2.2.el6.x86_64

    libX11-common-1.6.0-2.2.el6.noarch

    libX11-1.6.0-2.2.el6.i686

    #

     

    # rpm -qa | grep libXcursor

    libXcursor-1.1.14-2.1.el6.x86_64

    #

     

     

     

    Prerequisites to Install CABI 4.1 SP3 on RHEL6

    The following packages are required to install CABI 4.1 SP3 on RHEL 6:

    ·         libXext-devel-1.1-3.el6.i686

    ·         libXext-devel-1.1-3.el6.x86_64

    ·         libXext-1.1-3.el6.i686

    ·         libXext-1.1-3.el6.x86_64

    ·         glibc-2.12-1.*.el6.i686

    ·         glibc-2.12-1.*.x86_64

    ·         libstdc++-4.4.*.el6.i686

    ·         libstdc++-4.4.*.x86_64

    ·         compat-libstdc++-33-3.2.*el6.i686

    ·         compat-libstdc++-33-3.2.*x86_64

    ·         libstdc++.so.6

    ·         libXext.so.6

     

     

    Thanks & Regards,

     

    Md Mukul Hasan |Sr. Network Engineer |6767 – Corp IT India – HYD

    Email: mukulh@qti.qualcomm.com<mailto:mukulh@qti.qualcomm.com> | Cell: +91-9985836245 |Desk: +91-4030170331

    Desk No: 480A11|4th Floor|Building No: Maximus 2B|Raheja IT Park Mindspace|Hyderabad|India



  • 11.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 05:29 AM

    libXcursor is not mandatory to have a certain version. Or at least, none that I know of. I did not see it mentioned anywhere in the prerequisites list.



  • 12.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 08:09 AM


  • 13.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-08-2015 06:21 AM

    Could you please share the registry repair script.

     

    Thanks & Regards,

     

    Md Mukul Hasan |Sr. Network Engineer |6767 – Corp IT India – HYD

    Email: mukulh@qti.qualcomm.com<mailto:mukulh@qti.qualcomm.com> | Cell: +91-9985836245 |Desk: +91-4030170331

    Desk No: 480A11|4th Floor|Building No: Maximus 2B|Raheja IT Park Mindspace|Hyderabad|India



  • 14.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 03:31 AM

    How I can downgrade the pkg as RHEL 6.6 has already base pkg installed?

     

    Thanks & Regards,

     

    Md Mukul Hasan |Sr. Network Engineer |6767 – Corp IT India – HYD

    Email: mukulh@qti.qualcomm.com<mailto:mukulh@qti.qualcomm.com> | Cell: +91-9985836245 |Desk: +91-4030170331

    Desk No: 480A11|4th Floor|Building No: Maximus 2B|Raheja IT Park Mindspace|Hyderabad|India



  • 15.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 09:25 AM

    Download the old rpm files and then just issue the 'yum downgrade <path_to_rpms>'.



  • 16.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 09:42 AM

    Thanks It is done now. However could you please share the registry repair script as one of the CABI server process shows failed. It is not starting any more.

     

    Thanks & Regards,

     

    Md Mukul Hasan |Sr. Network Engineer |6767 – Corp IT India – HYD

    Email: mukulh@qti.qualcomm.com<mailto:mukulh@qti.qualcomm.com> | Cell: +91-9985836245 |Desk: +91-4030170331

    Desk No: 480A11|4th Floor|Building No: Maximus 2B|Raheja IT Park Mindspace|Hyderabad|India



  • 17.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 11:00 AM

    Hi,

     

    I can run only crystal reports not the pdf. Could you please put some light here. ☺

     

    Thanks & Regards,

     

    Md Mukul Hasan |Sr. Network Engineer |6767 – Corp IT India – HYD

    Email: mukulh@qti.qualcomm.com<mailto:mukulh@qti.qualcomm.com> | Cell: +91-9985836245 |Desk: +91-4030170331

    Desk No: 480A11|4th Floor|Building No: Maximus 2B|Raheja IT Park Mindspace|Hyderabad|India



  • 18.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 03:18 PM

    I'm not sure what you call 'pdf reports', but my suggestion would be to open a new forum thread and ask your question there, this topic is had already drifted in comments from the original intent.



  • 19.  Re: Tech Tip: Key points while installing CABI 4.1

    Posted 12-07-2015 05:30 PM

    Hello,

     

    I've created a tiny note for CABI and Spectrum integration, it's running fine in my server.

     

    CABI 4.1 SP3 - Spectrum 10 Integration notes for Linux RHEL 6.x

     

    Hope that can be helpful.

     

    Regards