DX NetOps

Expand all | Collapse all

Needs Tomcat with Spectrum 9.4.2.1 more time to be  available after a restart?

Jump to Best Answer
  • 1.  Needs Tomcat with Spectrum 9.4.2.1 more time to be  available after a restart?

    Posted 05-04-2015 07:07 AM

    After the update to v. 9.4.2.1 needs Tomcat after a (Tomcat) restart about 5 minutes, until a user can login.

    With 9.2.3 it only took about 2 minutes.

     

    I want to know: Is this a general effect of this version.



  • 2.  Re: Needs Tomcat with Spectrum 9.4.2.1 more time to be  available after a restart?

    Posted 05-04-2015 08:26 AM

    Elliger,

     

    stdout.log can give you more info on the intial tasks performed after recycling tomcat. May be srm initialize took more time?



  • 3.  Re: Needs Tomcat with Spectrum 9.4.2.1 more time to be  available after a restart?

    Posted 05-05-2015 02:12 AM

    Thank you, Kalyan,

    I will check the stdout.log and will compare it with an older version.

    At the moment I can only say that SRM is innocent. We don't use it.

     

    Regards, Frank




  • 4.  Re: Needs Tomcat with Spectrum 9.4.2.1 more time to be  available after a restart?
    Best Answer

    Posted 05-04-2015 10:56 AM

    Hi Frank,

     

    If you have not done so already you can remove the compiler entry from tomcat's startup configuration. This will improve startup time and performance

      with Spectrum 9.3.x and 9.4.x

     

     

    1.  Windows

            Modify $SPECROOT/tomcat/bin/OneClickService.conf

                Remove the compiler entry

                  -Djava.compiler=NONE

     

        Linux

            Modify $SPECROOT/tomcat/bin/catalina.sh

               Look for the JAVA_OPTS= line and remove the compiler entry

                -Djava.compiler=NONE

     

     

    2. Modify $SPECROOT/custom/common/config/tomcat-server-config.xml

     

    * Note: this file does not need to exist. It is created when you save tomcat settings from the OneClick Web

    interface and is meant to save settings so they persist across upgrades. So if this does not exist then nothing needs to be done.

     

      Remove the compiler entry

        <param>java.compiler=NONE</param>

     

     

    3. Restart tomcat

     

     

    There also might be the possibility that tomcat needs more memory (depending on the size of your environment and event rate). There also is an

      option of enabling 64bit tomcat and increasing tomcat's memory to 2048

     

    Greg



  • 5.  Re: Needs Tomcat with Spectrum 9.4.2.1 more time to be  available after a restart?

    Posted 05-05-2015 02:35 AM

    Hi Greg,

     

    I think, that's it, thank you!

    Before  this changes:     INFO: Server startup in 279010 ms

    After this changes:        INFO: Server startup in 55934 ms

    (Found in stdout.log, thank you also, Kalyan!)

    I've tried it earlier, but I have changed only the catalina.bat (under  Windows). That was not enough.

    I know,  the Compiler  Option is a very old relict. Maybe, it would be helpful for all others, if you would post it as an Tech Tip.

     

    Regards, Frank




  • 6.  Re: Needs Tomcat with Spectrum 9.4.2.1 more time to be  available after a restart?

    Broadcom Employee
    Posted 07-13-2015 09:32 AM

    Hi Frank,

     

    while hosted on Linux the setting for the "Java.Compiler=none" is set in the ./tomcat/bin/catalina.sh - the Windows implementation uses "OneClickService.conf". This is also a text native file and you can use any editor to remove this line. Please allow me to create one more entry for "running OC-server without option Java.Compiler=none". Which is a good recommendation right now.

     

    Note - once you edit the files manually, any subsequent reconfiguration of the OC-server via OC-weblogon (web-page) can re-introduce the default configuration file (as this is dynamically created each time of reconfiguration) covering the Java.Compiler=NONE entry again.  Cheers, Joerg



  • 7.  Re: Needs Tomcat with Spectrum 9.4.2.1 more time to be  available after a restart?

    Posted 07-14-2015 02:32 AM

    Thank  you, Joerg,

    I like your entry Run OneClick-Server without option "java.compiler=NONE" for R9.3+!

    Regards, Frank