Workload Automation1

Expand all | Collapse all

Alarm if fail: 0 - Still generates alarms

  • 1.  Alarm if fail: 0 - Still generates alarms

    Posted 08-09-2018 06:44 AM

    Hi All,

     

    I have a suite of jobs with all alarm_if_fail flags set to 0 however they are still generating alarms in the WCC alarms widget.

     

    Would anyone happen to have any ideas why they alerts are still generating?

     

    Thanks in advance!

     

    Cameron.



  • 2.  Re: Alarm if fail: 0 - Still generates alarms

    Posted 08-11-2018 09:55 PM

    Hi Cameron,

    What type of alarm is it? termination or change by any chance? In 11.3.6 SP7, you could use alarm_if_terminated to toggle JOBTERMINATED alarm.

     

    Cheers,

    Chandru 



  • 3.  Re: Alarm if fail: 0 - Still generates alarms

    Posted 08-17-2018 05:53 AM

    Hi Chandru,

     

    We have been looking into the alarm_if_terminated alarm that was added recently and I will be making a case to upgrade as we do have a few scenarios where we would like this to not alarm. In this case I think Michael's comment below has pointed me in the right direction. Thanks for commenting!

     

    Cameron.



  • 4.  Re: Alarm if fail: 0 - Still generates alarms

    Posted 08-16-2018 02:23 PM

    Hi,

     

    Check the Alert policy.  Is it based on an alarm or job status?  Both are options.

     

    Regards,

    Mike



  • 5.  Re: Alarm if fail: 0 - Still generates alarms

    Posted 08-17-2018 05:50 AM

    Hi Michael,

     

    Thanks for this, the policy is based on alarm type: jobfailure and job status: failure. I assume these two are conflicting and I have told WCC to alert on any job failure regardless of its alarm_if_fail definition?

     

    I will remove the job status selection from the alert policy and see how it works with only a alarm type defined.

     

    Cameron.