Workload Automation1

Expand all | Collapse all

How to check if SDK and CAPKI are on INCR2 version?

  • 1.  How to check if SDK and CAPKI are on INCR2 version?

    Posted 07-31-2018 03:21 AM

    Hi,

    We have an issue with wcc collector and I need to install 2 fix packs (ALL-WCC R11.3.5 INCREMENTAL 2 Fix #RO69436 & ALL-JOB STATUSES NOT UPDATED IN JOB FLOWS Fix #RO80618)

     

    RO69436 installation has a prerequisite of SDK and CAPKI being on INCR2.

     

    I am not sure how to check SDK and CAPKI are on INCR2.

     

    I am running following command but not sure if this output (11.3.5.408) means I am on INCR2.

    lsm -l -O pif

    +--------------------------------------------------------------------

    + TYPE   PRODUCT                        VERSION              PLATFORM

    +--------------------------------------------------------------------

    PIF      CACCS                          11.2.07341.0         Linux

    PIF      CACommonComponents             11.3.5.39            Linux

    PIF      CAWorkloadAutomationAE-SDK     11.3.5.408           Linux

    PIF      ca-cs-cci-cmp                  11.2.08100.0         Linux

    PIF      ca-cs-eem                      12.0.7.57            Linux

    PIF      ca-cs-utils-cmp                11.2.10057.0100      Linux

    PIF      ca-waae-jre-32                 1.6.0.33             Linux

    PIF      ca-waae-sockadapter            2.2.8.0              Linux

     

     

    So on WCC box as root I loaded sdk profile (/opt/CA/WorkloadAutomationAE/autosys/autosys_sdk.bash) and then I ran following command.

     

    autoflags -a

    546 LINUX UNK 11.3.5 INCR2 14ac8e1d cbylxdwcc1 cbylxdwcc1

     

    So I do believe we are on SDC INCR2 but I am not sure and I do not know in which version of CAPKI we are and how to check it.

     

    thanks

    José



  • 2.  Re: How to check if SDK and CAPKI are on INCR2 version?

    Posted 07-31-2018 04:06 AM

    `cat /opt/CA/SharedComponents/CAPKI/Linux/x86/32/.installdb`

    If the CurrentVersion and WAAE1135 show 4.3.0 or higher, then you have met the pre-requisite.

     

    How do I find which version of CAPKI is installed on a system?



  • 3.  Re: How to check if SDK and CAPKI are on INCR2 version?

    Posted 07-31-2018 04:44 AM

    thanks Chandru for your answer.

     

    I am getting.

    eiam 4.1.10
    ETRDIR 4.2.9
    iGateway 4.3.0
    CCC113 4.2.9
    WAAE1135 4.2.9
    SecureSocketAdapter 4.1.6

     

    So I can see I need to go first to INCR2 for CAPKI (ETRDIR).

    Is WAAE1135 showing the SDK version?

     

    thanks

    José



  • 4.  Re: How to check if SDK and CAPKI are on INCR2 version?

    Posted 07-31-2018 05:43 AM

    Hi José,

     

    You may apply the following fix to upgrade CAPKI:

     

    https<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>://<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>support.ca.com<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>/us/<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>download-center<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>/<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>solution-<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>detail.html<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>?<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>docid<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>=629399&<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>os<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>=ANY&<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>aparno<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>=RO82823<https://support.ca.com/us/download-center/solution-detail.html?docid=629399&os=ANY&aparno=RO82823>

     

    Backup $CASHCOMP/CAPKI directory before the upgrade so it can be restored, just in case...

     

    I believe you are already on WAAE 11.3.5 INCR2 ( as per autoflags).

     

    Thank you,

    Chandru

     

    Get Outlook for Android<https://aka.ms/ghei36>



  • 5.  Re: How to check if SDK and CAPKI are on INCR2 version?

    Posted 08-03-2018 05:59 AM

    Hi José,

    Have you managed to patch? Please mark the question answered if all is well.

     

    Thanks,

    Chandru



  • 6.  Re: How to check if SDK and CAPKI are on INCR2 version?

    Posted 08-03-2018 10:08 AM

    Hi Chandru,

     

    I need to raise a change and get the approval first to patch so I am afraid I still could not do it.

     

    I will be marking the question as answered as soon as I can patch it.

     

    Thanks

    José



  • 7.  Re: How to check if SDK and CAPKI are on INCR2 version?

    Posted 09-01-2018 10:35 PM

    @Jose Ramon Lopez, How are you going with this particular effort? Are you all set with the patch updates?