Symantec Privileged Access Management

Expand all | Collapse all

Upgrade PIM from 12.9 into 12.9 sp1

Jump to Best Answer
  • 1.  Upgrade PIM from 12.9 into 12.9 sp1

    Posted 11-12-2015 06:09 PM

    Hi

    when i try to upgrade my PIM 12.9 (running on RHL 6.5 ) into PIM 12.9 sp1 on same machine ,, after installing JDK 1.8 and exporting the new path of java, i ran the install_EntM.bin -i console (while all the PIM 12.9.0 running and jboss running too)

    i have received the following message:

     

    ===================

    Downgrade Notice

    ----------------

    This setup installs CA Privileged Identity Manager Enterprise Server version

    12.9.1.302. However, a newer version, 12.90.0.950, is already installed, and

    cannot be downgraded. Setup will now quit.

    =====================

     

    i repeat this again but with running the pimctl.sh stop command, so all the PIM services and  JBoss service stopped, same error message appears.

    how is that ? and how to correct this , it appear that the installer script identify PIM 12.9.0.950 to be higher than the new PIM 12.9.1.305 ?

     

    any idea what is going on ? and how to correct this ?

     

    thanks everyone



  • 2.  Re: Upgrade PIM from 12.9 into 12.9 sp1

    Posted 11-16-2015 02:12 PM

    Hello,

     

    I think this could be due to the fact we do not support an inplace upgrade of Enterprise Manager. You must do a migration upgrade.

     

    How to Migrate an Enterprise Management Server Deployment

     

    I will test and verify with our team that is this the case.

     

    Thanks,

     

    Aaron Armagost

    Principal Support Engineer, CA Privileged Identity Manager

     

     



  • 3.  Re: Upgrade PIM from 12.9 into 12.9 sp1

    Posted 11-17-2015 03:30 AM

    Hello,,

    that is killer that it does not support inline upgrade   ,,, although it was mentioned to be possible in the article upgrade ENTM (but it was removed after reporting couple missing parts ).

    please AaronArmagost  confirm on this



  • 4.  Re: Upgrade PIM from 12.9 into 12.9 sp1

    Posted 11-25-2015 03:14 AM

    Hello AaronArmagost

    have you tested this case ? and inline upgrade from PIM12.9 into 12.9 sp1

     

    thanks



  • 5.  Re: Upgrade PIM from 12.9 into 12.9 sp1
    Best Answer

    Broadcom Employee
    Posted 11-26-2015 05:01 AM

    Hi Abdel,

     

    Inline upgrade from R12.9 to R12.9SP1 is not supported, only a migration is possible.

     

    I did verify this by looking at the Product Documentation available at the Wiki.ca.com site

     

    Upgrading - CA Privileged Identity Manager - 12.9.01 - CA Technologies Documentation

     

    Under this section, look at

    How to Migrate an Enterprise Management Server Deployment

     

    This should give you a fair idea that we do not support an inplace upgrade from R12.9 to R12.9 SP1

     

    Do let us know if this does help.

     

    Also with respect to the message that you have shared, we would be working on this to make sure we have a proper message being displayed.

     

    Regards,

    Reatesh Sanghi.



  • 6.  Re: Upgrade PIM from 12.9 into 12.9 sp1

    Posted 11-26-2015 08:30 AM

    Thanks Reatesh for your reply

    I think the wrong article about the upgrade instructions make the confusion with me ,it was removed once i have reported the missing links in it.

    but don't you think it is hard to implement and hurt in the business wise , that CA PIM 12.9 sp1 cannot be in-place upgrade , while it is just service pack, not major version !!

    i already did the migrating process when moving from version 12.8 into 12.9, and it wasn't any easy task!! , but for the new feature (the proxy ssh and RDP) it worth the migration hard process ,, but now ..!

    i hope the development teams take that in consideration in the new releases of the product.

     

    thanks for your reply

    have a nice day