Clarity Client Automation

Expand all | Collapse all

caf setserveraddress command failed

Jump to Best Answer
  • 1.  caf setserveraddress command failed

    Posted 05-19-2015 08:49 AM

    Hi Everyone,

     

    I am getting below error on some machine after running caf setserveraddress command:

     

    Error: The specified operation has expired. The timeout is usually a client supplied value.

    Error: Failed to send a message to caf: . Possible reasons for this are:the host may not be contactable, caf may not be running or caf is too busy to reply. The command failed.

    Error: Initialization failed.

     

    The machines are missing from DSM Explorer console. I have also tried to reinstall the agent using Infrastructure wizard as well as munaul but that didn't worked as well.

     

     

    If anyone knows the solution, Please share.

     

    Regards,

    Mohd Wasique



  • 2.  Re: caf setserveraddress command failed

    Posted 05-19-2015 09:19 AM

    what is number of client and server? its possible your server have trouble for performance.

    in the logs files in agent you collect error, because is possible your agent was corrupt.

     

    please include printscreen for command

    caf setserveraddress

    caf status

    Folders and sub folders for

    C:\Program Files\CA\DSM\Agent



  • 3.  Re: caf setserveraddress command failed

    Posted 05-20-2015 05:16 AM
      |   view attached

    Hi Jonathan,

     

    Please find the required details and screenshot as below:

    Error.jpg

    Regards,

    Mohd Wasique

    Attachment(s)

    zip
    Agent.zip   14.45MB 1 version


  • 4.  Re: caf setserveraddress command failed

    Posted 06-15-2015 06:32 AM

    Hi

     

    Were you able to find the cause of the issue here. I agree with JY that it appears to be a cam problem.

    regards

    Rich



  • 5.  Re: caf setserveraddress command failed

    Posted 07-07-2015 11:32 AM

    Hi

     

    Have you made any progress on checking CAM?

     

    Rich



  • 6.  Re: caf setserveraddress command failed
    Best Answer

    Posted 06-06-2015 04:15 AM

    Hi Mohd Wasique,

     

    Maybe there is a CAM/CAF communication problem.

     

    Please try these commands on the agent and check if they work :

     

    camping ssname

    caf ping ssname

     

    If camping works but not caf ping then problem could be with the CAM fragment_size.

     

    To confirm this please try these commands :

     

    camping -s 8192 ssname

    camping -s 4096 ssname

    camping -s 2048 ssname

    camping -s 1024 ssname

     

    And check for which fragment_size it is working.

     

    If "camping -s 1024" is working but not "camping -s 2048" you could set the CAM fragment_size with :

     

    camconfig fragment_size=1024

    camsave explicit

     

     

    If camping does not work for every size then problem could be with UDP port 4104 (blocked by a firewall or router for example).

     

    Regards,

    Jean-Yves



  • 7.  Re: caf setserveraddress command failed

    Posted 06-15-2015 02:58 PM

    Hi

    I would also verify on the scalability server and Domain Manager that you are not seeing reverse proxy messages in the cam logs this can be corrected following technical document

    TEC539203

     

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec539203.aspx

     

    Hope this helps

    Joe



  • 8.  Re: caf setserveraddress command failed

    Posted 07-07-2015 11:45 AM

    Hi Wasique,

    Is the name of the scalability server the agent is depending to, correctly resolved into a valid IP address?

    Can you ping geamnwr1011p?

    Can you camping it?

    Can you try the following command and check if it works?

    caf setserveraddress <SSIPAddress>

    where <SSIPAddress> is the IP Address of computer geamnwr1011p.

     

    Please let us know on the results of these suggestions.

    Best regards,

    Jordi.




  • 9.  Re: caf setserveraddress command failed

    Posted 07-10-2015 05:42 AM

    Hi Wasique,

    Did any of the previous suggestions help?

    If 'caf setserveraddress' working now?

    If any of them helped, can you please mark the question as answered?

    Thanks in advance.

    Best regards,

    Jordi.



  • 10.  Re: caf setserveraddress command failed

    Posted 07-15-2015 05:29 AM

    HI Wasique

     

    We are keen to make sure this was resolved for you. Can you let us know if you need any further assistance on this and if it is resolved can you mark the correct answer or post the solution you used.

    Thanks

    Richard_Little