Automic Workload Automation

Expand all | Collapse all

AWA 12.1 Jobhänger und falscher Job-Status

  • 1.  AWA 12.1 Jobhänger und falscher Job-Status

    Posted 04-30-2019 09:09 AM

    Hallo zusammen,

     

    wieder mal neues aus unserer Fehlerküche. Vorab, es gibt dazu bereits Incidents, aber der Support ist aktuellandauernd ziemlich überlastet, weswegen ich die Punkte zusätzlich ins Forum stelle. Vielleicht kommt es ja jemandem von euch bekannt vor.

     

    Einmal haben wir regelmäßig Jobhänger. Ein Job wird gestartet, macht genau das was er soll und bleibt danach aktiv. Beenden nur mit "Status manuell modifizieren" möglich. Ist natürlich blöd, weil er ab da nicht wieder anläuft...

     

    Der zweite Fall trat bisher nur einmal auf, das war noch weniger schön. Job läuft ebenso ordnungsgemäß (RETCODE=00) und endet aber mit ENDED_NOT_OK. Rückgabewert danach war 724774449. Sowas ähnliches hatten wir hier schon an anderer Stelle im Zusammenhang mit ":REGISTER_VARIABLE". So auch in diesem Fall. Interessant die WP-Log-Einträge:

     

    WPsrv_log_031_04.txt:20190423/093919.915 - U00011007 Job 'JOBS.KW-B2C#4COM2B2C.OUTBOUND.KONTAKTE@PREPARE' (RunID '1118908261' / Workflow-Ru28') on Host 'UC4-1.PROD' ended abnormally (return code='4449'). Remote ID=22695

     

    Den Returncode '4449' konnte ich beim besten Willen noch nirgendwo entdecken. Vom Support gibt es frühestens kommende Woche Unterstützung. Das sind auch die letzten 4 Ziffern des Rückgabewertes "724774449". Mit den Zahlen davor kann ich nur leider ebensowenig anfangen.

     

    Wünsche allerseits einen schönen Feiertag.

    Viele Grüße

    Manfred



  • 2.  Re: AWA 12.1 Jobhänger und falscher Job-Status

    Posted 05-14-2019 05:07 AM

    Hallo Manfred,

    nur interessehalber, was genau meinst du damit ?

    Beenden nur mit "Status manuell modifizieren" möglich. Ist natürlich blöd, weil er ab da nicht wieder anläuft...

     

    Was läuft ab da nicht mehr an ?

    VG

    Christian



  • 3.  Re: AWA 12.1 Jobhänger und falscher Job-Status

    Posted 05-15-2019 01:28 AM

    Hallo Christian,

    da habe ich mich unklar ausgedrückt. Wenn der Status auf ("irgendwie beendet") gesetzt wird, laufen die Prozesse selbstverständlich wieder . Meistens passieren solche Dinge aber halt Abends oder am frühen Wochenende, sodass dann etliche Prozesse bis zur Entstörung nicht ausgeführt werden. Das hier ist ein Job, der alle 15 Minuten Telefoniedaten importiert und da staut sich dann über Nacht schon mal was auf...

    VG, Manfred



  • 4.  Re: AWA 12.1 Jobhänger und falscher Job-Status

    Posted 05-15-2019 01:35 AM

    Hier im Übrigen die Stellungnahme des Supports, falls das noch jemanden betrifft:

     

    "Unfortunately, without an agent trace (tcp=9) it's impossible to tell the root cause of this problem.

    We can have just a suspicion and it seems this is related to a bug which is fixed in following AE versions:

    Automation Engine 12.2.1 - planned release date: 2018-10-31

    Automation Engine 12.3.0 - planned release date: 2019-06-28

    Automation Engine 12.2.2 - planned release date: 2019-02-27

    It's a synchronization problem between CCM and MAIN thread in job messenger, actually it doesn't have any effect on agent core.

    1. Messenger MAIN thread initiate connection to agent.

    2. After handshake, MAIN waits for EXDATA message in ccm_receive_message() function. Due to agent replies EXDATA very fast, MAIN can grab this message without going idle, meaning 1 wakeup signal remains in wake-up queue.

    3. MAIN thread sends MELD message to agent and waits for QUITT again in ccm_receive_message() function.

    4. Because there is still a wakeup signal in CCM, ccm_receive_message() returns immediately with empty queue result and messenger shuts down before it could send MELD message.

     

    Therefore, we suggest upgrading your system to one of the versions mentioned above."

     

    Bei uns wird die Lösung damit leider noch etwas dauern. Da wir uns an unserem Release-Management orientieren müssen, kommt Stand heute ein Einsatz erst ab 12.3.1 in Frage.