Automic Workload Automation

Expand all | Collapse all

Problems with AutomationEngine ZDU-Upgrade 12.0.5 to 12.2.2 - Incompatible AWI-Version

  • 1.  Problems with AutomationEngine ZDU-Upgrade 12.0.5 to 12.2.2 - Incompatible AWI-Version

    Posted 05-23-2019 08:59 AM

    I'am upgrading a AE 12.0.5 system to AE 12.2.2 via ZDU. DB-Load was OK. I have two Automic-AE-Server and the second one is upgrades to an 12.2.2 und up and running as discribed in ZDU Step 2. The first one is remaining at Version 12.0.5.

    Now - in Step 3 of ZDU - I upgrade AWI from 12.0.5 to 12.2.2 successfully.

    But:

    I try to Login to the AE-System to finish ZDU-Upgrade and I get during Loginprocess following error:

    Incompatible AE version '12.0'. Expected: '12.2'

     

    Before I start this upgrade I ask CA, if it is possible to do such an upgrade with ZDU 12.0.5 to 12.2.2 and I get the answer yes.



  • 2.  RE: Problems with AutomationEngine ZDU-Upgrade 12.0.5 to 12.2.2 - Incompatible AWI-Version

    Posted 06-03-2019 08:48 AM
    Hi,

    generally, such an upgrade should be possible. I made test-upgrades from 12.0.x to 12.2.x myself.
    Some points you can check:
    1. Did you install the 12.2.2 AWI instead of the 12.0.5 or parallel. If parallel, do you go to the correct URL?
    2. Redeploy the AWI:
      1. Save the configuration-directory of you AWI.
      2. Stop Tomcat
      3. Remove the complete webapps/<AWI>-folder
      4. Start Tomcat
      5. Move the war-file to webapps. Wait till it is deployed, i.e. the AWI-folder is created an not changing its size anymore.
      6. Stop Tomcat again
      7. Move the configuration in place again
      8. Start Tomcat.
    3. If nothing helps, you should contact support. That wouldn't be the first bug in AWI.


    ------------------------------
    Software Engineer
    Erste Group IT
    Austria
    ------------------------------



  • 3.  RE: Problems with AutomationEngine ZDU-Upgrade 12.0.5 to 12.2.2 - Incompatible AWI-Version

    Posted 06-04-2019 03:18 AM

    The Problem is not how to update AWI ​but rather when. AWI12.2.2 can't connect to an 12.0.5-AE-Server, so you have to switch - with AWI12.0.5 -  aktive User and Processes  first to the new AE-Node. Then upgrade AWI to 12.2.2. That works.




  • 4.  RE: Problems with AutomationEngine ZDU-Upgrade 12.0.5 to 12.2.2 - Incompatible AWI-Version

    Posted 06-03-2019 08:48 AM

    I found a solution.

    Change the Steps in ZDU helps.
    Before you update AWI to new version, switch User to the now node which runs with the new Software.

    Then you are able to connect with AWI 12.2 and you can finish ZDU.