Automic Workload Automation

Expand all | Collapse all

host type not supported

  • 1.  host type not supported

    Posted 10-25-2018 09:14 PM
      |   view attached

    hello, I have setup a new agent on a new machine. The agent is running on top of solaris 5.11 O.S. I think i may have missed some of the configurations because the agent can't be authenticated by AE. When you try to start it manually a prompt would say that "host type not supported"  but when you go to the server where the agent is installed it is actually already running.

     

    hope you guys can help me on this.



  • 2.  Re: host type not supported

    Posted 10-26-2018 01:50 PM

    Could we see the agent log? This is probably going to end in opening a support case to have them verify the HTYP entry for that hardware/OS version



  • 3.  Re: host type not supported

    Posted 10-29-2018 02:54 AM



  • 4.  Re: host type not supported

    Posted 10-29-2018 02:55 AM

    the host is running on sparc64 machine and have installed agent for sparc64 as well...



  • 5.  Re: host type not supported

    Posted 10-29-2018 11:46 AM

    The fact that this particular install produce that message... the easiest way as Michael has stated is to look at that Agent log, it will tell you which host type... hw/os it showing/looking for... after that you can check if your has it listed as one of the supported (I assume, that what the Agent is looking for is not there).  If it not on the list, you would need to contact support and they will sent you a new file to be loaded into your system.

     

    If you can provide that agent logs here, I think Community can help find out what the agent is trying to look for (or you can try and take a look and see, in the Agent log what it shows).  Otherwise, if you feel that the logs have data that you don't want to share, I recommend opening up a ticket with support and they can help go through to determine what the Agent is looking for in term of the hw/os.



  • 6.  Re: host type not supported

    Posted 10-29-2018 09:58 PM

    hope this helps.

    Edit: Log are in attached file.

    Attachment(s)

    zip
    Agent_log.txt.zip   6K 1 version


  • 7.  Re: host type not supported

    Posted 10-31-2018 09:52 AM

    Hi Mier,

     

    As the error message in the system you have for the agent is the htyp you have is not supported.  

    the host is running on sparc64 machine and have installed agent for sparc64 as well...

    As you mention you have installed agent for sparc64 before.... I don't know if you have install those on this same machine, where this DLPBATCH is install or not.  I would assume those other agent are on a different machine than this?  If that is the case, it might have a slightly different HW/SW flavor then this machine.


    The log show this for the HW/SW 

    20181030/065436.513 - U02000020 Environment: Hardware = 'sun4v/32'.
    20181030/065436.514 - U02000021 Environment: Software = 'SunOS'.
    20181030/065436.515 - U02000022 Environment: SW version = '5.11'.

     

    The first and easiest  thing to confirm first is the htyp list and see if you have one for SunOS that listed version above in your htyp.  The UC_HTYP table will have the list of HW/SW available for your system.  If there isn't one for your the version above, then you will need to contact support and they can work to create a new htyp file for you to load into the database.

     

    Also as Wolfgang have commented below, you might want to check and see if you have any firewall/rules or other component that for the connection to disconnect after 5 minute.

     

    PS: I have put your logs file in a text file and attached to your comment, so that it will be easier/cleaner to view this thread.



  • 8.  Re: host type not supported

    Posted 11-04-2018 10:23 PM

    hi luu, this is what our htyp table looks like...would the asterisk mean on the column htyp_swvers and htyp_hw, any? if its yes then it should be fine.



  • 9.  Re: host type not supported

    Posted 11-05-2018 01:12 PM

    Yes, the * is a wildcard and mean that anything in that will count for the htyp_hw and htyp_swvers.  Out of curiosity, if you start the agent (without the use of the Service Manager), do you get the same error message, sometime similar or no issues?  This can also help rule out the SM as a factor.



  • 10.  Re: host type not supported

    Posted 10-26-2018 02:28 PM

    Client 0000 also holds an AGENT object for each one that retains static information about that agent.  Sometimes this AGENT object needs to be deleted prior to starting the agent, so that it can be automatically rebuilt with the new agent's details to flush out old agent details.  (These are stored in the HOST folder)

     

    I have no idea if this is the case here or not...



  • 11.  Re: host type not supported

    Posted 10-29-2018 02:53 AM

    yeah, i've already deleted it but still the same.



  • 12.  Re: host type not supported

    Posted 10-29-2018 05:28 AM

    Hi

     

    as Michael stated th Agent Log and SMGR log would be helpful to identify the issue.

     

    cheers, Wolfgang



  • 13.  Re: host type not supported

    Posted 10-30-2018 03:44 AM

    Hi

     

    thx for the logs.

     

    SMGR log looks fine.

     

    It seems that you have a network issue, the agent connects to AE and after 5 Minutes it gets disconnected.

    there is the multiple message:

     

    20181030/065437.681 - U02000073 Connection to system 'AUTOMIC' via CP Server 'AUTOMIC#CP003' successfully established.
    20181030/065437.898 - U02000066 Host information: Host name='batchserv', IP address='192.168.3.110'
    20181030/070013.830 - U02003044 Invalid 'read' call, socket 'AUTOMIC#CP003'. Error code: ('145' - 'Connection timed out')

     

    Do you have any firewall or networking components that disconnect auftera timeout of 5 Minutes?

    cheers, Wolfgang