Automic Workload Automation

Expand all | Collapse all

Some Tabs in the JOB templates (FTP,ZOS) are missing in ECC,AWI but same is visible in thickclient

Jump to Best Answer
  • 1.  Some Tabs in the JOB templates (FTP,ZOS) are missing in ECC,AWI but same is visible in thickclient

    Posted 10-27-2016 12:39 AM

    Some Tabs in the JOB templates (FTP,ZOS.. ) are missing in ECC,AWI but same is visible in thick client?

    We are planning to migrate our enterprise workload automation platform from $U to OneAutomation ( AWA,AE ) soon. Just to support my team, I have setup a temporary setup with AWA version 11.2 (with proper licence) and given to my team so that they can play with it and self-learn until a formal training.

    Everything seems working fine but see some discrepancies in the Web Interface (ECC,AWI ) and the thick client. Basically some tabs are missing in Web Interface (ECC,AWI ).

    Eg:

    In the FTP Job template, “RA” tab and the “FTP” tab is missing.

    In the Webservice-SOAP Job template, “RA” tab and the “WEBSERVICE” tab is missing. Case is same for most of the RA jobs and also for the ZOS jobs.

    Can someone tell me what is missing here?  

    Is there any configuration or a patch required for the ECC after base installation?

    kfzvt6ru0gwf.pnghttps://us.v-cdn.net/5019921/uploads/editor/2w/kfzvt6ru0gwf.png" width="564">

    k79m1i5qho8h.pnghttps://us.v-cdn.net/5019921/uploads/editor/ob/k79m1i5qho8h.png" width="722">



  • 2.  Some Tabs in the JOB templates (FTP,ZOS) are missing in ECC,AWI but same is visible in thickclient
    Best Answer

    Posted 10-28-2016 11:20 AM
    Dear Indika Peiris,

    Unfortunately the Enterprise Contol Center(ECC) is missing this functionality.
    You have to edit RA/zOS Jobs in the JAVA GUI.
    With our latest Release V12 this functionality has been implemented.

    Best Regards
    Christian Glaser



  • 3.  Some Tabs in the JOB templates (FTP,ZOS) are missing in ECC,AWI but same is visible in thickclient

    Posted 10-29-2016 01:37 AM
    Dear Christian,

    Quick check with you. Is the ECC 12.0 compatible with AE 11.2.x?

    Rgds,
    Indika 


  • 4.  Some Tabs in the JOB templates (FTP,ZOS) are missing in ECC,AWI but same is visible in thickclient

    Posted 10-29-2016 07:04 AM
    Dear Christian,

    I tried using the AWI 12.0.0 with the AE 11.2.1 and found it is not working( I'm sure it should be mentioned in the compatibility doc). It clearly showing the message " Incompatible AE version '11.2'. expected :12.0"( screenshot attached).

    catm5da7dqjq.png

    It is confirm that :
    a) AWA 11.x ECC( Web Interface) does not fully support design/configuration of all RA Job types and some special job types such as ZOS jobs. Java GUI is required for such job design/configuration. Once design completed with Java GUI, job can be executed and monitor from the 
    ECC( Web Interface) without any issue.

    b) AWA 12.x ECC( Web Interface) is not compatible with the AE 11.x version.

    I also noticed that Java GUI is having come incompatibility with Windows 10 ( some resolution issues that i think can be fixed)

    Rgds,
    Indika Peiris


  • 5.  Some Tabs in the JOB templates (FTP,ZOS) are missing in ECC,AWI but same is visible in thickclient

    Posted 02-15-2017 12:45 PM
    Dear Indika,

    Yes, your observation is correct.
    - ECC does not have the same functionalities as the Java UI
    - The Web Interface Version has to match the Automation Engine Version. (AE 11.x -> ECC 11.x)

    Regarding the compatibility issues with Windows 10. Can you please give me an example.

    I`d like to mention that I cannot guarantee that those issues will be fixed.
    With Version 12 we focus on our Web UI (AWI). All new features are implemented in the WEB UI only.
    The JAVA UI is still available but will not be develop any further.

    Best Regards
    Christian Glaser





  • 6.  Some Tabs in the JOB templates (FTP,ZOS) are missing in ECC,AWI but same is visible in thickclient

    Posted 02-15-2017 06:58 PM
    Came here because of the AWI version error. Too bad we can't make it work for older versions but will focus on upgrading.

    For Windows 10 it appears to be a 4k display issue. We've followed this article with success:

    https://www.tekrevue.com/tip/windows-10-display-scaling/

    We set it to ~225% and rebooted our machine and found it's usable but not close to perfect.

    -Ben