Automic Workload Automation

If the agent installation directory has "#" like agent#11 , thejobs will fail when using csh or -csh

  • 1.  If the agent installation directory has "#" like agent#11 , thejobs will fail when using csh or -csh

    Posted 08-30-2017 11:36 AM
    Symptoms:
    On Unix/Linux, if the agent installation directory has "#" like agent#11 , the jobs will fail when using csh or -csh . It seems that AE agent cannot handle # with csh or with -csh . It works with ksh.



    Error message:
    If the agent is installed in the path /automic/UC4/agent#12 , the job will fail with the following error message in the report log:

    /automic/UC4/agent: Permission denied.




    Solution:

    It's a limitation on csh. For example, if you have the following script and
    execute it outside Unix Agent.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    #! /bin/csh
    cd /home/UC4/ae11/agent#112
    pwd
    echo TEST
    exit $?
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Result:
    # ./test
    /home/UC4/ae11/agent: No such file or directory.

    Please do the following(please test it first on your test environment):
    -Modify the HEADER.UNIX and TRAILER.UNIX as shown in the attached files(HEADER.jpg and TRAILER.jpeg)
    p0rv3bh1iyye.jpghttps://us.v-cdn.net/5019921/uploads/editor/xe/p0rv3bh1iyye.jpg" width="1159">

    lxc0u60uxw5v.jpghttps://us.v-cdn.net/5019921/uploads/editor/24/lxc0u60uxw5v.jpg" width="1297">
    -Modify the parameter UC_EX_JOB_MD and makes ure put the full name of the job messenger binary as shown below:
    UC_EX_JOB_MD=ucxjlx6m
    -Then, in the UNIX tab of your JOBS, put -v on the Shell option field