Agile Requirements Designer

 View Only

Tech Tip: The following paths were not stored because they already exist in the stored path

  • 1.  Tech Tip: The following paths were not stored because they already exist in the stored path

    Posted Nov 30, 2017 08:34 AM

    This document can also be viewed at https://support.ca.com/us/knowledge-base-articles.TEC1473099.html 
    To see more documents like this, check out our ARD knowledge base here: CA Agile Requirements Designer 

    Issue:

    We previously built a flow in Agile Designer, but when we try to store the test cases again, we receive the following error: The following paths were not stored because they already exist in the stored path.

     

     

    following paths not stored.png

    Environment:
    CA Agile Requirements Designer (ARD)- Agile Designer
    Cause:

    This error message just means that there is an identical path already saved in this flow. If you have already saved test cases for a flow before and try to save again without making any changes to the flow, you will receive this error message. If you click OK on the message and go to the View Test Cases tab, you should still see all the expected paths. 

    Resolution:

    If you would like to re-save your test cases/paths again without making any changes to the original flow, you can do the following:

     

     

    1. In the Path Explorer, in the 'View Test Cases' tab, click on the red X button to delete all the test cases.
    2. In the 'Generate Test Cases' tab, pick your 'Optimization' setting and generate test cases by clicking the green play button.
    3. Go back to the 'View Test Cases' tab and verify paths were created.
    4. Save these paths/test cases that are generated by clicking on either of these icons: Store Single Path, Store Selected Path, Store All. To save all test cases available, click the 'Store All' save button.
    5. Since the previously generated paths that were identical to the ones just created were deleted, you should be able to save the test cases successfully. 

     

     

    If you would like to store these paths again without deleting the original paths, you can make a small modification to the flow and use the 'Add to existing' option when generating the test cases. If you ever go back and edit a flow that you previously created test cases for, the 'Path Impact Analyzer' will catch these changes and you will be able to review them. To see the 'Path Impact Analyzer' feature and re-save test cases, you can modify some of the process blocks from the flow.

     

     

    1. Make a modification to your existing flow. It can be small like adding or deleting a block. 
    2. Clicked on the 'View Test Cases' tab again in the Path Explorer.
    3. A 'Path Impact Analyzer' window will pop up. This shows what paths are no longer valid based on your recent changes, and any error/warning messages for individual paths.
    - In this feature you can choose to delete the paths no longer needed, or you have the option to 'Repair' them.
    - If you have actually added more process blocks or paths to your flow, you can see the test cases they will have generated by clicking on the 'Add to Existing' checkbox on the 'Generate Test Cases' tab.
    4. Choose what you would like to keep or delete depending on what changes you made. 
    5. Now in the 'View Test Cases' tab, you can see your set of test cases and save them. 

    Additional Information:

    If you experience any further issues, please open a support case by going to https://support.ca.com/us.html