Agile Requirements Designer

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Tech Tip: License Error- The CmActLicense is invalid, Error 264

  • 1.  Tech Tip: License Error- The CmActLicense is invalid, Error 264

    Posted Oct 20, 2017 01:10 PM

    This document can also be viewed here: https://support.ca.com/us/knowledge-base-articles.TEC1790448.html 

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    Issue:

    While trying to activate the offline license for Agile Designer, I received the following error message:
    Importing CmActLicense failed: The CmActLicense is invalid, Error 264.

     

    errror 264.png

    Environment:
    CA Agile Requirements Designer (ARD)- Agile Designer
    Cause:

    After analyzing the CmDust and CodeMeter log files with Wibu Systems, we discovered that the this error occurs when there is a lack of permissions/privileges to write to the machine. The error is saying that the CmActLicense cannot be accessed and the license cannot be written into the container. CodeMeter.exe normally run as 'System service', which means that it runs in the Account System, which is used by default for services on Windows systems. The System account normally has all the needed read/write permission for all folders which are used for CmAct, but sometimes the users IT administrator needs to set these up. Local Administrator accounts also have to start application with elevation, meaning use the 'Run as Administrator' option when launching CodeMeterCC.exe. You may also see this issue if you have an antivirus tool or scanner preventing the CodeMeter service from doing anything. 

    Resolution:

    First try to run CodeMeterCC.exe as Administrator and apply the license again.

     

    run as admin.png

     

     

    If this does not resolve the issue, work with your local IT Administrator to make sure your system user has elevated privileges.

     

    If your IT admin confirms that all the necessary privileges are in place, please open a support case and we can investigate the issue further. You can open a support case by going to https://support.ca.com.