Agile Requirements Designer

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Tech Tip: Work-group License is Required for Path Optimization Error in Agile Designer

  • 1.  Tech Tip: Work-group License is Required for Path Optimization Error in Agile Designer

    Posted Mar 21, 2017 10:22 AM

    This document can also be viewed at https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1123958.html 

     

    Issue:

    When using the Path Explorer feature in Agile Designer, I am receiving the following error message:
    Work-group license is required for path optimization. For additional features please contact CA Support.

     

    work-group license error.PNG

    Environment:
    CA Agile Requirements Designer (ARD)- Agile Designer
    Cause:

    If you receive this error message it means the license you were provided with is actually a 'Stand-alone' ARD license, which does not include test case generation capabilities. Either your contract does not entitle you to these capabilities so you were given this type of license, or you were given the wrong type of license.

     

    Here are the definitions of each license type:

    • ARD Stand-alone License: Includes repository, basic modeling functions, and connector capabilities with JIRA, Agile Central, and HP ALM.
    • ARD Work-group License: Includes Stand-alone capabilities plus test case generation and optimization features.
    • ARD Automation Builder Add-On License: Includes Work-group capabilities plus automation and scripting features.

     

    If you have any contract questions, please contact your CA Account Manager. If you do not know who your account manager is, please call CA Customer Care at one of these numbers: https://www.ca.com/us/services-support/ca-support/contact-support.html 

     

    If you think you are entitled to a Work-group license and were give a Stand-alone license in error, please follow the resolution steps below.

    Resolution:

    First you will need to delete your existing license which is causing the error message, then you will need to request and apply a new license to ARD.

     

    1. Delete your existing license.
    - Directions: https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1123134.html 

     

    2. Request and apply a new license: 
    - Directions for Offline licenses: https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1147813.html 
    - Directions for Online licenses: https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1424828.html 
    (In the license request form description section, make sure to note that you are requesting a work-group license specifically)

    Additional Information:

    If you experience any further licensing issues, please open a support case on https://support.ca.com/irj/portal/newhome or call CA Customer Care at one of these numbers: https://www.ca.com/us/services-support/ca-support/contact-support.html