Agile Requirements Designer

Tech Tip: Subflow automation script not updated/missing from main script

  • 1.  Tech Tip: Subflow automation script not updated/missing from main script

    Posted 11-29-2017 09:24 PM

    This document can also be viewed at https://support.ca.com/us/knowledge-base-articles.TEC1880333.html 

    To see more documents like this, check out our ARD knowledge base here: CA Agile Requirements Designer 

    Issue:

    In Agile Designer, the subflow automation script is not updated to the main script in some flows is missing in the main script. 

    Environment:
    CA Agile Requirements Designer (ARD)- Agile Designer
    Cause:

    This usually happens when the references are not refreshed from the subflow to the master/main flow.

    Resolution:

    In general, we always recommend regenerating paths and refreshing references if you are experiences issues like this. Here is an example of how to resolve this:


    1. Make a minor change to the subflow in ARD; even moving a block slightly will do.

     

    2. Save the subflow. 

     

    3. Repeat for all of the subflows. 

     

    4. In the main flow, you will receive a notification saying a subflow update is available. Click the notifications panel like so: 

     

    notifications.png

     

    5. Now hit the ‘Reload direct subflows’ button: 

     

    reload direct subflows.png

     

    6. Now you should be able to generate Automation from the master flow that takes into account the subflows. 

    Additional Information:

    If you experience any further issues, please open a support case by going to https://support.ca.com/us.html