DX Infrastructure Management

Expand all | Collapse all

How can I make the Launch Relationship Viewer from the Actions menu appear for the USM groups

  • 1.  How can I make the Launch Relationship Viewer from the Actions menu appear for the USM groups

    Posted 10-14-2018 11:15 PM

    I rebuild the topology through How do I rebuild or clean up topology data a few days back and can see that through relationship viewer portlet that there is changes as it is being build but the link for Launch Relationship Viewer from the Actions menu still does not show up for each USM group.

    When I add a Relationship Viewer to a Portal page it show devices and robots but I don't see the usual network connectivity for Relationship Selector.

     

     

    For discovery configuration I am currently NOT using WMI, SSH or SNMP to scan the network range scope of each discovery_agent.

    As I notice that previous before the rebuild with SNMP authentication turn on for all scope a number of switches device of different tenant merge or correlated as one device in the Inventory.

    How can I make the Launch Relationship Viewer from the Actions menu appear for the USM groups.

     

    I am running UIM 8.5 , discovery_server and discovery agent version 8.5, relationship services and topology_agent version 1.72.



  • 2.  Re: How can I make the Launch Relationship Viewer from the Actions menu appear for the USM groups

    Posted 10-15-2018 02:50 PM

    Please open a support case for this as this should be populating automatically.



  • 3.  Re: How can I make the Launch Relationship Viewer from the Actions menu appear for the USM groups

    Posted 10-15-2018 11:25 PM

    I have open a support case 01216554.



  • 4.  Re: How can I make the Launch Relationship Viewer from the Actions menu appear for the USM groups

    Posted 10-16-2018 01:19 AM

    The Launch Relationship Viewer menu option is present only if the relationship_services probe is running and at least one relationship exists for the selected group or group member. 

    Same is updated on support case now



  • 5.  Re: How can I make the Launch Relationship Viewer from the Actions menu appear for the USM groups

    Posted 10-16-2018 03:19 AM

    I a bit puzzle line in https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/using-ump/the-relationship-viewer-portlet
    line "at least one relationship exists for the selected group or group member" as always stated in the documents and  

    the Relationship Viewer can depict almost any kind of objects and their relationships:

       - Computers and network device icons, with the relationship line indicating a network connection between two of them.
       - User and service icons, with the relationship line indicating a user's subscription to a service.
       - Physical locations, with the relationship line indicating perhaps a direct transportation route or some other link between locations.

    For all of the time I only saw network connectivity for Relationship Selector with previous discovery that include SNMP authentication which some device responded.
    Without currently using snmp or wmi or ssh for discovery for all devices should I be expecting no relationship existing between groups or group member.
    Currently without using snmp or wmi or ssh for discovery when I add a Relationship Viewer to a Portal page it show devices and robots but each is a single device with no relationship line indication links to each other.



  • 6.  Re: How can I make the Launch Relationship Viewer from the Actions menu appear for the USM groups

    Posted 10-19-2018 10:39 PM

    Support Franklin D'souza reply will not get relationship without snmp . The way RCA works is that the topology_agent uses SNMP to communicate with routers, switches, and network devices, and queries their routing tables to determine their connectivity to other devices in the network.

     

    I run SNMP v2 on one of the discovery_agent with two network /24 subnet with 13 of the 80 devices (3 routers and 1 switch and 9 servers ) responding to SNMP. In the Relationship Viewer that I add to a Portal page it show devices and robots discovered by the discovery_agent for some of the router and switch and has the Network Connectivity in the relationship selector. The USM group that I filter for the subnet also shows in the Actions menu View Relationships Network Connectivity option.

     

    Even the remaining USM groups that I use other discovery_agents 30 network /24 subnet to discover without using WMI, SSH or SNMP also have Actions menu View Relationships Network Connectivity option available. These seem indicate an apply to all if there is one relationship exist in my situation.