DX Infrastructure Manager

Expand all | Collapse all

Invalid credentials SNMPCOLLECTOR

  • 1.  Invalid credentials SNMPCOLLECTOR

    Posted 05-13-2019 10:54 AM

    Hi all.

    Has it happened to you that the USM Wizard discovers a device via SNMPv3 and when they are going to import the device from snmpcollector does not it?
    Or that when you add the manual profile in snmpcollector through snmpv3 it says invalid credentials even though the USM-Wizard discovers it and when you try with tool sapwalk2 it also responds. That the device answer snmpv3 to all but not snmpcollector ?.

     

    Anyone know what happened this, this drive me crazy.

     

    I am making test and i see this line from the logs snmpcollector

     

    May 13 11:33:31:356 [DefaultUDPTransportMapping_0.0.0.0/0, snmpcollector] Profile : 10.200.170.169/161has reached sysUpTime > 497 days. Cleared the stale engineTime from USM
    May 13 11:33:33:927 [DefaultUDPTransportMapping_0.0.0.0/0, snmpcollector] Profile : 10.200.170.169/161has reached sysUpTime > 497 days. Cleared the stale engineTime from USM
    May 13 11:33:35:734 [DefaultUDPTransportMapping_0.0.0.0/0, snmpcollector] Profile : 10.200.170.169/161has reached sysUpTime > 497 days. Cleared the stale engineTime from USM
    May 13 11:33:37:819 [DefaultUDPTransportMapping_0.0.0.0/0, snmpcollector] Profile : 10.200.170.169/161has reached sysUpTime > 497 days. Cleared the stale engineTime from USM

     

    Maybe this has something to do with this problem?



  • 2.  Re: Invalid credentials SNMPCOLLECTOR

    Broadcom Employee
    Posted 05-13-2019 06:36 PM

    It could be that the snmpcollector is requiring return data for some specific OID, poller log may have some helpful info on that. A good starting point is to verify the device is supported.

    UIM SNMP Device Support 



  • 3.  Re: Invalid credentials SNMPCOLLECTOR

    Broadcom Employee
    Posted 05-13-2019 10:25 PM

    The term of "USM" in the error does not mean USM in CA UIM, it represents for User Based Security Model, a term specific to SNMP v3.

     

    I am seeing sometimes "Invalid Credential" error in snmpcollector probe while supplied credential is correct.

    Please try the following.

     

    Increase number of retries.

    Increase timeout

    Use MAX_BATCH to reduce bulk size of SNMP requests.

    https://communities.ca.com/docs/DOC-231179273-tech-tip-maxbatch-in-snmpcollector-and-caveats