DX Infrastructure Manager

Expand all | Collapse all

No Contact communication Error

  • 1.  No Contact communication Error

    Posted 09-06-2018 09:21 AM

    I have a concern that a robot gives constantly communication error but no robot inactive generated from the hub.

    I am unable to understand the logic behind communication error, the communication has been lost between a HUB and Robot in my case for approx 24 hours and logs says continuously "Controller: Failed to send set_hub to spooler (communication error) " then what should the hub do in such cases? Will it generate a robot inactive or not.

     

     

    Sep  5 13:33:06:243 [3688] Controller: Failed to send set_hub to spooler (communication error)

    Sep  5 13:38:09:437 [3688] Controller: Failed to send set_hub to spooler (communication error)

    Sep  5 13:43:11:673 [3688] Controller: Failed to send set_hub to spooler (communication error)

    Sep  5 13:48:13:262 [3688] Controller: Failed to send set_hub to spooler (communication error)

    Sep  5 13:53:17:007 [3688] Controller: Failed to send set_hub to spooler (communication error)

    Sep  5 13:58:19:879 [3688] Controller: Failed to send set_hub to spooler (communication error)

     

    *

    *

    *

    *

    *

    Sep  5 15:44:18:623 [3688] Controller: Failed to send set_hub to spooler (communication error)

     

    In my case it doesn't only when I see logs below an Inactive alarm ---

     

    Sep  5 16:30:44:240 [3688] Controller: Going down...

    Sep  5 16:30:54:366 [3688] Controller: Down

     

    I also understand that the agent is not able to communicate with HUB but HUB in such cases if can not connect to agent shall generate the alarm or not?



  • 2.  Re: No Contact communication Error

    Broadcom Employee
    Posted 09-06-2018 03:55 PM

    There is this:

    Failed to send set_hub to spooler (communication e - CA Knowledge 

     

    Would also recommend updating both the hub and robot to 7.93. That is at hub, deploy hup 7.93 & robot 7.93, and at robot deploy robot 7.93. Then make the settings recommended here:

    Avoiding communication errors when configuring UIM - CA Knowledge 



  • 3.  Re: No Contact communication Error

    Posted 09-10-2018 04:01 PM

    I would recommend you to Upgrade to Robot and Hub( on this order) to 7.95 version that you can get from a CA Support ticket!

     

    And do this changes in the Hub.cfg files:

     

    postroute_interval = 120
    postroute_reply_timeout = 180
    postroute_passive_timeout = 300
    hub_request_timeout = 120
    tunnel_hang_timeout = 300
    tunnel_hang_retries = 3

     

    Kind Regards,

     

    Alex Yasuda
    Sr. Support Engineer



  • 4.  Re: No Contact communication Error

    Posted 09-12-2018 06:26 AM

    Hi Alex,

     

    These setting are already in place, this is the first thing I applied to make the environment stable. 

    Issue is with the agents reporting to hub, which when go into a state of communication error does not trigger any alarms until the agent goes down