DX Infrastructure Manager

Expand all | Collapse all

snmpcollector probe issue

  • 1.  snmpcollector probe issue

    Posted 07-05-2017 03:04 AM

    Hi team,

     

    After deploying snmpcollector probe am getting below error. Probe is not coming up, showing

    down

     

    Ca

    n anyone help on the same

     

     



  • 2.  Re: snmpcollector probe issue



  • 3.  Re: snmpcollector probe issue

    Posted 07-05-2017 03:36 AM

    Hi,

     

    this can help SNMPcollector probe in failed state after deployment. Last time when I had this issue i try to reinstall 2-3 times the probe and it helps. In mind I had an TEC articel which the issue describe, but I´m not sure. In an fast search at support.ca.com in the KB articel I didn´t find more. If seen this issue in some enviroments with 3.31 and 3.4 (removed from Archive). But I don´t open an ticket until today because of an lag of time and that I can resolve with some reinstalles :-(

     

    Alex



  • 4.  Re: snmpcollector probe issue

    Posted 07-05-2017 04:01 AM

    If this is Linux platform, please disable loopback from /etc/hosts.

    snmpcollector is not able to start with 127.0.0.1.



  • 5.  Re: snmpcollector probe issue

    Posted 07-05-2017 04:16 AM
      |   view attached

    Hi,

     

     

     

    This thing is not related to Linux. Its related to windows server.

     

     

     

    Can you help me on this.

     

     

     

    Warm Regards,

     

     

     

    Yusuf

     

     

     

    IT Operations Centre (ITOC)

     

    HCL Services Ltd.

     

    (A Subsidiary of HCL Info systems Ltd.)

     

    RS No 107/5,6 & 7,Sedarapet,

     

    Pondicherry India- 605111

     

    Tel: 8870181927

     

    <http://www.hclservices.in/> www.hclservices.in

     

    <http://www.hclinfosystems.com/> www.hclinfosystems.com 

     

    Fact_File_d8

     

    The information transmitted is intended only for the person or entity to which it is addressed and may

     

    contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of,

     

    or taking of any action in reliance upon, this information by persons or entities other than the intended

     

    recipient is prohibited. If you received this in error, please contact the sender and delete the material from

     

    your computer.



  • 6.  Re: snmpcollector probe issue

    Posted 07-05-2017 06:46 AM

    Have you tried starting the probe manually to see if any error messages are being created?

     

    use a command prompt where you are in the probes directory.

     

    <nimsoft installation folder>/jre/<java version>/bin/java -Xrs -cp "lib/*;jars/*" com.nimsoft.probes.network.snmpcollector.SNMPCollectorProbe

     

    run the above changing <nimsoft installation folder> to your installation folder and <java version> to either java8u102 or jre7

     

    this should capture any errors being generated



  • 7.  Re: snmpcollector probe issue

    Posted 07-05-2017 06:54 AM

    Hello Yusuf, please also verify the java version that is installed in this robot.

     

    Kind regards,

    Britta Hoffner

    CA Support



  • 8.  Re: snmpcollector probe issue

    Posted 07-05-2017 07:51 AM

    I got the same issue but "jars" and "lib" directories on the Linux host are empty after deploying the snmpcollector probe  



  • 9.  Re: snmpcollector probe issue

    Posted 07-19-2017 03:48 AM

    Hello Britta,

     

    I opened case “00782449 -snmpcollector probe cannot be deployed to remote hub”.

    I have still the same issue.

     

    Best Regards,

    Dirk



  • 10.  Re: snmpcollector probe issue

    Posted 07-14-2017 10:44 AM

    Hello Yusuf, is this question answered for you or are there still problems. I would suggest to open a case with support for it to followup.

     

    Kind regards,

    Britta Hoffner

    CA Support



  • 11.  Re: snmpcollector probe issue

    Posted 08-14-2017 04:52 AM

    Hi all,

     

    I'm going to add to this topic because I believe we have the same issue. At least, the same issue as mentioned by Dirk.

     

    Referring to case 00771685 snmpcollector 3.40 upgrade fails.

     

    The above case is closed because at the time we thought version 3.40 was faulty, but now we're having the same issue with 3.41 and 3.31.

     

    In short: deploying the snmpcollector to a hub always fails with the error: Aborted, retry limit exceeded, unknown status. You'll also notice that the robot in question in unresponsive, hence the above error. I believe that during the installation of the probe, the hub gets reset somehow.

    Sometimes the installation continues on his own locally and finishes, but the probe won't work. Sometimes the templates won't load, sometimes he won't poll, sometimes he gives a not ok response on get_ctd_configuration.

    The same happens when we try to update the vendor certifications as well.

    It's not related to Linux or windows, it happens on both platforms.

     

    Currently we're at the stage where we keep the running snmpcollectors alone, because any modification here might break the config.

     

    I'd like to know if there are other customers out there with similar experiences.

     

    kind regards

    Mark



  • 12.  Re: snmpcollector probe issue

    Posted 08-14-2017 04:59 AM

    How are you deploying the SNMPCollector?

     

    Ive found that using distsvr to deploy the SNMPCollector breaks it where are using the adminconsole is successful



  • 13.  Re: snmpcollector probe issue

    Posted 08-14-2017 05:08 AM

    Yes, I'd like to add to that:

     

    - Using IM to deploy always fails

    - Using the distsrv first to set the install files on the local hub and then using the adminconsole to deploy succeeds

    However: we still get the issue that he fails to start or won't poll etc etc. Not all the time, mind you. But it's like a toss of a coin, if you're lucky you get a working environment.

     

    It's all very unstable at the moment.

     

    The strangest thing is that it used to work fine, it all began after the first deployment of version 3.40, which was recalled later. Also, other probes get deployed fine, either with IM or AC.



  • 14.  Re: snmpcollector probe issue

    Posted 08-14-2017 10:15 AM

    rebuild the local db, SnmpCollector.mv.db

    deactivate snmpcollector

    rename SnmpCollector.mv.db

    activate snmpcollector

    query discovery server to rebuild local db with all the profiles



  • 15.  Re: snmpcollector probe issue

    Posted 08-14-2017 09:18 PM

    FYI

    I have a customer reporting the same symptom although it was a clean fresh deployment of 3.40



  • 16.  Re: snmpcollector probe issue

    Posted 08-16-2017 03:35 AM

    Did a few more tests.

     

    The only way I can deploy the old snmpcollector v3.31 now,  is using the following method:

     

    - deploy automated deployment engine on the remote hub

    - deploy distsrv on the remote hub

    - forward all versions of snmpcollector from the primary hub to the remote hub, using the distsrv probe on the primary hub

    - login to the admin console

    - go to the remote hub, select archive

    - deploy the snmpcollector version 3.31 from the local archive of the remote hub

     

     

    Then the installation succeeds. All other methods are currently failing. Infrastructure manager won't work, Admin console using the archive of the primary hub won't work either.

    In all the above cases, you can see the installer creating directories and filling them with the  xml files and in the end he deletes all xml files (which he isn't supposed to do). So there's clearly an issue here with the installer.

    Time for another case I guess.



  • 17.  Re: snmpcollector probe issue

    Posted 08-28-2017 07:42 AM

    Some extra info I got from CA support:

     

    Issue seems to be related to Robot 7.91/7.92HF and HUB 7.91/7.92HF on the robot.

     

    Rollback to HUB – 7.80HF22 Robot – 7.80HF21 could help, but we didn't test this because we had other issues with these probes :-)

     

    But they're working on a bugfix.



  • 18.  Re: snmpcollector probe issue

    Posted 08-29-2017 07:30 AM

    We have reproduced the problem in our lab.

    Some observed behavior are

     

    SNMPcollector hub running Robot 7.91 => Fail

    SNMPcollector hub running Robot 7.92HFx => Fail

    SNMPcollector hub running Robot 7.80 => Success

    SNMPcollector hub running Robot 7.80HF21 => Success

     

    Admin Console works out regardless of Robot version in SNMPcollector hub.

     

    Regards,

    Yu Ishitani