DX Infrastructure Management

Expand all | Collapse all

AWS Monitoring

Jump to Best Answer
  • 1.  AWS Monitoring

    Posted 03-05-2018 09:40 AM

    Hi team ,

    we are trying to monitor AWS env of our customer and we are facing certain issues.
    So our requirement is basically to deploy only default templates on all profiles (3 currently) .
    So acc to documentation, what i did was created copy of each default template and set its precedence to 0.
    On my 1st profile , all templates are getting deployed properly. for ex on ec2 , template ec2 factory is deployed and so on.
    But on my 2nd and 3rd profile no changes are happening !!
    According to my understanding , all precedence 0 templates must be deployed to all profiles.

    Kindly suggest if any changes in configuration needs to be done.

    Thanks



  • 2.  Re: AWS Monitoring

    Posted 03-08-2018 01:44 AM

    Hello Anmol,

     

    may I ask you which version of the aws probe you are currently using ? We have published a new release 5.34 two weeks ago. Is this the release you are already using ?

     

    Kind regards,

    Britta Hoffner

    CA Support



  • 3.  Re: AWS Monitoring

    Posted 03-08-2018 03:56 AM

    Hi Britta ,

     

    i am using Version 5.26 and while applying templates in this , i am getting very inconsistent results.

    Like i created a template previously and later deleted it but still when i add new profile , those deleted templates get applied from nowhere !!

     

    thanks



  • 4.  Re: AWS Monitoring
    Best Answer

    Posted 03-08-2018 04:25 AM

    Hello Anmol, can you please upgrade to 5.34

     

    1. upgrade the AWS probe to version 5.34
    2. deactivate AWS probe 3. on the AWS robot, navigate to the folder:
    /Nimsoft/probes/application/aws/
    4. In this folder, delete all of the following files if they exist:
    services.json
    graphDump.txt
    internalGraph.json
    *.bak
    5. Delete the folder /Nimsoft/probes/application/aws/mapdb/ entirely
    6. Activate the AWS probe

     

    Please verify if you still see the same problem. If yes please raise a case with CA Support.

     

    Kind regards,

    Britta Hoffner

    CA Support



  • 5.  Re: AWS Monitoring

    Posted 03-19-2018 02:17 PM

    One thing I just wanted to share, I just did the upgrade from aws 5.26 to 5.34 and afterwards every single metric was in the Detached Configurations folder. Thus profile was broken.

     

    Thru trial and error found out I had to De-Activate my existing profile, save, then re-activate profile, save and now the probe is back to normal. No more Self Monitoring alerts and the Detached Configurations is empty.