DX Infrastructure Manager

Expand all | Collapse all

CAUIM - Mismatch of information between NAS and USM

  • 1.  CAUIM - Mismatch of information between NAS and USM

    Posted 03-22-2018 02:37 PM

    Hello CA Guys,

     

    One more time I need your help !  

     

    I have discovered that the amount of alarms that appears in IM are not the same amount of alarms displayed in USM.


    For example, we currently have 20 Majors alarms on the IM for the XPTO customer.

     

     

     

    And we have 10 Major alarms in USM for the same XPTO customer

     

     

    This scenario is repeated for anothers customers.

     

    For example, the IC HQDSWANX2_TERREO-01 displays the following alarm.

     

     

    This alarm does not appear in USM.

     

     

    Could you help us?

     

    Follow the details of our environment:

     

    # UIM 8.20
    # UMP 8.20
    # NAS 8.56
    # Controller 7.70
    # Hub 7.70

     

    Regards,
    Jean Gomes



  • 2.  Re: CAUIM - Mismatch of information between NAS and USM

    Broadcom Employee
    Posted 03-22-2018 03:16 PM

    Check the usm default Alarm view, instead of filtered to a specific group or device, to see if they show up there. Also try the Show Historical there as well. 

     

    I think, all alarms show up at the default un-filtered Alarm view, and to be associated to a specific device and group require the dev_id & met_id. 

     

    If they do show up at the default Alarm view check the nas_alarm table to see if the ids show up. 

     

    select * FROM [CA_UIM1].[dbo].[NAS_ALARMS] where nimid = '***'

    where *** = the ID shown in the IM console Alarm details.

     

    If the IDs are missing then this will go back to the probe generating the alarms. 



  • 3.  Re: CAUIM - Mismatch of information between NAS and USM

    Posted 03-22-2018 03:28 PM

    Hi David!

     

    Thank you very much for your reply.

     

    Please, could you tell me what is USM Default Alarm View?

     

    I am using the USM and I searched the alarms via item(hostname) or via Group and not via filters. Is there another way?

     

    I tested the query that you indicated and yes, the alarm that I used for example in this forum has dev_id & met_id.

     

    select * FROM [CA_UIM_8].[dbo].[NAS_ALARMS]
    where nimid = 'QK11575811-98322'

     

    DEV_ID: D65E69DE6DB2C29300B4DFC4D15F3964B
    MET_ID: M4E44CB1C6C8B73CC09623BB579409E32

     

    Regards,
    Jean Gomes



  • 4.  Re: CAUIM - Mismatch of information between NAS and USM

    Broadcom Employee
    Posted 03-22-2018 04:55 PM

    ump > usm > with the tree top level 'Groups' selected > alarms 

    this shows all the alarms for all groups. 

     

    Regardless with the IDs there, they should be showing up. 

    Did you check Show Historical? 

     

    Something to point out:

    IM latest alarm is 3/15

    AC alarms are all 3/22

     

    Check show historical at both ends to eliminate closed alarms effecting this. 

    It could be a sync related problem. 

     

    Things that could effect it are:

    nas_* table fragmentation

    nas local dbs too large (over 750mb can start effecting it)

    database.db
    transactionlog.db

    too many open alarms at the IM console. 



  • 5.  Re: CAUIM - Mismatch of information between NAS and USM

    Broadcom Employee
    Posted 03-22-2018 11:12 PM

    had usm hotfix for 8.2 to deal with similar symptom in the past.

    unfortunately 8.2 is too old and there is no longer such hotfix download available in public space.

    request uim upgrade. 



  • 6.  Re: CAUIM - Mismatch of information between NAS and USM

    Posted 03-23-2018 07:31 AM

    Hi David,

     

    I checked 'Show Historical' and also checked alarms on the top level 'Groups'.
    Alarms do not appear.

     

    NAS local bds has 75mb, should not affect in that case.
    We have an average of 600 active alarms in the alarm console.

     

    I'm going to upgrade and open a case in support.

     

    Regards,
    Jean Gomes



  • 7.  Re: CAUIM - Mismatch of information between NAS and USM

    Broadcom Employee
    Posted 03-23-2018 11:24 AM

    Hey Jean, this article might provide some insights on why this is occurring:

    Nas alarm counts are not in sync between UMP USM a - CA Knowledge 

     

    I think it's a good idea to go ahead and open a ticket with Support.



  • 8.  Re: CAUIM - Mismatch of information between NAS and USM

    Posted 03-26-2018 08:42 AM

    Hi Philip.

     

    Thanks for your reply

     

    I believe that if I delete all the tables related to NAS probe and also delete
    transactionlogs of NAS probe, we will lose all the alarms and when new alarms
    arrive, so new tickets will also be generated (about the same case, which already had an alarm previously)

     

    I do not like this solution, I will keep with the upgrade.

     

    I really hope that CAUIM in version 8.5.1, this issue does not occurs.w
    It's very strange that a monitoring platform can not synchronize its alarms
    between backend and frontend.

     

    Regards,

    Jean



  • 9.  Re: CAUIM - Mismatch of information between NAS and USM

    Broadcom Employee
    Posted 03-26-2018 08:59 AM

    Correct, if the two local databases in the nas folder are recreated existing alarms are lost and there will be duplicate tickets generated. The nas_* tables may be truncated and then the alarms will be copied over again. 

     

    UIM 8.51 does have many improvements which prevent a lot of problems that were common in the revisions 8.4 and earlier.