DX Infrastructure Manager

Expand all | Collapse all

UIM Installation fails

  • 1.  UIM Installation fails

    Posted 02-07-2017 07:03 AM

    Hi guys,

     

    I'm trying to install UIM 8.5 in a VMWare VM  but the installation ends at 38% with an error. After months of investigations we have seen the following:

     

    - The installation fails trying to copy and activate probes, usually mpse.

    - After aborting the installation we installed IM and we can connect to the Primary Hub but only a few probes are in there. If we try to drag / drop from the archiver it take ages to copy (install) the files and fails at some point with a timeout.

    - The installation log also shows a timeout error.

     

    Details:

    - We can install other software without problems.

    - We tried to install a SQL Express DB locally to discard network or DB issues but the same happens.

    - There's no java installed, in fact there's almost nothing installed.

    - I tried the installation on my laptop with two VMWare player VMs with less than minimum requirements and it works (my laptop is not a valid Primary HUB)

    - Tried the installation at a different VM and the same.

    - We removed the VM from the domain.

    - We tried to install 8.45 and 8.4, exactly the same.

     

    Any idea? I'm desperate.



  • 2.  Re: UIM Installation fails

    Broadcom Employee
    Posted 02-07-2017 07:47 AM

    I have seen a few cases where clients were using a VM image their OS team provided.

    this had been customized and would not install.

    When a new VM image was created with a stock OS install  from media doing a full installation the issue was resolved.

     

    You may want to try that.

     

    You can check disk Queue length make sure it is not above 1

    You can check and make sure all windows updates are done

    you can check and make sure there is no anti-virus installed.

    Check the windows system and application event logs for errors.

     

    Other wise you will probably need to open a support case to schedule a webex to have some one look at your environment.



  • 3.  Re: UIM Installation fails

    Broadcom Employee
    Posted 02-07-2017 08:03 AM

    the other thing to check is do an md5 hash check on the installation files.



  • 4.  Re: UIM Installation fails

    Posted 02-07-2017 09:32 AM

    By the way, I have used the same files to install it on my laptop ;-)



  • 5.  Re: UIM Installation fails

    Posted 02-07-2017 09:31 AM

    Gene,

     

    - Support ticket is already open

    - There's no Win FW or anti-virus

    - Windows is up to date

     

    There's a X-File there that wants to make my life miserable.

    I have already asked the platform guys to "iron" the server.



  • 6.  Re: UIM Installation fails

    Broadcom Employee
    Posted 02-07-2017 10:06 AM

    Are you using SQL authentication or integrated Windows authentication?



  • 7.  Re: UIM Installation fails

    Posted 02-07-2017 10:34 AM

    SQL authentication with a super privileged user. I also tried Windows auth. with the same result.



  • 8.  Re: UIM Installation fails

    Posted 02-07-2017 11:47 AM

    So this is a brand new fresh install correct? What does the UIM install log say at the time it times out and the install fails?

     

    I had a similar issue when I tried to upgrade to 8.5 from 8.47 in my lab. The ADE probe timed out and didn't want to start up and the install aborted. See my other thread: 8.5 Upgrade Install Failure on ADE probe startup 

     

    Did you check all the Known Issues during installation and try the registry tweaks?

    Look here:

    Known Issues - CA Unified Infrastructure Management - 8.1 - CA Technologies Documentation 

    Probes Fail to Start After UIM Server Installation - CA Unified Infrastructure Management - 8.1 - CA Technologies Docume… 

    "Installation on all platforms

    Several components are distributed and configured during installation. On slower systems, some probes might not be started after installation. This can be detected in Admin Console or Infrastructure Manager, and is fixed by manually activating the probe."

    Troubleshooting UIM Server Installation or Upgrade - CA Unified Infrastructure Management - 8.5 - CA Technologies Docume… 



  • 9.  Re: UIM Installation fails

    Posted 02-10-2017 02:52 AM

    Thanks. Indeed I was reading your post before open this question. Checking in deep, on progress.



  • 10.  Re: UIM Installation fails

    Posted 02-09-2017 01:55 AM

    Hello,

     

    Had similar problem in the past. 

    The cause was another UIM hub running in the same LAN.

    After shutting it down, the installation completed with no problems. 



  • 11.  Re: UIM Installation fails

    Posted 02-10-2017 02:49 AM

    You know? This was one of my first ideas but I discarded it because it was so bizarre. Now I think that it's time to try switching off the two hubs that I have on the same network.

     

    Thank you very much for your answer



  • 12.  Re: UIM Installation fails

    Broadcom Employee
    Posted 02-09-2017 03:10 AM

    Also, make sure that you have a proper hosts file or dns record pointing at the ip address you want to use for your UIM hub. UIM relies on dns to resolve hostnames, so if your local hostname does not resolve to your local ip then you can run into such issues. 



  • 13.  Re: UIM Installation fails

    Posted 02-10-2017 02:50 AM

    Thanks. Yesterday we had a look on that but with no success.



  • 14.  Re: UIM Installation fails

    Broadcom Employee
    Posted 02-10-2017 09:59 AM

    I have seen similar behavior when the uimserverpackages.zip was corrupted.  It might be a good idea to re-download the package.



  • 15.  Re: UIM Installation fails

    Posted 02-13-2017 06:02 AM

    I don't think so, since I have used the same files to install it in my laptop and in our old virtualization platform and it works.

    Thanks for you idea,



  • 16.  Re: UIM Installation fails

    Broadcom Employee
    Posted 02-13-2017 10:25 AM

    Do you have the installation files themselves on a network share?

     

    If so, does it make any difference if you copy them directly over to the VM first?



  • 17.  Re: UIM Installation fails

    Broadcom Employee
    Posted 02-14-2017 06:08 AM

    Hello.

    It is a good idea to open support case with the installation log in C:\tmp\ca_uim\*

     

    Regards,

    Yu Ishitani



  • 18.  Re: UIM Installation fails

    Posted 03-10-2017 02:55 AM

    Well guys,
    After hundreds of tries and investigation we decided to create a new machine and this time the installation SUCCEED. Is amazing that we met all the requirements but still there's something that prevents the installation.
    Anyway thank you very much to all of you for your help.