DX Infrastructure Manager

Expand all | Collapse all

Monitoring ActiveMQ / AIX

  • 1.  Monitoring ActiveMQ / AIX

    Posted 09-08-2017 07:06 AM

    Hi,

    What probe(s) can I use to monitor ActiveMQ in an AIX environment?

     

    Regards

    Kenneth



  • 2.  Re: Monitoring ActiveMQ / AIX

    Broadcom Employee
    Posted 09-10-2017 06:42 PM

    You can use tomcat probe to monitor ActiveMQ.

    If you point the tomcat probe to an ActiveMQ installation it will connect and show up in the tree-view. You may then set up your profile.



  • 3.  Re: Monitoring ActiveMQ / AIX

    Posted 09-12-2017 04:13 AM

    Thank you,

    We will try this out!



  • 4.  Re: Monitoring ActiveMQ / AIX

    Posted 09-14-2017 08:04 AM

    Yes, it works. And also the JVM_monitor-probe. Looks almost the same, but in the JVM_monitor-probe you have some more options in the monitoring. Maybe someone else can tell the exact different?

    Both probes needs to be edited though, regarding running out of memory. Here is what you need to do:

    tomcat probe internal used memory error (I think this goes for the JVM-probe as well)

     

     

    This is how I did it:

     

     

    1. Open up port 1099 in the firewall between your UIM-server and the ActiveMQ-server.
    2. Now you need to activate the JMX-connector so the ActiveMQ-server starts listening to port 1099. 
    You do this in the XML-config, which you will find in the install directory for ActiveMQ. 
    In my case it's in here:
    /opt/<activemq-dir>/conf/activemq.xml
    This is what you need to change/add inbetween your "<Broker xmlns.."-tag:
    <broker xmlns="http://activemq.apache.org......................">
    ………..…
    ………
    <managementContext>
      <managementContext createConnector="true" connectorPort="1099"/>
    </managementContext>
    ……
    ………….
    </broker>

    3. Now you should start ActiveMQ:
    • cd /opt/<activemq-dir>/bin
    • ./activemq start       --- (If it's already started you need to stop it first with "./activemq stop")

     

    4. Check that the server now is listening at port 1099

    • netstat -an | grep 1099

     

    5. Now open up your Tomcat or JVM-probe and add the host with port 1099.

    • Default User/Password is admin/admin (you should change this later).

     

    6. When it's connected, it should look something like this:

     

     

     

     

    If you still having problem, JMX might not be enabled by default in ActiveMQ. Then add this to the XML-config:

    /opt/<activemq-dir>/conf/activemq.xml

    <broker xmlns="..….brokerName="localhost" useJmx="true">
    .......
    .........
    </broker>