DX Infrastructure Manager

Expand all | Collapse all

emailgtw probe sending email for every single alarm without AO profile

Jump to Best Answer
  • 1.  emailgtw probe sending email for every single alarm without AO profile

    Posted 07-19-2017 09:29 AM

    Recently my emailgtw probe starting sending emails for every single alarm and there is no AO profile to perform this. Is there somewhere else I can check for a rule causing these emails. Also it is is only sending the emails to one of the profiles in the emailgtw probe.

     

    Thank You for any help...



  • 2.  Re: emailgtw probe sending email for every single alarm without AO profile

    Broadcom Employee
    Posted 07-19-2017 09:35 AM

    the emailgtw probe is looking for a message with a subject of email.

    There would have to be a script or an AO profile that is posting a message with a subject for the emailgtw to pickup.

    you can edit the nas.cfg and search for email and see what that probes.

     

    You can also set the nas debug level to 3 or higher and you  should be able to see the profile firing for this.

    You may need to check your scripts as well.

     

    hope this helps



  • 3.  Re: emailgtw probe sending email for every single alarm without AO profile

    Posted 07-19-2017 09:38 AM

    OK I just deleted the emailgtw profile that is receiving all the emails and they are still be sent there. Are there any other probes to check...



  • 4.  Re: emailgtw probe sending email for every single alarm without AO profile

    Broadcom Employee
    Posted 07-19-2017 09:45 AM

    only the emailgtw probe can send alarms out via email.

    I do know clients who have setup lua scripts to do this as well.

     

    if you use netstat or wireshark are you still seeing connections from the primary hub to your email server?



  • 5.  Re: emailgtw probe sending email for every single alarm without AO profile

    Posted 07-19-2017 09:55 AM

    I searched the nas .cfg file and found my AO profiles that I want and are working fine. I currently have all of these disabled to troubleshoot though. I have the nas log level set to 3 and there is nothing in the output that indicates that an AO profile is triggering emails. I hit test in the emailgtw probe and it returned green, what are you thinking regarding the connection question? I will have have to engage our network guys to have them look at it via wireshark.



  • 6.  Re: emailgtw probe sending email for every single alarm without AO profile

    Broadcom Employee
    Posted 07-19-2017 10:00 AM

    you said you deleted the emailgwt probe but were still getting emails.

    Something has to be connecting to the email server so checking the network connections to see what is make the connection would be the next step.

     

    Do you possibly have an HA hub that has had emailgtw and nas activated by accident?

     

    You may need to open a case with support so they can do a webex and help you find the issue.



  • 7.  Re: emailgtw probe sending email for every single alarm without AO profile

    Posted 07-19-2017 10:07 AM

    Sorry, I deleted the emailgtw profile that is receiving the emails and they were still being sent to the address in that profile. How can that be possible? I did remove the emailgtw probe and the emails stopped, however the moment I put in our mail server and hit apply they started again. This is with no profiles added. It does sound like I may have to open a case. I want to try to refresh the nas the same way (delete re-add) but Im worried I may miss somepiece of it that needs to be backed up, like the lua scripts, schedules, AO Profiles, etc... I think this started when a bad profile was created, but now I cant find it or remove it...



  • 8.  Re: emailgtw probe sending email for every single alarm without AO profile
    Best Answer

    Broadcom Employee
    Posted 07-19-2017 11:25 AM

    Yes I agree please open a support case.

    Attach your emailgtw.cfg nas.cfg and scripts folder from nas to the case for quicker help.



  • 9.  Re: emailgtw probe sending email for every single alarm without AO profile

    Posted 07-19-2017 11:26 AM

    Thanks for all the help Gene...



  • 10.  Re: emailgtw probe sending email for every single alarm without AO profile

    Broadcom Employee
    Posted 07-19-2017 11:28 AM

    Can you check whether the option 'Email on assignment' is checked in emailgtw probe configuration? This would trigger an email for every alarm that gets assigned.



  • 11.  Re: emailgtw probe sending email for every single alarm without AO profile

    Posted 07-19-2017 11:31 AM

    It is unchecked. I also removed the profile from the emailgtw probe that contains the email address that is receiving all of the alerts.The emails still get sent...



  • 12.  Re: emailgtw probe sending email for every single alarm without AO profile

    Posted 07-19-2017 11:32 AM

    How does an alarm get assigned?



  • 13.  Re: emailgtw probe sending email for every single alarm without AO profile

    Posted 07-19-2017 02:16 PM

    Opened a ticket and in case anyone runs into this, here is the solution -

    Turns out the messages were queued up to be sent. There was a "not so great" ao profile created where the filter picked up everything in the alarm console and immediately queued it all up to be sent. In the Hub probe > Status tab, found the emailgtw queue and cleared it out.

     

    Thanks all for the help