DX Infrastructure Management

Expand all | Collapse all

Unable to Reset Robot Device ID

  • 1.  Unable to Reset Robot Device ID

    Posted 11-04-2016 11:51 AM

    So has anyone ever come across a situation where you cannot reset the robot device ID? 

    We have an issue where alerts generated by this robot is sending the MDR Element ID with a CS_ID value that does not exist w/in the UIM DB. 

    So for example robot1 generates an alert and in the alert properties the cs_id or the MDR Element ID is 81633 but when we search the CM_COMPUTER_SYSTEM table, this cs_id doesn't exist. This robot already went thru the discovery server remove_robot_by_CS_ID procedure and was re-recreated with a new cs_id of 121333. Yet the robot is still sending 81633.

     

    So I tried running thru _reset_robot_id_clean_niscache callback on the controller yet the Robot_ID is still the same robot ID. I tried this a few times and nothing. I even logged onto the box, stopped Nimsoft Robot Watcher service, and deleted everything in the \nimsoft\niscache directory. Restarted the service and when I did a _get_info on the robot it was the same robot_ID??? How is that possible? 

    We are opening a case but if anyone ever ran into the past if you figured this out please let me know.

    Thank you,

    Dan



  • 2.  Re: Unable to Reset Robot Device ID

    Posted 11-04-2016 11:58 AM

    Hi Dan,

     

    A robot_device_id is based on a hash of the robot name/hostname and IP address.   If you delete the .robot_device_id file and restart the robot, and it regenerates the same ID, that indicates that this ID is actually the correct ID for the robot.

     

    I am not familiar with the "MDR Element ID" - I guess that relates to SOI which I am unfortunately not familiar with but I suspect the real problem lies with whatever is generating that ID and/or associating it with a cs_id.