DX Infrastructure Manager

Expand all | Collapse all

Device Correlation

  • 1.  Device Correlation

    Posted 03-10-2017 12:07 PM

    I want to share some information with the masses to 1) see if anyone else experiences the same issues and 2) if our 7 step resolution approach works for other.

     

    We have struggled for countless hours trying to get QOS data, typically from net_connect and VMware probes, to correlate. For example in the UMP search, you may see two instances of the same device. In other instances, you may see net_connect QOS but no VMware probe QOS and vice versus.

     

    We have opened numerous cases and eventually come to a resolution. After working through all these cases, I have compiled a list of actions that seem to work for us:

     

    ***Note: It's unfortunate, but making host file entries has made a HUGE difference. I hear that correlation is much better in 8.51 as there is more control within discovery_server to configure what is used for correlation.

     

    1. Run the following query on your UIm DB: SELECT origin,name,ip,dns_name,nimbus_type,cs_id,cs_key,dedicated,mac,os_name FROM cm_computer_system WHERE name LIKE ('%device_name%') ORDER BY name
    2. Copy the 'cs_key' value
    3. Using the discovery_server probe call back utility, select 'remove_master_device_by_cs_keys' from the drop down to remove the device from cm_computer_system using 'cs_key' ***Note this will reset the cs_id, in case you use this cs_id key in other applications/reporting etc. After a few minutes, you should notice that the device is no longer present in UMP.
    4. Using the Controller/robot call back utility on the secondary hub where the device is being monitored from, select '_nis_cache_clean' from the drop down list (need to be in 'Expert Mode') and click the 'Play' button.
    5. Using the same call back utility, select '_reset_device_id_and_restart' from the drop down list (need to be in 'Expert Mode') and click the 'Play' button
    6. IM console will reload and you may be required to log back in.
    7. Re-run the 'Inventory' job associated with the device and update the containers/folders in UMP as needed

     

    Following these 7 steps, we have successfully correlated QOS data in UMP. I hope others, who have run into these same issues, have the same results.

     

    Environment:

    UIM 8.4 SP2

    HUB 7.80

    Controller/Robot 7.80

    Discovery_server probe 8.42-DevCor-SNAPSHOT

    Discovery_agent 8.41



  • 2.  Re: Device Correlation

    Broadcom Employee
    Posted 03-10-2017 01:03 PM

    Hey Brett, do you have any plans to upgrade in the future? As mentioned in the UIM 8.5.1 release notes, there is increased functionality in the 8.51 discovery_server build.

    "Discovery_server v8.51 contains improved default device correlation logic and allows for a high degree of correlation customization."

     

    Check out this page here to see the new Device Correlation Configuration. That's a very helpful page that goes over correlation and how the new 8.51 discovery_server handles devices.

     

    I think, moving forward, you'll see fewer instances of these types of scenarios.



  • 3.  Re: Device Correlation

    Posted 03-15-2017 08:51 AM

    Thanks for the response Phillip, we do plan on upgrading. However, until then, this process has been working for us.

     

    -Brett



  • 4.  Re: Device Correlation

    Broadcom Employee
    Posted 03-12-2017 08:48 PM

    Hello, Hath91.

    Thank you very much for sharing this in the community. It is very helpful.

     

    FYI

    BAT - niscache cleanup & robot ID reset 

    This is my sample script which automates similar job.

     

    Regards,

    Yu Ishitani