DX Infrastructure Manager

Expand all | Collapse all

UIM Support on (SUSE 12 SP2) Linux OS

  • 1.  UIM Support on (SUSE 12 SP2) Linux OS

    Posted 06-14-2017 10:18 AM

    Hi,

    Do we have any option to add SUSE 12 SP2 servers in CA UIM 8.51 version?

    I have checked the compatibility matrix and came to know that Robot 7.80 & 7.91 won't support these type of OS. I have tried using 7.70 but its not working for me.. 

     

    Could anyone suggest me an idea to have this under UIM with all performance monitoring?

     

    @CA Technical Team, Please take this as a request and certify SUSE 12 SP2 also in 8.51 and upcoming versions.



  • 2.  Re: UIM Support on (SUSE 12 SP2) Linux OS

    Posted 06-14-2017 02:20 PM


  • 3.  Re: UIM Support on (SUSE 12 SP2) Linux OS

    Posted 06-14-2017 03:01 PM

    Alex, robot 7.92HF3 added support for SLES12SP2. I am running this today on that platform without issue.

     

    -Garin



  • 4.  Re: UIM Support on (SUSE 12 SP2) Linux OS

    Posted 06-15-2017 08:11 AM

    Hi Garin,

     

    I tried using the hotfix robot 7.92HF3.. But it's not working.. Can you give me the details how you rectified the issue using this hotfix? 



  • 5.  Re: UIM Support on (SUSE 12 SP2) Linux OS

    Posted 06-16-2017 03:36 AM

    Hello Sirajudeen, please open a support case for this request so I can provide you the necessary installer for it

     

    Kind regards,

    Britta Hoffner

    CA Support



  • 6.  Re: UIM Support on (SUSE 12 SP2) Linux OS

    Posted 06-16-2017 07:41 AM

    Hi Britta,

     

    I have an open case 00769920 for this issue. Could you please give me the request with reference to it or do i need to open a new one for it?



  • 7.  Re: UIM Support on (SUSE 12 SP2) Linux OS

    Posted 06-15-2017 10:51 AM

    The "support" issue with SLES12SP2 is that the methodology (or response to the existing method) of identifying the running version of the OS changed. Pretty much any controller version older than 7.92HF3 will run but you can't install any additional packages that require the identification of the OS type or version.

     

    You don't indicate what your error is or what you have running already or not so here's the couple things that I did to account for the varying scenarios.

     

    You have to get a version of nimsoft running on the robot to start. If you are on SLES12SP2 you have a chicken and the egg issue - can't run the installer because it asks the controller what version you are running. The really crude solution is to find a similar bittedness Linux system with UIM already running on it and just copy the whole /opt/nimsoft directory structure to your new machine. If you search the help docs there are instructions on how to create the startup files if you're not familiar with that. I think that the documents on how to run two robots on one server include that and that is a recent conversation topic item on the forum.

     

    Whatever way you go about it, once you have a non-7.92HF3 version running, you then are faced with defeating the OS and version checks in the install package.

     

    I just made a copy of the robot_update package and then deleted all the tabs that didn't apply to the exact version I was installing. Make sure to remove the criteria fields on each tab so that the controller doesn't have to check the OS on the local system.

     

    Then drop that on the new system. It should install and replace whatever you copied over there to boot strap things.

     

    When that is complete, you will have the HF3 version of the controller running on that system but the package name, version and build numbers may be wrong. That can be fixed by dragging the unmodified official HF3 version onto the robot and allowing it to replace the previous install.

     

    At this point I'd suggest that if you have a number of these systems to do, tar up the /opt/nimsoft directory so that you can use it on the next system. Will save a couple steps.

     

    If you push your support person, perhaps they can add to the need to release a native infrastructure installer that includes this SLES12SP2 support from the start. 

     

    Also if you are copying Nimsoft installs around, don't forget to empty the contents of /opt/nimsoft/niscache 

     

    -Garin



  • 8.  Re: UIM Support on (SUSE 12 SP2) Linux OS

    Posted 06-23-2017 06:30 AM

    Hello, Garin.

    Thank you very much.

     

    Just FYI.

     

    We verified that Robot_Update 7.92 HF3 solved the below problem too.

     

    > Unable to deploy any probes on RHEL robot after glibc was upgraded to 2.2