DX Infrastructure Management

Expand all | Collapse all

Discovery_server isn't communicating with the discovery_agents

  • 1.  Discovery_server isn't communicating with the discovery_agents

    Posted 07-02-2015 09:01 PM

    Hi,

     

    On my infrastructure i have one discovery_server and two discovery_agents, one for servers and one for snmpcollector, but the communication between them is presenting error like show below:

     

    Discovery_server

     

    02 Jul 2015 21:43:26,736 [main] WARN  com.nimsoft.discovery.server.probe.ProbeInitializer - Waiting to initialize UDM. Retrying... : clojure.lang.ExceptionInfo: Transactor request timed out {:db/error :peer/request-timed-out, :request :start-database, :result #<Object java.lang.Object@17911e38>}

    02 Jul 2015 21:44:33,566 [main] WARN  com.nimsoft.discovery.server.probe.ProbeInitializer - Waiting to initialize UDM. Retrying... : clojure.lang.ExceptionInfo: Transactor request timed out {:db/error :peer/request-timed-out, :request :start-database, :result #<Object java.lang.Object@37d9f14f>}

    02 Jul 2015 21:45:48,415 [main] WARN  com.nimsoft.discovery.server.probe.ProbeInitializer - Waiting to initialize UDM. Retrying... : clojure.lang.ExceptionInfo: Transactor request timed out {:db/error :peer/request-timed-out, :request :start-database, :result #<Object java.lang.Object@1ac05bcb>}

     

    Discovery_agent

     

    Jul 02 21:58:37:877 INFO  [DiscoveryLauncher, discovery_agent] Waiting to receive initial central configuration from Discovery Server. Discovery is delayed.

    Jul 02 21:58:52:878 INFO  [DiscoveryLauncher, discovery_agent] Waiting to receive initial central configuration from Discovery Server. Discovery is delayed.

    Jul 02 21:59:07:880 INFO  [DiscoveryLauncher, discovery_agent] Waiting to receive initial central configuration from Discovery Server. Discovery is delayed.

     

    Anybody know or have already see this problem?

     

    Thank You



  • 2.  Re: Discovery_server isn't communicating with the discovery_agents

    Posted 07-02-2015 11:57 PM

    You need to ensure that the udm_manager probe is running and successfully connected to your underlying database. Or follow https://na4.salesforce.com/articles/HowToProcedures/How-to-use-discovery-server-verion-8-x-with-CA-UIM-7-6?popup=true to disable publishing to UDM.

     

    -Garin



  • 3.  Re: Discovery_server isn't communicating with the discovery_agents

    Posted 07-06-2015 11:54 AM

    It sounds like it could be something like the Discover Agent is waiting on config because the Discovery Server has not started yet.  The Discovery Server has not completed its startup process because it is having UDM connection problems.  Are you seeing any errors in the UDM Manager log?  Are both the Discovery Server and UDM Manager running on the same Robot?   This sounds like something that Support should be able to assist you with.

     

    Jim Cooke, Product Manager, UIM Core Services