DX Infrastructure Manager

Expand all | Collapse all

**** Defect Announcements ****

Anon Anon

Anon Anon03-19-2015 08:03 PM

  • 1.  **** Defect Announcements ****

    Posted 11-13-2014 11:11 PM

    **** Defect Announcements ****

    Since the Announcements section is not used on the official support page I'll create one in here where most folks check.

     

    I'll keep this thread going with new finding, bugs, defects that I find in the GA probes so others will become aware of issues:

     

    NOTE:

    If posting a new defect please include the following information regarding the defect so others can quickly identify if they would be effected by the defect you found. Please start the post off with:

     

    UIM Version #.#       Exp:   UIM 7.5

    UIM Component:        Exp:  UMP, HUB, Portlet - USM, SLM, etc...

    Probe_Name v#.#       Exp:  CDM 5.10

    OS Running:           Win|Lin|Unix

    Description of Defect:

    TAGS:  <key words regarding the defect, include the probe name if probe is part of the defect. Very helpful as this will allow others to find the defect when searching.>

    Ex: cdm, breaks, threshold, false, alert, hub, slow, etc....

     

     

    So here to start off:  

    ------------------------------------

    UIM:  7.5 / Robot Base v7.62 Build # < 1330  Fixed in Latest Robot Build 7.63

    Bad robot build of v7.62.  Found 10/22/14

    If you have Robot version 7.62 and the build is not 1330 you really need to upgrade to the latest build 1330 and re-deploy. The issue was whenever the robot went down, machine rebooted, service stopped the robot would automatically un-register itself from the hub and thus you would never get an Robot is inactive alert. It would just remove itself from under the HUB.

    FIX Solution: 12/12/14:  Update Robot to latest version with Build >= 1330.

    ------------------------------------

    UIM 7.5, Probe: NTEVL v4.01  HIGH CPU Usage 10/30/14 - Fixed in ntevl v4.02

    With our current ntevl v4.01 if you have many exclusions in your ntevl profile, with this latest version it eats up CPU cycles on the machine. Downgrade to v3.84. I had another issue with v3.90 where I had bad memory leaks on Exchange Servers running the 3.90 ntevl probe. So far v3.84 seems to be w/o issues for me.

    2/5/2015: Latest version of NTEVL 4.02 CPU usage finally is back to normal.

    ------------------------------------



  • 2.  Re: **** Defect Announcements ****

    Posted 03-19-2015 08:03 PM


  • 3.  Re: **** Defect Announcements ****

    Posted 02-03-2015 11:15 PM

    Perl-SDK >= 5.05 in windows 32 bit segfaults.  5.04 works bug has a bug related to daemon probes and lacks CMDB/NIS2 related calls.

     

    Version 5.05 and 5.06 segfaults when loading the nimbus apis. This happens with both toolkit and Nimbus::API.

     

    5.04 works as expected. I tracked this down to the "bootstrap Nimbus::API $VERSION;" line which loads the API.dll. Leaving 5.05 or 5.06 deployed and just swapping in the 5.04 API.dll fixes the issue.  (Not a recommended workaround, just a conformation of where segfault is.)

     

    Public change logs are sparse in 5.05 and non-existent for 5.06. 5.05/6 works well in 64 bit windows and all variations of Unix.

     

    A workaround is to use SDK_Perl 5.04, but this lacks the NIS2 calls added in 5.06.  5.05 also contains a bug preventing Win32 from automatically registering the port when establishing a server session.

     

    The bug in question is listed as fixed defect in 5.05 "Win32 server port retrieval fix." I can tell you exactly what that means. When you start a Nimbus::smileyfrustrated:ession->server, it's supposed to report the port back to the controller. The end result is that server session is unusable, thus creating a daemon (not timed) probe with Perl_SDK 5.04 fails unless you use a workaround by to manually register the port with the controller after establishing the session.

     

    my $session = Nimbus::smileyfrustrated:ession->new($prgname);

    if ( $session->server(NIMPORT_ANY, \&timeout, \&restart) == NIME_OK ) {

         nimRegisterProbe($prgname,$ENV{NIMPROBEPORT});

    } else {

         die "sucks" ;

    }

     

    Of course this still won't allow you to associate alarms with ci data since those functions are not in 5.04.  Kind of makes you wonder how fixing the Win32 specific bug in 5.05 was tested if the dll causes segfaults?

     

    5.05 was released May 2013.

    5.06 was released Dec 2013.

    I discovered and reported the segfault Nov 2013.

    No ETA yet on a bug fix.



  • 4.  Re: **** Defect Announcements ****

    Posted 07-31-2015 05:16 PM

    Found this problem in latest version of the vmware probe.

    By default it tries to start up with:

    -Xms32m -Xmx128m -Duser.language=en -Duser.country=US

     

    Then the issue occurs after you add a resource. The probe just breaks. When you try to open the probe, you get the following error:

    Key Host not Found.

    Then to fix this you need to bump up the starting memory usage to the following which worked for me in the probes RAW CONFIG > startup > options  mode:

    -Xms256m -Xmx2048m -Duser.language=en -Duser.country=US



  • 5.  Re: **** Defect Announcements ****

    Posted 06-09-2015 03:52 AM

    sqlserver 4.91 template overrides static profile checkpoint


    If you change a profile checkpoint to static and remove all checkpoints from it, the probe will read the checkpoints from the template.



  • 6.  Re: **** Defect Announcements ****

    Posted 09-23-2018 12:39 PM

    7.93 HF 10 Robot is out which supports Ubuntu 18 



  • 7.  Re: **** Defect Announcements ****

    Posted 07-15-2015 10:27 AM

    net_connect version 3.10 - Cannot modify default host parameters

     

    When trying to modify the default host parameters and clicking OK to save, you are prompted with a "Please enter a valid IP address" error. This is not needed in the default host parameters, and even if you wanted to enter an IP you can't because that field is greyed out. Support case has been entered.



  • 8.  Re: **** Defect Announcements ****

    Posted 11-14-2014 06:06 PM

    Also:

    Bad build of the robot_exe v 7.62 - using with bulk deployment, third party (SCCM), the robot will not register as service

    Bad build of the robot_aix v 7.62 - using with ADE, will receive net.lingala.zip4j exception saying file headers not found



  • 9.  Re: **** Defect Announcements ****

    Posted 02-27-2017 03:53 PM

    Tech Tip: Alarm Enrichment probe not processing alarms 

     

    UIM 8.4 SP2 Alarm_Enrichment probe stops working   alarm flow stops alarms defect bug



  • 10.  Re: **** Defect Announcements ****

    Posted 03-18-2015 06:47 PM

    Bumping...Since the move this got buried in the new site.



  • 11.  Re: **** Defect Announcements ****

    Posted 02-27-2017 04:00 PM

    Another confirmed defect with vmware probe and audit probe. Several times a day we have many different instances of our vmware probe crash and get corrupted when applying changes. Turns out that if you have the audit probe enabled it seems to contribute to this. There is a defect # and is waiting a fix. Running vmware 6.72 and latest audit 1.22 and issue is still exists.



  • 12.  Re: **** Defect Announcements ****

    Posted 04-08-2015 10:55 AM

    Defect Version 8.2

    Component: HUB Probe

    Description: Tunneling issue with communicating on ports other than the specified 48000 range.

    Fix: Update to hub version 7.71

    Linking Post: https://communities.ca.com/message/241782995#241782197

     

    Defect Version 8.2

    Component: controller \ robot ports

    Description:

    "It seems robot v7.70 has broken proxy_mode. We use proxy_mode extensively, and it seems when you enable proxy_mode on 7.70, controller ALWAYS binds to 48001, preventing spooler from starting (and all other probes)."

    Fix\Workaround:

    Then, after we upgraded to 7.70 at 11:34am today, you see it bound to 48001. Then we tested by setting proxy_mode to 0, and first_probe_port to 48000. Then you can see it binds as expected to 48000, and it works.

    We then enabled proxy_mode again, and removed first_probe_port (used to cause problems with proxy_mode), and it binds to 48001, and spooler refuses to start.

     

    Linking post: https://communities.ca.com/message/241782995#241783149



  • 13.  Re: **** Defect Announcements ****

    Posted 05-01-2015 04:39 PM

    Dirscan profiles created through the admin console directory browser create invalid directory paths. The paths end in an "\" whereas profiles created with IM don't have it, and dirscan probe seems to be unable to handle directories that end like this. This seems to be the case with at least the latest dirscan probe. This has also been recognized as a bug by support and they're in the process of raising a defect.

     

    I'm not actually sure if you get an alarm about this unless you're using a "directory exists" checkpoint.

     

    -jon



  • 14.  Re: **** Defect Announcements ****

    Posted 03-31-2016 08:15 AM

    exchange_monitor probe - there is a defect with the perfmon probe used by exchange_monitor where the perfmon probe creates millions of useless CI's in the niscache directory which then are pulled in by discovery.

    Fix is available from support with new package and also additional configurations for process monitors from perfmon - perfmon probe version 1.63-T



  • 15.  Re: **** Defect Announcements ****

    Posted 09-22-2015 03:34 PM

    Found something in logmon probe, default profiles that come with the probe from archive - there are sections in the UNIX logmon.cfx files as part of the package that have a start expression that has an xml tag of sorts which will throw the logmon probe off in reading the config file if left in the config.  I have a case open with Support but my workaround was to clear these sections of the config on ALL UNIX systems with logmon probe.

     

    Section that causes the issue

    <clusterblock>

    active = yes

    start = *<insert_your_START_expr>*

    lines = 0

    </clusterblock>

     

    logmon config created to deploy through distsrv to the UNIX systems to clear the default profile sections.

    <profiles> overwrite

       <sulog> clear

       </sulog>

       <system_messages>clear

       </system_messages>

       <my_log> clear

       </my_log>

    </profiles>



  • 16.  Re: **** Defect Announcements ****

    Posted 03-31-2015 01:12 PM

    Defect Exists in: Nimsoft v7.5 - UIM v8.x

    User Tags do not show up in UMP till after cycling Primary Hub services.

    Description: So hit a bug where I added User Tags to a group of robots w/in their Controller Probe. UIM services on those robots cycled and then waited for those updates to be reflected against those robots in the UMP b/c I wanted to create a group based on those UserTags. Yet it never showed up. Waited a hour + and never updated. I tried cycling the UMP services but didnt' fix it. It wasn't until I cycled the Primary Hubs' UIM services did the new UserTags show up against those robots.

    Work around was to write a SQL Query to update the user_tag_1 property on the specific robot entries that matched my query in the respective database.

     

    UPDATE NimsoftSLM.dbo.CM_NIMBUS_ROBOT

    SET user_tag_1 = 'XXXX'

    WHERE robot like ('%robot_name_search_criteria%')

     

    ID of DE41418 Fix eta in summer of 2015.



  • 17.  Re: **** Defect Announcements ****

    Posted 07-27-2016 11:24 AM

    Deploying new probes that require the Visual C++ re-distributables 'could' reboot the target box. Yes Reboot the target box. This happened to me on 3 machines when deploying to a group of 100 robots. The newest cdm probe v5.72 in the Miscellaneous tab,  pushes out vs2010sp1_vcredist_x64.

    cdm and processes probe both push out this vs2010sp1_vcredist_x64 package so be careful when deploying this.



  • 18.  Re: **** Defect Announcements ****

    Posted 04-17-2018 09:03 AM

    Hello, anyone else having issue with Maintenance not working? We are setting maintenance in USM (have been for years working fine) and with the latest maintenance_mode 8.53 hotfix I've been having alerts from boxes in maintenance showing up in the console.

     HotFix:

    CnIa24uJ@ftp.ca.com/UIM_Probe_Hotfixes/maintenance_mode-8.52-HF1.zip" rel="nofollow" style="color: #208dd6; background-color: transparent" target="_blank">maintenance_mode-8.52-HF1.zipCnIa24uJ@ftp.ca.com/UIM_Probe_Hotfixes/release_notes/maintenance_mode-8.52-HF1.txt" rel="nofollow" style="color: #34aeff; background-color: transparent" target="_blank">maintenance_mode-8.52-HF1.txt


  • 19.  Re: **** Defect Announcements ****

    Posted 02-03-2015 05:18 AM

    Found a defect with the CDM probe (v5.10) which has been acknowledged by support as a logged defect with ID# DE39700

     

    The problem is that when using the Admin Console to configure the probe to capture QOS data for the Disk Read B/S and Disk Write B/S metrics by selecting "Publish Data", it generates alarms even though you don't tick the "Publish Alarms" check box.

     

    Workaround from support is:

     

    1. In the Admin Console first check the “high and low” threshold(NOT PUBLISH ALARMS) for the same metric and then uncheck and click save.

     

    2. Or you can Open the cfg in notepad ,under the disk>>alarm section you will get these 6 section according to QOS enabled
    1. disktotal error
    2. disktotal warning
    3. diskread error
    4. diskread warning
    5. diskwrite error
    6. diskwrite warning
    In the above sections, all 6 or as per your need add a key active with value no “active = no” to disable the alarms.
    For Eq:
    <diskread error>
    message = DiskRateError
    description = Read Throughput
    threshold = 0
    active = no
    </diskread error> 

     

    The CDM probe v5.11 was released a day or two after I was given this defect number, so I doubt the defect has been resolved yet, and there is no mention of it in the release notes.



  • 20.  Re: **** Defect Announcements ****

    Posted 11-19-2014 10:05 PM

    Hub 7.61 

     

    Client request over a tunnel receives a TCP/RST and the connection is closed before data transfer of response finishes under
    specific circumstances. NIME_COMM and nimSessionGetLastError=104 filter through to the requester and the TCP connection is reset by the hub before completing transmission. Gui config tools usually report this as a communication error. The hub on the request side logs cadence check SSL, while the remote end logs successful transmission of response at high debug levels.


    The trigger seems is extra latency in the network on the response receiving end of the tunnel along with a large response to a callback.  IE: requester<VPN<hub<tunnel<hub<destination.  Tunnels got faster in 7.61 which flushed out the related bug that only appears when latency on the last hop of the response is greater than latency accross the tunnel.

     

    Fixed in a 7.62 hub beta is available through support if you run into it. Last report was that it missed a cutoff for the next GA, but will likely make it into a GA release in January.



  • 21.  Re: **** Defect Announcements ****

    Posted 12-11-2014 07:41 PM

    I ran into another bug the other day with UIM v8.0 and running the (Windows Infrastructure (HUB, distsrv and Robot) installation from Build 803) DMZ Setup Wizard on a 2012 R2 machine.

    The hub portion installed fine, but when it got to the DMZ Setup Wizard the 8.0 version would constantly crash. I ran it 2-3x and crashed every time. 

    When I ran the 7.6 version it worked perfectly fine. Didn't open an issue yet but just wanted to throw this out there as a FYI.

     

     



  • 22.  Re: **** Defect Announcements ****

    Posted 05-09-2017 01:28 PM

    Just wanted to be reply 100.....

     

    Hub 7.92HF2 was supposed to be posted yesterday at CA Unified Infrastructure Management Hotfix Index - CA Technologies 

     

    -Garin



  • 23.  Re: **** Defect Announcements ****

    Posted 07-06-2015 05:28 PM

    Logmon 3.5x probe crashes (on all) and core dumps (those where its enabled) Linux systems when the watcher has spaces in the expression to match.  This was duplicated by CA support and defect issued - DE45983



  • 24.  Re: **** Defect Announcements ****

    Posted 10-29-2015 04:29 AM

    Mobile client for Android is showing only white screens when running on Lollipop. Only thing available in screens is the number of alarms.

     

    It is a known defect, fix will come possibly when UIM 8.4 is released.

     

    /teppo



  • 25.  Re: **** Defect Announcements ****

    Posted 04-18-2018 04:22 AM

    Minor issue with USM and cdm v6.30 when using those new disk free QOS features. If you enable those disk free features, then USM also will show those, but instead of showing QOS_DISK_FREE_PERC it puts QOS_DISK_FREE there and will show it as percentage; so if you have 42136MB free in disk, it is shown as 42136% and when that is then put on graph where scale is 0-100 then the Details page's graphs will get a bit scrambled. It is now a known defect.



  • 26.  Re: **** Defect Announcements ****

    Posted 09-21-2017 05:56 AM

    New admin console (UIM 8.47+) seems store something in binary tmp* files in its wasp directory. This happens most often when one works with probes having large config files, then intermittently the admin console forgets to delete those tmp files. So in come case there can huge number of those tmp* files. We had hundreds of those.

     

    This is now a known defect. Anyway we created dirscan profile to monitor and manage those files.



  • 27.  Re: **** Defect Announcements ****

    Posted 10-27-2015 07:00 AM

    ntservices 3.23 doesn't seem to work at leats on 2012R2. it discovers some services and puts them into the config file and then hangs. Apparently has to do with the way it handles some custom cfx  that works with previous versions

     

    -jon



  • 28.  Re: **** Defect Announcements ****

    Posted 06-07-2016 09:42 AM

    ntservices v3.25 broke again with deploying our latest version with our custom cfx file. Same issue reported above with the release of v3.23. Case opened.



  • 29.  Re: **** Defect Announcements ****

    Posted 01-22-2015 05:51 PM

    ntperf/ntperf64: Comparisons don't do anything nor trigger any alarms in the ntperf probe. 

     

    ntperf / ntper64 probe v1.86-*1.89 *edited: tested with the latest version that was released today 1/22/15 and still broken Did anyone test this probe?*

    Created a simple WMI query on Memory Usage on the box the probe was deployed. Grabbed the current Memory Usage value and set alert to Generate an alerts if != 500. Apply and no alarm getrs generated. Log shows the values do not match yet no alarms is triggered. basic probe functionality doesn't work. Both versions x86 and the x64 bit dont. Tested on Windows 2012 4-bit machine. 

     

    Okay updating this based on the totally insane response from Level 2 support. This probe has oppisite logic.

     

     

    So when using and configuring this the ntperf probe, you have to read the metric your setting up as the following statement: "The expected value is: X = Y, if not then trigger an alert" 

     

    For instnace you want to monitor Memory Usage and trigger an alert when Memory usage < 100MB. (just and example) you would setup your WMI query on Memory then Available Memory. On the "Alarm on Value" tab, you would think you would set the comparison to  < 100 trigger an alert. But no. The probes logic is I expect the value to be < 100. So if memory was 200 it would trigger an alert. You would have to switch the Threshold Operator to > 100. :smileyfrustrated:

     

    So this is going right back to development for them to fix this. No other probe follows this logic. We don't configure the CDM probe to say I don't expect the C:\ drive to be < 10% but if it does then throw an alert. No we just say, if Free Space < 10 then throw an alert. 



  • 30.  Re: **** Defect Announcements ****

    Posted 04-17-2018 02:21 PM

    Ok nas has to be set to at least log level 3 to show this info...



  • 31.  Re: **** Defect Announcements ****

    Broadcom Employee
    Posted 07-27-2016 02:06 PM

    Please check the online Archive for vs2010sp1_vcredist_x64 & vs2010sp1_vcredist_x86.



  • 32.  Re: **** Defect Announcements **** ironic ppm infinite recursion suicide.

    Posted 01-08-2015 11:14 PM

    Ppm's job is primarily to get ctd data for adminconsole as far as I can tell.  It's hardly documented.  

     

    As of ppm 3.03 UIM 8.1 and possibly earlier, ppm will repeatedly delegate getting the ctd information to itself until it exhausts it's allocated memory or exhuasts the sockets available to it.

     

    The trigger is selecting configure from the admin console for the ppm probe. Adminconsole requests the ctd info from ppm which requests it from itself ...  You'll see the results in the log and netstat.  Eventually admin console will timout the request, but ppm will still keep going like the little engine that sucks.



  • 33.  Re: **** Defect Announcements ****

    Posted 04-01-2015 04:15 AM

    Robot 7.70 seems to have problems with communication. This is my setup: Primary connects to tunnel proxies without tunnel. Tunnel proxies connect to client hubs through tunnels. If I install controller 7.70 on tunnel proxy, all communitcations from primary hub to hubs behind the tunnel proxy stop working. If I downgrade to 7.63, it starts working again. Tested several times. Hub version didn't seem to matter.

     

    -jon



  • 34.  Re: **** Defect Announcements ****

    Posted 07-06-2015 06:01 PM

    robot_update 7.05 / 7.6X / 7.70 controller defect related to probe license update not working.  This is not documented in the fixed defect product information for robot_update 7.80

     

    https://na4.salesforce.com/articles/Case_Summary/Probe-license-update-is-not-working?popup=true



  • 35.  Re: **** Defect Announcements ****

    Posted 05-19-2015 04:04 AM

    snmptd creates profiles wrong for dell (at least rac) mibs when create from the trap browser. If created from the trap monitor, they're done correctly.

     

    There's defect DE43371

     

    -jon



  • 36.  Re: **** Defect Announcements ****

    Posted 03-29-2016 06:48 AM

    Static Containers disappearing from UMP and turning to group.



  • 37.  Re: **** Defect Announcements ****

    Posted 05-01-2015 12:29 PM

    Processes Probe Breaks with profile set to watch memory > 100MB

    UIM 8.2

    Broken in Processes Probe >= v3.83 - v3.93

    I noticed in the latest version this broke (3.93) that my old template stopped working. When I disabled the Memory Metric that I setup to watch all processes > 1GB the probe would not function. As soon as I turned it off it started working again. Needed to back down to version 3.82 for it to work again.

    Defect has been noted by UIM support.



  • 38.  Re: **** Defect Announcements ****

    Posted 09-11-2017 10:51 AM

    So not sure why this is still available but if your using the url_response probe and have it configured using a version older than 4.42 then upgrade to version 4.42 all your profile will break with the error: "Protocol not supported"

    Was running 4.30 then upgraded and all my profiles started throwing this error to the console. 

    Support was aware of issue and provide hot fix yet they still have the broken GA 4.42 version up in the archive. 

    TF is available but no idea why the GA is still up when it causes this known issue on upgrade.



  • 39.  Re: **** Defect Announcements ****

    Posted 01-24-2018 05:07 PM

    So this i hit when doing a global update to v7.93 and started having communication issues 1/2 thru.

    Found out it was a known defect!!! Wow again thanks for the heads up UIM. 

    Here is what should be in place if your updating to v7.93:

    Avoiding communication errors when configuring UIM components and improving tunnel stability for hub-to-hub tunnels 



  • 40.  UIM-8.1 ppm-3.02 3.03 and 3.04 upgrades do not work.

    Posted 02-12-2015 01:01 AM

    The good news is that the 3.04 ppm fixes the infinite recursion ppm bug reported earlier.  The bad news is that you have to delete the probe from you robot, then install 3.04 fresh, but even that might not be 100% effective.

     

    I upgraded the probe and it wasn't fixed. Checked the log and it's reporting itself as 3.02. Note, I had upgraded to 3.03 previously, and the controller reported that 3.04 was installed.

    I found the problem in lib. Apparently there are versioned ppm.jar files being installed and the old ones are never cleaned up. I believe java is trying ppm.jar first when resolving the library.  I'm not sure how it chooses but it was consistently coming up with 3.02 which I believe is the default installed with UIM-8.1.   Anyway, moving all of the ppm*jar files except the 3.04 versioned one out of nimroot/probes/service/ppm/lib got it to successfully strart and report 3.04 which then successfully passed the bug test.

    Unfortunately this looks like another bug, and whomever is using 3.03 expecting those bugs to be fixed after an upgrade may not be seeing any of those patches working either. :smileysad:

    [nimroot/probe/service/ppm]$ ls -lt lib/ppm*.jar
    -rwxrwSrwx 1 nimbus sshusers 6340390 Feb 11 15:14 lib/ppm-3.0.4.jar
    -rwxrwSrwx 1 nimbus sshusers 6336302 Jan 7 15:06 lib/ppm-3.0.3.jar
    -rwxrwSrwx 1 nimbus sshusers 6336316 Jan 6 11:30 lib/ppm-3.0.2.jar
    -rwxrwSrwx 1 nimbus sshusers 6291487 Dec 19 15:39 lib/ppm.jar

     

    You might be able to work around this by uninstalling ppm first, but if you have already upgraded, you may have lost a reference to one of the versioned ppm.jar files and it wouldn't be uninstalled.

     

    MPSE seems to leave crufty old version libraries behind too after updates, but at least it calls the version mpse jar in startup args.  There is no simple way of knowing how many of the updated libraries it requires to operate as expected or which ones it's using.

     

    [nimroot/probes/service/mpse]$ ls -lt cimanager_bundle-8* ctdbase-2* ctdextension-2* ctdgraph-2* ctdtemplate-2* ctdutil-2* mpse-1* nimclient-core-1* nimclient-model-1* nimclient-probes-1* nimsoft-SDK-2* pf-common-2* stax-api-1*
    -rwxrwSrwx 1 nimbus sshusers 23346 Jan 6 11:28 stax-api-1.0-2.jar
    -rwxrwSrwx 1 nimbus sshusers 26514 Jan 6 11:28 stax-api-1.0.1.jar
    -rwxrwSrwx 1 nimbus sshusers 356419 Jan 6 11:28 pf-common-2.5.0.jar
    -rwxrwSrwx 1 nimbus sshusers 387639 Jan 6 11:28 mpse-1.6.4.jar
    -rwxrwSrwx 1 nimbus sshusers 26161 Jan 6 11:28 nimclient-core-1.6.5.jar
    -rwxrwSrwx 1 nimbus sshusers 6200 Jan 6 11:28 nimclient-model-1.6.5.jar
    -rwxrwSrwx 1 nimbus sshusers 25126 Jan 6 11:28 nimclient-probes-1.6.5.jar
    -rwxrwSrwx 1 nimbus sshusers 178299 Jan 6 11:28 nimsoft-SDK-2.9.25.jar
    -rwxrwSrwx 1 nimbus sshusers 337236 Jan 6 11:28 ctdbase-2.4.0.jar
    -rwxrwSrwx 1 nimbus sshusers 223457 Jan 6 11:28 ctdextension-2.4.0.jar
    -rwxrwSrwx 1 nimbus sshusers 65866 Jan 6 11:28 ctdgraph-2.4.0.jar
    -rwxrwSrwx 1 nimbus sshusers 16008 Jan 6 11:28 ctdtemplate-2.4.0.jar
    -rwxrwSrwx 1 nimbus sshusers 50872 Jan 6 11:28 ctdutil-2.4.0.jar
    -rwxrwSrwx 1 nimbus sshusers 1518021 Jan 6 11:28 cimanager_bundle-8.1.0-2014-12-18.jar
    -rwxrwSrwx 1 nimbus sshusers 292472 Jan 5 14:11 pf-common-2.4.0.jar
    -rwxrwSrwx 1 nimbus sshusers 176378 Jan 5 14:11 nimsoft-SDK-2.9.23.jar
    -rwxrwSrwx 1 nimbus sshusers 24915 Jan 5 14:11 nimclient-probes-1.6.4.jar
    -rwxrwSrwx 1 nimbus sshusers 6198 Jan 5 14:11 nimclient-model-1.6.4.jar
    -rwxrwSrwx 1 nimbus sshusers 26161 Jan 5 14:11 nimclient-core-1.6.4.jar
    -rwxrwSrwx 1 nimbus sshusers 387102 Jan 5 14:11 mpse-1.6.3.jar
    -rwxrwSrwx 1 nimbus sshusers 48460 Jan 5 14:11 ctdutil-2.3.0.jar
    -rwxrwSrwx 1 nimbus sshusers 15365 Jan 5 14:11 ctdtemplate-2.3.0.jar
    -rwxrwSrwx 1 nimbus sshusers 63258 Jan 5 14:11 ctdgraph-2.3.0.jar
    -rwxrwSrwx 1 nimbus sshusers 223453 Jan 5 14:11 ctdextension-2.3.0.jar
    -rwxrwSrwx 1 nimbus sshusers 310017 Jan 5 14:11 ctdbase-2.3.0.jar
    -rwxrwSrwx 1 nimbus sshusers 1468152 Jan 5 14:11 cimanager_bundle-8.0.0-2014-09-12.jar



  • 41.  Re: **** Defect Announcements ****

    Posted 11-14-2014 09:04 AM

    There are a lot, but one from this morning:

     

    3. ntservices (at least 3.12 and 3.15) can't handle services that have < > in the service name, and text after that. They appear in the profile list, but you can't activate them (even through raw config)

     

    -edit: actually fixed in 3.16, though updating doesn't solve it without deleting some of the service sections

     

    -jon



  • 42.  Re: **** Defect Announcements ****

    Posted 02-03-2015 05:26 AM

    There was a defect with hub 7.61 (the GA version that was released with UIM 8.0) which was performance related, and caused issues with being able to open the interface_traffic configuration (refer to this article for more info). Anyway, the issue was resolved in a release of hub 7.62 which wasn't published in the archive, and was only available from support. I was able to verify with support that the new hub version resolved my exact issue as per the article.

     

    However, after upgrading UIM to 8.1, and subsequently the hub probes being upgraded to the new GA version of 7.63, I began experiencing the same problem again. After logging another ticket with support, it was referred to backline, and I was told that the fix that was implemented in hub 7.62 was LEFT OUT of the 7.63 build!! A new hub release coming soon will apparently have the fix back in it again.

     



  • 43.  Re: **** Defect Announcements ****

    Posted 12-23-2015 05:32 AM

    There seems to be some issues in the way some SDKs / probes handle float value fields in PDSs which may lead to queue issues. I'm waiting for CA to confirm this, wrote a blog entry detailing it Queue issues

     

    -jon



  • 44.  Re: **** Defect Announcements ****

    Posted 01-13-2015 09:08 PM

    UMP 8.1 installer deploys dashboard_engine and dap legacy probes to the UMP server by default with dashboard_engine enabled and dap disabled.  For some reason the dashboard_engine subscribes to all qos from the root hub, possibly a change from older versions or a behaviour that happens in the absense of a running dap or variable server.  In a large environment, the dashboard_engine falls behind on the subscription and backlogs huge amounts of qos on the root hub which will fill the partitiion if unchecked.  Dashboard_engine and dap are only to support deprecated legacy dashboards.

     

    Changing java memory settings and enabling dap and/or variable server might fix the issue if you need legacy dashboards.  Disable it if you don't need legacy dashboards.



  • 45.  Re: **** Defect Announcements ****

    Posted 05-09-2017 10:44 AM

    Upgrade to 7.91 fails to rename files if PATH exists

     

    If you are upgrading to 7.91 robot version make sure you check that your controller probe doesn't have the environment variable:   PATH = " "   (a space)

    This was recommended for a specific vmware probe issue but now if you have this in place and occasionally if you upgrade to 7.91, the upgrade will fail. The is a rename step that fails to rename and the robot will not start back up. 

    Work around, remove the PATH=" "  entry in the controller probe first, apply then upgrade robot to 7.91.

    You don't need the PATH var any longer in the latest version anyway.



  • 46.  Re: **** Defect Announcements ****

    Posted 06-24-2015 09:29 AM

    Wow, this one is REALLY bad folks. DO NOT USE ADE to update HUBS. It will delete all critical files out of the remote hubs folder like the hub.exe, hub.cfg etc.. and the remote hub will stop working.

    UIM 8.2

    ADE 8.2

    HUB 7.71

    Robot 7.70

    If you try to deploy and update a remote hub using the ADE tool and push out current as of 6/23/15 hub v7.71 it will delete the nimsoft\hub\ hub.exe, hub.cfg, hub.* and that remote box is DOWN.

    To fix you have to get back onto the targeted box and re-run the Nimsoft Infrastructure.exe to repair. DO NOT DEPOY HUB PACKAGE USING ADE!!!!

    Robot_update deployment works, but do not run it against a hub. Use the IM tool to update hubs. Support reproduced the issue in house. This was 'tested' but obviously not.



  • 47.  Re: **** Defect Announcements ****

    Posted 04-01-2015 02:44 AM

    UIM 8.2 installer fails if primary hub has probes that do not have a "description" defined. You have to cancel the installer after the error.



  • 48.  Re: **** Defect Announcements ****

    Posted 08-01-2015 04:33 AM

    We had the same issue on vmware probe 6.51 (beta) . Besides we had a missing QOS values from DS_DISK_FREE  (percentage) because of missing HASMAX field in that specific QOS template. (you can add it in raw-configure qos templates, hasmax=100)

    A ticket has been created for these issues.



  • 49.  Re: **** Defect Announcements ****

    Posted 02-28-2017 01:36 AM

    Daniel, are you using IM or admin console for configuring vmware? We are seeing similar issues with oracle probe + admin console.



  • 50.  Re: **** Defect Announcements ****

    Posted 06-09-2015 12:21 PM

    DE44617

    Dirscan 3.12, running directory scan(not integrity profile) when you put the pattern to match into the profile and apply (using IM), the change is not saved to the config and looking at the config in raw configure mode, the pattern key is never even added.  In order to successfully configure, you have to create the profile then edit in raw configure and add the pattern key and value.

    Answer from support - deferred to future release - smh I believe the reason it was deferred is that this probe is slated to move to Admin Console only configuration in future release (pass the buck anyone?)



  • 51.  Re: **** Defect Announcements ****