IT Process Automation

Expand all | Collapse all

How to use resources operator ?

  • 1.  How to use resources operator ?

    Posted 03-28-2018 05:37 AM

    Hi,

    I have trying to use resources operator by following on line documentation here " Resources - CA Process Automation - 4.3.1 - CA Technologies Documentation " but nothing works.
    When I use it, operator become purple color (running) but resources are not used.

    Resouces

    Can somebody explain me step by step how to use resources operator please ?

    Thx!



  • 2.  Re: How to use resources operator ?

    Posted 03-28-2018 01:11 PM

    How many resources do you have in my resources, could you print it? aren't the resources locked?



  • 3.  Re: How to use resources operator ?

    Posted 03-29-2018 03:19 AM

    Marcel,

    As you can see on this screenshot

    I have 10 amount resources.



  • 4.  Re: How to use resources operator ?

    Posted 03-29-2018 08:52 AM

    The screenshots appear to show this setup properly.   I would recommend taking a look at the Out Of the Box, Predefined Content, example processes.    There is an example of resource operator usage:

     



  • 5.  Re: How to use resources operator ?

    Posted 03-29-2018 10:19 AM

    Hi Michael, I work with Filsbak

    we can't import "Out Of the Box" to see the example.

     

    When we try we have "Unable to download the out-of-the-box content from host support.ca.com"

    (probably because it's forbidden from our network)

     

    How can we get it ?



  • 6.  Re: How to use resources operator ?

    Posted 03-29-2018 10:48 AM

    You can download from the following community thread:
    https://communities.ca.com/docs/DOC-231177982-outofthebox-content-predefined-processes

     

    Just import the included .xml and you will have the predefined content to review!



  • 7.  Re: How to use resources operator ?

    Posted 03-29-2018 12:15 PM

    Thanks,

    we now have the predefined content, and we started process "Resources as a Pool" in PAM_PreDefinedContent/Process and Resource Mgmt/08 Resources as pool/

     

    It stays on first operator, so we think it doesn't work..

     

     



  • 8.  Re: How to use resources operator ?

    Posted 03-29-2018 12:24 PM

    That first operator is suppose to clear any lingering Resources in use at the time.  It seems like you guys are definitely having a problem with the resource usage.  
    We can try to troubleshoot here, but it would be better if you could open a case with the support team so we are not passing logs and screenshots in a public forum.



  • 9.  Re: How to use resources operator ?

    Posted 03-29-2018 12:27 PM

    ok, thanks, we already have a case opened for that problem.

    I'm going to update it to say we tried with the example in PAM_PreDefinedContent and that it doesn't work either.



  • 10.  Re: How to use resources operator ?

     
    Posted 04-05-2018 11:59 PM

    Just out of curiosity, have you tried running your process with the Resource object checked out to the PAM user account?  Please update the thread when you have a resolution from Support, I too have struggled with resources and will be interested to see what your eventual solution is.



  • 11.  Re: How to use resources operator ?

    Posted 04-30-2018 12:23 PM

    Hi James,

    yes I've tried and it doesn't work either

    Do you finally find a solution ?



  • 12.  Re: How to use resources operator ?

    Posted 04-05-2018 11:09 AM

    What the c2o.log says when the it's in this process?

    You guys should probably already figured it out but I'm curious



  • 13.  Re: How to use resources operator ?

    Posted 04-30-2018 12:35 PM

    I just tried with a process who tries this

     

    In logs there is"

    Evaluation of [Tape1] failed - ReferenceError: "Tape1" is not defined.

     

    Here is resource Resourcen/Tape:

     



  • 14.  Re: How to use resources operator ?

    Posted 04-30-2018 12:45 PM

    Does it help if you put Tape1 in quotes?  Might be trying to evaluate Tape1 as a variable and not a literal.



  • 15.  Re: How to use resources operator ?

    Posted 04-30-2018 12:54 PM

    Thanks to you, error message Evaluation of [Tape1] failed - ReferenceError: "Tape1" is not defined has dispared but it still doesn't work



  • 16.  Re: How to use resources operator ?

    Posted 04-30-2018 12:43 PM

    I just tried with /PAM_PreDefinedContent/Process and Resource Mgmt/08 Resources as pool/Resources as a Pool

    With this one, there is nothing in logs; but it doesn't work either.



  • 17.  Re: How to use resources operator ?

    Posted 04-30-2018 12:51 PM

    I see another error in logs but I don't know if there is a link with the test I'm doing

     

    2018-04-30 18:47:55,790 ERROR [com.optinuity.c2o.resources.C2OResourceManager] [)-172.27.36.156] Registering resource Release action with ID: d716aafa-69aa-4011-94eb-702f70cd22d6



  • 18.  Re: How to use resources operator ?

    Posted 05-09-2019 11:24 AM

    I'm getting the same error "Registering resource Release action with ID" logging every 5 minutes to the c20.log.  I'm running 4.3.3.  Is this error anything I should be concerned about?  The workflows that are "taking" and "freeing" resource units seem to be working okay.  Please advise.