IT Process Automation

 View Only
Expand all | Collapse all

Rest api processinstances doesn't show instances started by all user

Jump to Best Answer
  • 1.  Rest api processinstances doesn't show instances started by all user

    Posted Jan 16, 2018 12:07 PM

    Hi,

     

    we wan't to use Open Api to get information about process instances.

     

    When I start a process with a user, if I call the url (with the good instanceID)

    https://....//v1/processinstances/{instanceID}

    with same user, I can see the instance.

     

    If I call same url with another user, I get message "Error: Runtime instance with ID: {instanceID} not found"

     

    When I call https://....//v1/processinstances/ I think I only see instances started with user connected.

     

    Is that normal ?Do we have to change something in our users rights ?

     



  • 2.  Re: Rest api processinstances doesn't show instances started by all user

    Posted Jan 16, 2018 01:55 PM

    Hi,

    I just made some tests here and I did confirm that I only see processes started by the logged user, even though he has all possible roles of administration.

    It looks like some sort of bug

    When you do, in my example

     

    /processinstances/50171/processdataset

     

     

    I can see the process dataset,

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <Response>
        <Code>200</Code>
        <Details xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="processDatasetResponse">
            <ProcessDataset>
                <PathName>50171</PathName>
                <Parameters>
                    <Param>
                        <Name>ParentProcessROID</Name>
                        <Label>ParentProcessROID</Label>
                        <Type>String</Type>
                        <Value></Value>
                    </Param>
                    <Param>
                        <Name>RootProcessROID</Name>
                        <Label>RootProcessROID</Label>
                        <Type>String</Type>
                        <Value></Value>
                    </Param>
                    <Param>
                        <Name>Progress</Name>
                        <Label>Progress</Label>
                        <Type>Double</Type>
                        <Value>100.0</Value>
                    </Param>
                    <Param>
                        <Name>TouchpointName</Name>
                        <Label>TouchpointName</Label>
                        <Type>String</Type>
                        <Value>Orchestrator</Value>
                    </Param>
    ...

     

     

    but if I try to access the instance:

    /processinstances/50171/

    I get this error

     

    Error: Runtime instance with ID: 50171 not found



  • 3.  Re: Rest api processinstances doesn't show instances started by all user
    Best Answer

    Broadcom Employee
    Posted Jan 16, 2018 01:57 PM

    Thanks Marcel, can one or both of you open a support case so we can get this to the SE team for attention?



  • 4.  Re: Rest api processinstances doesn't show instances started by all user

    Posted Jan 17, 2018 05:05 AM

    Ok Michael, I'm going to open a support case.



  • 5.  Re: Rest api processinstances doesn't show instances started by all user

    Posted Jan 17, 2018 05:10 AM

    Thanks for your answer Marcel !