Continuous Delivery Automation

Expand all | Collapse all

Agent to Agent file transfer

  • 1.  Agent to Agent file transfer

    Posted 06-14-2018 05:18 PM

    I'm trying to transfer couple of files from Linux server(Agent Version 12) to windows server(Agent version 11). I'm using out of box action PCK.AUTOMIC_AGENT_2_AGENT.PUB to perform this action. I'm getting bellow error

     

    2018-06-14 14:15:32 - Selection started with filter '/path/to/files/*' ... 2018-06-14 14:15:32 - Files selected: '1'. 2018-06-14 14:15:32 - ERROR '0' bytes, incorrect transfer of '0' records for file '/path/to/files/*'->' <name not yet determined>'. Duration  '00:00:00'.2018-06-14 14:15:32 - FT '5683282': Cannot open file 'http:///path/to/files/*'. Error: 'errno 2, No such file or directory'. 2018-06-14 14:15:32 - FT '5683282': FileTransfer ended abnormally.

    Note: Linux server has Agent version of 12 and Windows server has Agent server version of 11.

    When i tried to transfer files from same windows server to the same Linux server which i mentioned above using same action Agent to Agent transfer it is succeeding. But vice-versa is failing.


  • 2.  Re: Agent to Agent file transfer

    Posted 06-18-2018 12:18 PM

    Hi Nikhilesh.Dasari,

     

    I tried that on my system and don't appear to run into that error but for mine all my agent are on the same major version.

     

    For your error, as you mention when you are transferring from:

    Linux(v12) -->Window (v11) = Not Working

    Window (v11) --> Linux (v12) = Working

     

    Part of me wonder the fact that its going higher to a lower version, that lower agent is not compatible?  Do you have a v12 agent on that window box to do a try/test?



  • 3.  Re: Agent to Agent file transfer

    Posted 06-18-2018 12:23 PM

    Hello Luu,

     

    Unfortunately we dont have v12 on that windows box. 



  • 4.  Re: Agent to Agent file transfer

    Posted 06-22-2018 06:36 PM

    Hi Nikhilesh.Dasari,

     

    I tried installing the older agent in one of my test system and I was able to get error when transferring from the higher to lower version.

     

    I would imagine something might of changed so going from higher to lower... the lower version is just not compatibility interpreting in how the v12 is sending? 

     

    If possible try to find a system in which you have a window v12 -->unix v12  (or on that system that you have the v11, spin up another agent that v12 and try the transfer... if you can repo the issues even after agent are on version and you still have the issues)... I would recommend opening a case with support (as they can take a closer look with your logs to determine the cause).