Layer7 API Management

Expand all | Collapse all

Unable to install OTK toolkit 4.3.00 CR01 on our Gateway 9.3.00 CR02.

Jump to Best Answer
  • 1.  Unable to install OTK toolkit 4.3.00 CR01 on our Gateway 9.3.00 CR02.

    Posted 04-10-2019 08:34 AM

    Dear CA API Gateway friends,

     

    I am unable to install OTK toolkit 4.3.00 CR01 on our Gateway 9.3.00 CR02.

     

    I get a resolution conflict on v2GenerateAuthHeaderForClient with

    '.. This mapping requires the property 'SK_AllowMappingOverride' be set to true ...' .


    This is exactly like this KB artikle:

    https://comm.support.ca.com/kb/solution-kit-install-error-this-mapping-requires-the-property-skallowmappingoverride-be-set-to-true-by-the-skar-file-author/kb000004392

     

    I increased the max_allowed_packet from 32M to 200M !

    (via /etc/my.cnf, I also see it listed in MySQL with show variables.. max_allowed_packet = 209715200).

    I rebooted mysql and ssg services, tried again to install the OTK, and still fails at same conflict.

     

    What to do?

    I see there is also a 'maxHttpHeaderSize=16000' on some of the listening ports can this be the issue??

     

    Regards,

     

    Ton



  • 2.  Re: Unable to install OTK toolkit 4.3.00 CR01 on our Gateway 9.3.00 CR02.
    Best Answer

    Posted 04-10-2019 09:12 AM

    I solved this issue..

     

    To be able to upgrade from our old OTK 2.1.2 and keep the old policies/assertions as a reference, I renamed the OAuth 2.0 folder to 'OLD OAuth 2.0' and disabled all services.


    In this old folder I also found a 'OAuthClients/v2GenerateAuthHeaderForClient' policy.
    After renaming this policy to 'OAuthClients/v2GenerateAuthHeaderForClient_OLD' I could install the OTK.

     

    Regards,

     

    Ton