AppWorx, Dollar Universe and Sysload Community

Upgrading AIX : Sysload binaries not compliant with this operating system

  • 1.  Upgrading AIX : Sysload binaries not compliant with this operating system

    Posted 01-03-2018 05:14 AM
    After upgrading a server AIX 6.1 to AIX 7.x, the Sysload agent for Unix no longer starts.

    The following message appears in the Collector logs: [coll] ERROR : Sysload binaries not compliant with this operating system

     

    ==================================================================================  === Stop Sysload Agent v5.80 Thu Nov 23 15:27:21 2017  === by process 7340076 (explsld, 58)  === (S35A6164) - Build date:  Nov 25 2014 - 15:20:44  === Build : Nov 25 2014 15:20:44 139  === Host  : AIX HOSTNAME 1 6 00CA3D774C00   ================================================================================== ==================================================================================  === Start Sysload Agent v5.80 Thu Nov 23 18:56:04 2017  === process 7405638 (explsld, 58)  === (S35A6164) - Build date:  Nov 25 2014 - 15:20:44  === Build : Nov 25 2014 15:20:44 139 === Host  : AIX HOSTNAME 1 7 00CA3D774C00 ================================================================================== DD MM HH:MM:SS YYYY: [coll] EventMgr version               : EventMgr 1.0 Oct 15 2014 18:25:01 aix61 DD MM HH:MM:SS YYYY: [coll] LBtree version                 : LBtreeFile 1.0 Oct  6 2014 11:48:20 aix61 DD MM HH:MM:SS YYYY: [coll] LGenBase version               : LGenBase 1.0 Nov 20 2014 16:31:01 aix61 DD MM HH:MM:SS YYYY: [coll] LGenCnxMgr version             : LGenCnxMgr 1.0 Oct  3 2014 13:26:36 aix61 DD MM HH:MM:SS YYYY: [coll] LGenComm version               : LGenComm 1.0 Oct  3 2014 13:26:39 aix61 DD MM HH:MM:SS YYYY: [coll] LGenContainers version         : LGenContainers 1.0 Oct  3 2014 13:26:42 aix61 ... DD MM HH:MM:SS YYYY: [coll] LSldSysAgtReactions version    : LSldSysAgtReactions 1.00 Oct  6 2014 19:05:20 aix61 DD MM HH:MM:SS YYYY: [coll] LTpTopList version             : LTpTopList 1.0 Oct  3 2014 16:52:00 aix61 DD MM HH:MM:SS YYYY: [coll] LXml version                   : LXml 1.0 Oct  3 2014 14:01:10 aix61 DD MM HH:MM:SS YYYY: [coll] INFO : REAL-TIME collect defined by user (1) DD MM HH:MM:SS YYYY: [coll] CFG INFO : parameter nice_value(-20) set by user  DD MM HH:MM:SS YYYY: [coll] CFG INFO : keyword set by user 'VreqStackSizeInBytes=4000000' DD MM HH:MM:SS YYYY: [coll] INFO : Activity history enabled by user for Short Term History. DD MM HH:MM:SS YYYY: [coll] INFO : Processes history enabled by user for Short Term History.  DD MM HH:MM:SS YYYY: [coll] INFO : Short Term History enabled (Activity: 1, Processes: 1, period=60 secs.)  DD MM HH:MM:SS YYYY: [coll] WARNING : Can't change process priority errno(13) DD MM HH:MM:SS YYYY: [coll] INFO : process priority = 0 DD MM HH:MM:SS YYYY: [coll] ERROR : Sysload binaries not compliant with this operating system 

    We note in the Collector's log that the agent was compiled for an AIX 6.1 (EventMgr 1.0 Oct 15 2014 18:25:01 aix61 90)

    1. Stop the agent (Collector + File Server)
    2. Install the Agent for Unix compiled for AIX 7.1
    3. ./setup -task patch
    4. Start the agent (File Server + Collector)