AppWorx, Dollar Universe and Sysload Community

Expand all | Collapse all

[Solved] Sysload Oracle Collector service won't work

  • 1.  [Solved] Sysload Oracle Collector service won't work

    Posted 10-21-2020 01:21 PM
    Hi,
    I can't launch my Oracle Collector service, neither by services.msc or C:\...\sldord\sldord.exe -start.
    For services.msc it returns me an error : 1067, the process stopped unexpectedly.

    I tried to attach my logs but i can't (Error [b]You aren't permitted to upload this kind of file) [/b]

    Thanks,
    Best regards.

    Robinson Graas.


  • 2.  [Solved] Sysload Oracle Collector service won't work

    Posted 01-28-2013 08:08 AM
    Hello Robinson,

    For any new topic, always provide your OS and product(s) version.

    Has your Oracle Collector service ever worked before or is it the first time you are trying to start it?

    You cannot attach .exe files on the forum; you can put it in a .zip file in order to upload it.

    Octavie


  • 3.  [Solved] Sysload Oracle Collector service won't work

    Posted 01-28-2013 08:22 AM
      |   view attached
    Hi Octavie,

    Thanks for your answer.
    Sorry, I thought my product version I filled in my profile show up on the post... nvm.  Here it is : 5.32 (Build 96)

    Yes, it worked before, this happens when one of our clusters of VMs went down, and when we restarted Sysload, many servers were not monitoring anymore.
    My monitoring on Windows servers is fine, it's just with Oracle DB.

    Logs attached in zip (I only put the logs of today, but if you want I can give you the whole 8mo file) /smile.png' class='bbc_emoticon' alt=':)' />

    Best regards.
    Robinson Graas.

    Edit : In my memories, we always have issues with the service, but don't know why and how, it worked before.

    Attachment(s)

    zip
    sldord.zip   2 KB 1 version


  • 4.  [Solved] Sysload Oracle Collector service won't work

    Posted 01-28-2013 10:50 AM
    Robinson,

    Could you please perform the following actions:
    1- check if the port 9503 is not used
    2- try to start the agent with the following command: [b][i]sldord.exe –start @#@[/i][/b]
    3- send us the resulting log

    Octavie


  • 5.  [Solved] Sysload Oracle Collector service won't work

    Posted 01-29-2013 02:39 AM
    Hi,

    Here it is :

    sldord.exe -start @#@ :
    [CODE]
    --> [SLDrm] - coll : szDir = 'C:\Program Files\Sysload\sldord\'
    coll : dwOSVersionInfoSize = 148
    coll : dwMajorVersion = 5
    coll : dwMinorVersion = 2
    coll : dwBuildNumber = 3790
    coll : dwPlatformId = 2
    coll : szCSDVersion = Service Pack 2
    --> [SLDrm] - coll : szVer5 O10NT
    --> [SLDrm] - coll : version OS O10NT502
    --> [SLDrm] - coll : Call cnbi-dbagtin
    --> [SLDrm] - coll : iNbInst=13 iNbAgent=13
    --> [SLDrm] - coll : Call fnInitAlloc
    --> [SLDrm] - coll : Call cfgc_dbagtin
    --> [SLDrm] - coll : (GetCfg) network param
    ==> Agent Sysload-Oracle v5.30 start on Tue Jan 29 08:40:17
    [/CODE]

    So it shows up at started, but still down in Windows services...

    sldord.log :
    [CODE]

    ==================================================================================
    === Start Sysload-Oracle Agent v5.30 Tue Jan 29 08:41:32 2013
    === by : process 580
    === (O10NT ) - Build date : Feb 8 2010 - 20:06:36
    === Build : Feb 8 2010 20:06:36 5
    === Host : SYSLOAD Windows5.2 5 2 i686
    ==================================================================================
    Tue Jan 29 08:41:32 2013: coll -
    Tue Jan 29 08:41:32 2013: coll - . LGenBase version           : LGenBase 1.0 Nov 20 2009 16:33:23 nt 38
    Tue Jan 29 08:41:32 2013: coll - . LGenComm version           : LGenComm 1.0 Nov 20 2009 16:38:52 nt 14
    Tue Jan 29 08:41:32 2013: coll - . LGenContainers version      : LGenContainers 1.0 Nov 20 2009 16:35:40 nt 17
    Tue Jan 29 08:41:32 2013: coll - . LGenMisc version           : LGenMisc 1.0 Nov 20 2009 16:37:56 nt 28
    Tue Jan 29 08:41:32 2013: coll - . LGenSocket version           : LGenSocket 1.0 Nov 20 2009 16:36:51 nt 19
    Tue Jan 29 08:41:32 2013: coll - . LSldAgentTrap version      : LSldAgentTrap 1.0 Nov 23 2009 12:13:57 nt 9
    Tue Jan 29 08:41:32 2013: coll - . LSnmp version                : LSnmp 1.0 Nov 23 2009 10:10:47 nt 9
    Tue Jan 29 08:41:32 2013: coll -
    Tue Jan 29 08:41:32 2013: coll - . LLicenseClient version      : LLicenseClient 1.0 Nov 19 2009 17:35:09 nt 10
    Tue Jan 29 08:41:32 2013: coll -
    Tue Jan 29 08:41:32 2013: coll - . LEventMgr version           : EventMgr 1.0 Jan 27 2010 13:29:20 nt 39
    Tue Jan 29 08:41:32 2013: coll -
    Tue Jan 29 08:41:32 2013: coll - . LPmPurgeManager version      : LPmPurgeManager 1.0 Jan 15 2010 12:59:03 nt 5
    Tue Jan 29 08:41:32 2013: coll -
    Tue Jan 29 08:41:32 2013: coll - . LOrclOci version           : LOrclOci 5.30 Feb 8 2010 19:54:06 nt 4
    Tue Jan 29 08:41:32 2013: coll - . OCI version                     : 8
    Tue Jan 29 08:41:32 2013: coll - . Oracle client major version : 10g
    Tue Jan 29 08:41:32 2013: coll - . LUname                          : SYSLOAD Windows5.2 5 2 i686
    Tue Jan 29 08:41:32 2013: coll -
    Tue Jan 29 08:41:36 2013: Evt - 'PFSCAPE' *** Client not responding: 'Management Server' Pid=1400 'sysload' (130.1.0.43:1027)
    [/CODE]

    Thanks you in advance,
    Robinson Graas.

    [color=#00ff00]EDIT : Oh, it seems to be working on my monitoring screen, I don't know why, but it happens after the sldord.exe -start @#@ !
    Windows service still down, but it's working /wink.png' class='bbc_emoticon' alt=';)' /> Thanks Octavie, but still a bit worry about this issue.[/color]


  • 6.  [Solved] Sysload Oracle Collector service won't work

    Posted 01-30-2013 10:30 AM
    Hi Robinson,

    Could you stop both processes [b][i]sldord.exe[/i][/b] & [b][i]sldorhst.exe[/i][/b] manually, then make sure that the socket used by the agent listener is not in use ([i]netstat –av|find "9503"[/i]).
    Then, try and restart the agent through the Windows services panel.


    Yann


  • 7.  [Solved] Sysload Oracle Collector service won't work

    Posted 01-31-2013 02:35 AM
    Hi Yann,

    I have stop both sldord.exe and sldorshst.exe, check if something was listening on 9503 port (nothing was there), then restart Oracle Collector Service, and it worked on first try /smile.png' class='bbc_emoticon' alt=':)' />
    I never used to stop sldorhst.exe with sldord.exe, that's maybe why... ?

    Thanks Yann,
    Robinson.


  • 8.  [Solved] Sysload Oracle Collector service won't work

    Posted 01-31-2013 10:49 AM
    Indeed, the[font="helvetica, arial, sans-serif"][color="#666666"] "sldorhst.exe" process was most likely not properly stopped, therefore the socket was still being used. Which explains why the service could not be started.[/color][/font]