View Only
  • 1.  vSphere Read Cache - no disk is found

    Posted Dec 02, 2013 04:25 PM

    Hi all,

    ESXi 5.5 ent+

    HP BL460c Gen8 with P220i array controller

    Intel SSD DC S3700 200 GB (Intel disk is supported, also tried with Samsung 960 GB SSD)

    I have a problem with adding a SSD disk in web client. I click Manage - Settings - Virtual Flash Resource Management - Add capacity, but the list i empty.

    Both disks are visible if looking on storage adapters, it is fully possible to add them as a datastore, which I tried on the Samsung without any success.

    The disks have been used for PernixData evaluation and worked well there.

    Any suggestions?


  • 2.  RE: vSphere Read Cache - no disk is found

    Posted Dec 02, 2013 05:21 PM

    I think Pernix has already put a partition on the disks, and since vFRC uses a dedicated filesystem, it might not able to detect this disk as usable. Perhaps you can use some kind of partition tool (gParted, for example), you might be able to remove the current partition layout and try it again.

  • 3.  RE: vSphere Read Cache - no disk is found
    Best Answer

    Posted Dec 04, 2013 03:46 PM

    Found the issue: The drive was marked as not local. Also it may be that the drive is not flagged as an SSD (not in my case though).

    ~ # esxcli storage core device list -d naa.600508b1001c4fb788c917f46bf2a2f5

       Display Name: HP Serial Attached SCSI Disk (naa.600508b1001c4fb788c917f46bf2a2f5)

       Has Settable Display Name: true

       Size: 915683

       Device Type: Direct-Access

       Multipath Plugin: NMP

       Devfs Path: /vmfs/devices/disks/naa.600508b1001c4fb788c917f46bf2a2f5

       Vendor: HP

       Model: LOGICAL VOLUME

       Revision: 4.68

       SCSI Level: 5

       Is Pseudo: false

       Status: degraded

       Is RDM Capable: true

       Is Local: false

       Is Removable: false

       Is SSD: true

       Is Offline: false

       Is Perennially Reserved: false

       Queue Full Sample Size: 0

       Queue Full Threshold: 0

       Thin Provisioning Status: unknown

       Attached Filters:

       VAAI Status: unknown

       Other UIDs: vml.0200010000600508b1001c4fb788c917f46bf2a2f54c4f47494341

       Is Local SAS Device: false

       Is Boot USB Device: false

       No of outstanding IOs with competing worlds: 32

    In order to mark it as local I ran this command (note that the syntax of option sub-command is wrong in the documentation, I posted the correct one):

    esxcli storage nmp satp rule add -s VMW_SATP_LOCAL --device naa.600508b1001c277a2d4d5e0285b4f6db --option="enable_local"

    After a reboot it was possible to add the drive as flash device.


  • 4.  RE: vSphere Read Cache - no disk is found

    Posted Feb 22, 2014 08:56 AM

    Just unclaim and claiming the device should make non-local to local. Instead reboot. But there should not be any active local locks in the device.