ESXi

 View Only
Expand all | Collapse all

vSphere Client does not connect to any host or vCenter anymore

  • 1.  vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 13, 2014 03:00 PM

    Hi,

    I have a very strange problem. My vSphere Client does not connect to any vCenter or single host. It happens from one day to another, without any significant changes on my client computer.

    The client onyl shows since hours "Connecting..." without any error or time-out.

    I tried to uninstall the vSphere Client, including the "Microsoft Visual J# Redistributable Package - SE (x64)" and installing again in different versions. I disabled local virus scanner and firewall. Nothing helped.

    Has anyone an idea how to troubleshoot or what can I do? I´am very frustrated.

    Cheers, Tom



  • 2.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 13, 2014 03:23 PM

    please refer logs.

    \vpx directory in the Application Data directory on the vSphere Client machine.

    Pre-Windows 2008 example: C:\Documents and Settings\user_name\Local Settings\Application Data\VMware\vpx\viclient-x.log

    Windows 2008 and Window 7 example: C:\Users\user_name\Local Settings\AppData\Local\VMware\vpx\viclient-x.log

    x(=0, 1, ... 9)Below link gives more deatils about the viclient log. Also share the screenshot of the error if you are getting any. VMware vSphere 5.1



  • 3.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 13, 2014 03:29 PM

    Hi, thank you for your reply.

    This it my latest log:

    [    :startup :W: 1] 2014-10-13 17:27:41.697  Log for vSphere Client Launcher, pid=6520, version=5.5.0, build=build-1993072, option=release
    [    :Error   :W: 1] 2014-10-13 17:27:41.732  System.UnauthorizedAccessException: Es wurde versucht, einen nicht autorisierten Vorgang auszuführen.

       bei Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)

       bei Microsoft.Win32.RegistryKey.SetValue(String name, Object value, RegistryValueKind valueKind)

       bei Microsoft.Win32.RegistryKey.SetValue(String name, Object value)

       bei VpxClient.Program.RegisterClientMimeExtension()

    What tells me the log?



  • 4.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 13, 2014 03:28 PM

    When you see this problem, test the connectivity to vCenter with Telnet by connecting to port 443, you should get a response. If there's no response, something else is using the port already or it is blocked.

    Also test connectivity to the ESXi host by telnting to port 902, you should get a response. You should get a response, if there's no response, the port is block in your network.

    Testing port connectivity with Telnet

    http://kb.vmware.com/kb/1003487


    TCP and UDP Ports required to access VMware vCenter Server, VMware ESXi and ESX hosts, and other network components

    http://kb.vmware.com/kb/1012382


    Port 902 is required to connect to the ESXi hosts and 443 to connect to vCenter. Disable the firewall and AV on the vCenter server and test again. Also when you notice these problems, test the client connectivity at the vCenter, if all works well, the problem is network related between the workstation and the hosts/vCenter.



  • 5.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 13, 2014 03:31 PM

    This I have checked. Telnet works on all ports.



  • 6.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 13, 2014 03:34 PM

    When yous notice the issue at your workstation, does it work at the vCenter. You will need to RDP to VC and test there.



  • 7.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 13, 2014 05:14 PM

    It works on each workstation, everywhere in our company network, except on my client.

    I have posted the .net client log ... can anybody read something from that?



  • 8.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 07:35 AM

    Install below hotfix on problematic server from where vSphere client is not working - In my case these are Windows XP and 2003 Servers


    http://support.microsoft.com/kb/948963



  • 9.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 08:28 AM

    I have Windows 7 SP1 ... trying to install this hotfix will cause an error. :smileysad:



  • 10.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 10:25 AM

    I had faced the same issued, finally I removed recently updated few of windows hot fixes from the client system and restart client system.

    after this process, it is working fine.



  • 11.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 10:39 AM

    I uninstalled each hotfix from microsoft wich was younger than 2 weeks, so I don´t have any microsoft patch from october.

    But it does not help. :smileysad:



  • 12.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 10:55 AM

    Let us try to gather more details about the scenario:

    1)     vCenter and ESXi versions along with build number

    2)     Any recent upgrades performed for vCenter server?

    3)     Which version of vSphere client that installed on Windows 7 machine?

    4)     Have you tried removing all the vSphere clients and then install fresh client from vCenter?

            https://vcenter.fqdn.name   -  open it in browser and download the vSphere client

    5)     I assume your Windows 7 met pre-requisites as mentioned below

           http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1037552

    6)     Is the Windows 7 machine is VDI or Laptop?

    7)     Any issues while accessing via Web Client?  (if you are using vSphere 5.x)

    8)     Finally communication issues between Windows 7 and vCenter server (depends on Network setup of your Customer)

       

            Confirm that two way communication is fine including port numbers (ping, tracert, telnet ... etc)

            Software version compatibility (as per point 5)

    Hope this information will help you to fix client issue.



  • 13.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 12:38 PM

    Let us try to gather more details about the scenario:

    1)     vCenter and ESXi versions along with build number

           - we have 3 different vCenter, from 5.1 to 5.5 U2; ESXi 5.5.0 Build 2068190 (on the vCenter 5.5. U2) ...but it´s not the vCenter, it´s my Client who causes the problem, because I can connect from any computer or VM to each of our vCenter and Hosts

    2)     Any recent upgrades performed for vCenter server?

          - no

    3)     Which version of vSphere client that installed on Windows 7 machine?

            -vSphere Client 5.5.0 1993072

    4)     Have you tried removing all the vSphere clients and then install fresh client from vCenter?

            https://vcenter.fqdn.name   -  open it in browser and download the vSphere client

           - yes, by now 5 times

    5)     I assume your Windows 7 met pre-requisites as mentioned below

           http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1037552

            - yes, it worked the last 2 years

    6)     Is the Windows 7 machine is VDI or Laptop?

            - Laptop

    7)     Any issues while accessing via Web Client?  (if you are using vSphere 5.x)

           - no issues

    8)     Finally communication issues between Windows 7 and vCenter server (depends on Network setup of your Customer)

            Ports - telnet:

              80 - yes

              8080 - yes

              443 - yes

              902 - yes (to ESXi)

              8443 - yes

              9443 - yes

              10080 - yes

              10443 - yes

      

    In conclusion: all requirements fulfilled but no working vSphere Client :smileysad:

    EDIT: pinging the hosts or vCenter works without a problem.



  • 14.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 12:40 PM

    Same problem here.

    The VMs work great, but I can not access the ESXi host.

    The first ping work, but not the next.

    From other host I can connect by SSH without erros.

    vpx log show:

    [    :startup :W: 1] 2014-10-14 09:32:56.946  Log for vSphere Client Launcher, pid=6036, version=5.1.0, build=build-786111, option=release
    [    :Error   :W: 1] 2014-10-14 09:32:56.994  System.UnauthorizedAccessException: Tentativa de execução de uma operação não autorizada.

    I can not find the cause!



  • 15.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 08:43 PM

    Is your workstation in the same segment as the vCenter and the ESXi hosts? Disable the Windows Firewall on the vCenter server if you are using Windows. Also check on AV and for testing purposes, disable it for the time being and update the results.



  • 16.  RE: vSphere Client does not connect to any host or vCenter anymore

    Posted Oct 14, 2014 09:11 PM

    Firewall and antivirus are disabled or uninstalled.