ESXi

 View Only
  • 1.  vSphere 6 Client Search Error

    Posted Mar 19, 2015 10:55 PM

    Recently upgrade our vCenter from 5.5 to 6. Everything seems to work great except for the search feature in the vSphere C# client.  I get the following error.

    Login to the query service failed. The server could not interpret the communication from the client. (The remote server returned an error: (500) Internal Server Error.)

    When using the web client the search feature works and I can search VMs and hosts.  Another thing that I noticed is that prior to the upgrade I access the web client through the following address:

    https://vcenterserver:9443

    After the upgrade the web client link on the vcenter homepage (http://vcenterserver)  takes me to the web client login page that uses port 443 instead which throws a bunch of error messages when I log in. But if I use port 9443 everything works fine.  I'm not sure if this is related to the search issue I'm having.

    Any help would be appreciated.



  • 2.  RE: vSphere 6 Client Search Error
    Best Answer

    Posted Mar 20, 2015 05:49 AM

    Are you using "Use Windows Session Credentials" option when logging in with vSphere Client?

    Are you using vCenter Server Appliance or Windows version?

    I think VCVA 5.5 has known issue what search function does not work when you log in with "Use Windows Session Credentials" option, but it does work when you type in your account and password. This is known issue but I cannot remember KB article number describing this. I do not know if this applies with VCVA 6.0 but could be.



  • 3.  RE: vSphere 6 Client Search Error

    Broadcom Employee
    Posted Mar 20, 2015 08:14 AM

    Can you please try to login VI client using vCenter administrator user without selecting "Windows Integrated Authentication" checkbox and do the inventory search ?

    You can use following knowledge base article and try to solve the problem .

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2063020

    BTW, can you please elaborate the problem you faced with web client login ? Error screenshot or log file will be very helpful.




    Regards




  • 4.  RE: vSphere 6 Client Search Error

    Posted Mar 20, 2015 02:02 PM

    Thanks guys! That's exactly what it was.



  • 5.  RE: vSphere 6 Client Search Error

    Posted Sep 15, 2015 10:18 AM

    Hi,

    the problem still exists with Update 1. I have the Windows version in use. Are there perhaps more information for a fix?

    thanks, regards



  • 6.  RE: vSphere 6 Client Search Error

    Posted Mar 01, 2016 05:51 PM

    Hoping this will be fixed with Update 2 this month..



  • 7.  RE: vSphere 6 Client Search Error

    Posted Apr 14, 2016 05:55 PM

    Hi guys,
    the problem still exists with Update 2. :smileyangry:
    It was not this time, Bleeder‌.


    the solution is still clear the check box "Use Windows session credentials". Following guidelines KB 2063020.
    regards.



  • 8.  RE: vSphere 6 Client Search Error

    Posted Aug 10, 2016 09:22 AM

    Hi,

    there is a vmware kb on this topic ( kb2143566 )

    Unfortunately the kb is clear ... "This is an expected behavior"

    isn't a bug, then no fix

    scanda