vSAN1

 View Only
Expand all | Collapse all

VSAN Build Recommendation Engine Proxy settings.

  • 1.  VSAN Build Recommendation Engine Proxy settings.

    Posted Aug 15, 2017 04:36 PM

    HI all.

    I am here trying to use VSAN Build Recommendation Engine Health thing. It asks for my.vmware.com credentials, but after providing those it fails to connect.

    I think problem is that vCenter is behind a proxy and this tool is not picking up proxy setting configured on vCenter or in VSAN health plugin. I have proxy also configured on Update manager still no luck.

    I know this because i was monitoring proxy log, and there is no requests coming from vCenter when i click Login.

    Can someone confirm or deny, this theory? Or may be someone know how to configure proxy for this thing.

    btw, also tried RVC. no luck. Here is what i got:

    > vsan.login_iso_depot -u USER -p PASS

    2017-08-15 16:20:37 +0000: Login to VMware ISO Depot using my.vmware.com credentials

    2017-08-15 16:20:37 +0000: Note: vCenter needs to have access to depot.vmware.com.

    2017-08-15 16:22:44 +0000: Failed to save cookie of depot.vmware.com.

    Error: Incorrect my.vmware.com login credential.

    and here is what i see in Web client:

    I am running vSphere 6.5u1. vCenter Appliance with an External PSC.

    Thanks in advance.



  • 2.  RE: VSAN Build Recommendation Engine Proxy settings.

    Broadcom Employee
    Posted Aug 17, 2017 04:23 PM

    Hi Aram,

    Saw your message on vE Slack.

    First thing I would try is logging in directly to my.vmware.com via browser to rule out locked account or bad password... if you have not done so yet.

    Are you able to download the latest version of HCL DB from vCenter using "Get latest version online" button?

    In case you haven't seen this KB, here are some troubleshooting steps from KB2150914

    The following issues might be detected by this check.

    • Internet access is unavailable.
      Check and restore Internet connectivity to ensure that release metadata and VMware compatibility information can be updated correctly.
    • vSphere Update Manager is disabled or is not installed.
      Make sure that Update Manager is installed, enabled, and available.
    • vSphere Update Manager (VUM) is not responsive.
      Make sure that the Update Manager is enabled and available.
    • vSAN release metadata is outdated.
      This warning can occur if the vSAN build recommendation engine has lost internet connectivity for an extended time. Check and restore Internet connectivity to refresh the release metadata.
    • my.vmware.com login credentials are not set.
      Log in to my.vmware.com with proper credentials, through the vSphere client or RVC. vSAN system baselines are generated after a few minutes.
    • my.vmware.com authentication failed.
      Log in to my.vmware.com with proper credentials, through the vSphere client or RVC. vSAN system baselines are generated after a few minutes, if necessary.
    • Unexpected vSphere Update Manager (VUM) baseline creation failure.
      Check vsan-health log to view detailed error information.


  • 3.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Aug 18, 2017 07:35 AM

    Hi Dave,

    Thanks for the reply.

    Tried all of that.

    Here is what i can.

    1 I can access and download latest ACL, no problem(Proxy settings in vsan config)

    2. vCenter can access Vapp-Repo and check for Appliance updates.(proxy settings in VCA, and even edited proxy config file to enabled https, proxy)

    3. Update manager can access and download updates(Proxy settings in update manager)

    4. My my.vmware.com account is not locked, using it every day, and checked it several times.

    This has to be some kind of BUG, or i am getting crazy....

    Technically i could open a ticket, but this is a lab environment and i would not want to waste time of VMware support, especially if this is something simple.

    Any other ideas are very welcome.

    Regards.



  • 4.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Sep 01, 2017 02:49 AM

    Were you able to find a resolution to this issue?  I'm seeing the same in my environment.



  • 5.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Sep 05, 2017 10:20 AM

    Nope, not yet.

    I assume this is a bug, there is nothin else i can check.

    Will have to wait for a patch.

    Regards,

    Aram



  • 6.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Sep 22, 2017 02:39 AM

    Hi AramAvetisyan​,

    I have similar issue at the moment with vSAN 6.6.1 behind the proxy.

    It might be related to a bug in the previous version of vSAN when online check of vSAN health was generating an error message as follows:

    The latter is a well-known bug (no KB though) that VMware is working on to resolve.

    Regards,



  • 7.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Sep 22, 2017 08:34 AM

    It looks like a bug yes.

    Lets hope it will be fixed soon.

    Unfortunately i cannot open ticket to VMware to ask for more details, as i face this issue on one of my labs.

    If anyone of you guys can open ticket, i would appreciate. It would be good to see an official statement form VMware.



  • 8.  RE: VSAN Build Recommendation Engine Proxy settings.

    Broadcom Employee
    Posted Sep 26, 2017 09:34 PM

    There's a kb live now that confirms it's a known issue with no workaround currently.

    vSAN Build Recommendation Engine Health fails (2151692) | VMware KB

    Cheers

    Brian



  • 9.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Sep 27, 2017 12:12 AM

    Hi broreg​,

    Thank you for providing this link.

    In a conversation with VMware GSS about a week ago, they promissed me to publish a KB about this issue. Looks like they keep their promiss. Well done!



  • 10.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Feb 07, 2018 12:36 PM

    Hi All,

    I have just found a workable solution to this issue - https://virtualnomadblog.com/2018/02/07/vsan-6-6-1-vsan-build-recommendation-engine-health-issue-resolved/ .

    It would be great if you could test it as well and let me know.

    Regards,



  • 11.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Feb 19, 2018 06:25 PM

    any ideas about this solution for someone not using a proxy for just a lab environment? Same issue seen but i don't have any proxy changes since I don't have a proxy.



  • 12.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Feb 19, 2018 10:04 PM

    Hi gpn001​,

    Interesting case. What is the version of VCSA you're running on? I was able to resolve all issues only after updating to 6.5 U1e.

    Also, can you check the following:

    • Appliance can resolve DNS names outside your local network (for example, www.vmware.com),
    • You can download from the Internet using wget utility,
    • HCL Database updates correctly - Cluster_Name>Configure>vSAN>Health and Performance>HCL Database,
    • CEIP is enabled - Administration>Deployment>Customer Experience Improvement Program>Customer Experience Improvement Program>Enabled,
    • You have a valid account on 'My VMware' with the current subscription.

    If all those settings are fine, please reboot the appliance and chech the status of vSAN Build Recommendation Engine Health.

    Regards,



  • 13.  RE: VSAN Build Recommendation Engine Proxy settings.

    Posted Feb 23, 2018 12:34 AM

    Hi gpn001​,

    There is one more article that might help you to trobbleshoot connectivity isssue - Storage and Availability Technical Documents .

    Regards,