View Only
  • 1.  vSAN and MTU

    Posted Jun 22, 2017 01:47 PM


    I think I am lost. First of all I have correctly set up vSAN. And it was working. I have installed on it some VMs everything was fine until I checked ->  Hosts and Clusters -> Monitor -> Virtual San

    Then Under Network it says MTU check (ping with large packet size) this is red

    I searched the internet and it was saying to increase to 9000 the MTU mine was 1500.

    vCenter is running on vSAN (3 hosts cluster). From vSphere Web Client I am changing the MTU from 1500 to 9000 to the first host and the vCenter was not responding. I could do nothing. Then I logged in from esxi host to the 3 hosts and increased in all of them the MTU at 9000. Then vCenter was not responding again so I tried: "fsck /dev/sda3" and then answered yes to all questions about repairs. Then I did

    shell.set --enabled true


    cd /bin
    service-control --stop --all

    service-control --start --all

    From console.

    Eventually I was able to log on now to vSphere Web client (vcenter) with some errors hear and there. Now the MTU is to 9000 the vSAN works (hopefully) but the MTU check is still red. Why? I am using a NETGEAR ProSAFE XS708E 8-Port 10G.

    Should I reinstall vCenter to avoid future problems? Because after typing fsck /dev/sda3 it finished with some errors.

    Thank you,


  • 2.  RE: vSAN and MTU

    Posted Jun 22, 2017 02:48 PM

    Have you checked if the switch can also support "Jumbo Packets" / MTU=9000 ?

    I haven't used those netgears, but I know the Cisco's need some extra configuration in there..

    So, basically, each host has a wider pipe, but does the switch in between them?

  • 3.  RE: vSAN and MTU

    Posted Jun 22, 2017 07:27 PM

    make sure each component (switch and NIC) is set to 9000, if any component is set to 1500 you will get a flag.

  • 4.  RE: vSAN and MTU

    Posted Jun 23, 2017 02:21 PM

    Hi, the MTU checks can sometimes give a false positive. Check this thread where it is discussed further: MTU Check warning

    You can verify that MTU works with vmkping and disable the MTU check to get green lights.


  • 5.  RE: vSAN and MTU

    Posted Jun 26, 2017 01:01 PM


    I it seems that I had a problem with my cable I think on third host. I have put a new cable and double checked the MTU it is 9000.

    Now I have something like:

    --- [IP OF THIRD HOST] ping statistics ---

    3 packets transmitted, 3 packets received, 0% packet loss

    round-trip min/avg/max = 0.386/0.469/0.571 ms

    [root@esxi-10:~] vmkping -s 8972 [IP OF SECOND HOST]

    PING [IP OF SECOND HOST] ([IP OF SECOND HOST]): 8972 data bytes

    8980 bytes from [IP OF SECOND HOST]: icmp_seq=0 ttl=64 time=0.449 ms

    8980 bytes from [IP OF SECOND HOST]: icmp_seq=1 ttl=64 time=0.271 ms

    8980 bytes from [IP OF SECOND HOST]: icmp_seq=2 ttl=64 time=0.479 ms

    So it looks good right? Shall I reset it to green? It is still red.

  • 6.  RE: vSAN and MTU

    Posted Jun 26, 2017 09:49 PM

    Ping with 1000 packets to analyze the average latency.

    I had the same issue and was related NIOC settings as had VSAN on a dedicated VDS with VSAN traffic set as 100 Shares with all others not in use and high latency on 9000 ping was seen. Amended share value for management to 25% on that switch and all was then ok.

  • 7.  RE: vSAN and MTU
    Best Answer

    Posted May 09, 2018 09:58 AM

    Kind of old post. But in case someone else come up with same issue. It was a firmware issue actually. Just be sure you have latest firmware of switch :smileywink: